Versioned server protocol

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
kephasp
Posts: 3
Joined: March 13th, 2020, 11:33 am

Versioned server protocol

Post by kephasp »

I recently tried playing in MP with friends and ran into the problem that one had diligently downloaded the latest version (1.14.11) while both of us had just installed the latest debian package (1.14.9). But currently, it's impossible to play together with different versions, although I suspect there aren't actual incompatibilities between such close versions.

I understand that asking for the same version is almost foolproof and very easy, but there could be a wire protocol between client and server that lets everyone discover if they can run compatibly (and even "dumb down" to the lowest common denominator).

gfgtdf
Developer
Posts: 1309
Joined: February 10th, 2013, 2:25 pm

Re: Versioned server protocol

Post by gfgtdf »

both 1.14.11 and 1.14.9 have no problems connecting to the current official stable wesnoth server.
Scenario with Robots SP scenario (1.11/1.12), allows you to build your units with components, PYR No preperation turn 1.12 mp-mod that allows you to select your units immideately after the game begins.


kephasp
Posts: 3
Joined: March 13th, 2020, 11:33 am

Re: Versioned server protocol

Post by kephasp »

But a 1.14.11 client displayed the error "you need 1.14.9,test to connect" and my 1.14.9 also displayed "you need 1.14.5,test to connect".

Are 1.14.11 → 1.14.9 and 1.14.9 → 1.14.5 really incompatible pairings? Or shouldn't a 1.14.* server send 1.14.* in the version list it accepts?

User avatar
Ravana
Forum Moderator
Posts: 2440
Joined: January 29th, 2012, 12:49 am
Location: Estonia
Contact:

Re: Versioned server protocol

Post by Ravana »

If you tried to connect to official server, you should post to technical support.

User avatar
Iris
Site Administrator
Posts: 6675
Joined: November 14th, 2006, 5:54 pm
Location: Chile
Contact:

Re: Versioned server protocol

Post by Iris »

I double-checked the configuration for the official server and the alternate server (server2) just to make sure. Both support all past, present and future 1.14.x releases.

Were you actually trying to play on those servers (Multiplayer → Join Official Server and Connect to Server, respectively) or were you trying to host/join a LAN game instead (Multiplayer → Host Networked Game)?

(I've moved this topic to Technical Support accordingly.)
Author of the unofficial UtBS sequels Invasion from the Unknown and After the Storm.

kephasp
Posts: 3
Joined: March 13th, 2020, 11:33 am

Re: Versioned server protocol

Post by kephasp »

Well, it may be a configuration issue, then. The default Debian install has no versions_accepted configuration.

Post Reply