How to set Video refresh rate at gamestartup

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
Henry

How to set Video refresh rate at gamestartup

Post by Henry » December 23rd, 2005, 9:20 pm

Hello all,

the game didn't start proper, because it set the video mode to a video mode not supported by my montior. I use an LCD at 60Hz and I don't know, how to tell this to the game at startup.

stderr.txt:
Battle for Wesnoth v1.1-svn
Started on Fri Dec 23 22:11:34 2005

started game: 0
Checking video mode: 1024x768x32...
32
setting mode to 1024x768x32
no valid cache found. Writing cache to 'C:/Programme/Wesnoth/userdata/cache/game.cfg-cache-v1.1-svn-MEDIUM-NORMAL'
locale could not be determined; defaulting to system locale
WARNING: setlocale() failed for .
started music
4599
showing title screen...
4599
Loading tips of day

stdout.txt is empty

ott
Inactive Developer
Posts: 838
Joined: September 28th, 2004, 10:20 am

Post by ott » December 28th, 2005, 3:33 pm

You could try using different bits per pixel, using a different resolution, or windowed mode. See http://www.wesnoth.org/wiki/WesnothMan for the manual page that details all the options.

Your video driver really should not advertise that it supports modes that your display can't handle -- if you have an old display you might be able to configure the driver accordingly.
This quote is not attributable to Antoine de Saint-Exupéry.

Post Reply