Shadows of Deception 0.5.3 [Wesnoth 1.12]

Discussion and development of scenarios and campaigns for the game.

Moderators: Forum Moderators, Developers

User avatar
vultraz
Community Manager
Posts: 958
Joined: February 7th, 2011, 12:51 pm
Location: Dodging Daleks

Re: NX-RPG/Revenge from the Shadows 0.2.9 [Wesnoth 1.9.10+]

Post by vultraz »

Version 0.3.0 is out!

Changelog:

Code: Select all

Version 0.3.0
-------------
* Scenarios
  * E1S1
    * Fixed some incorrect event filters
    * Fixed wrong side positions (for sides 2 and 3)
    * Fixed some grammar issues
    * Fixed possible bug where the gates might not be unlocked if both units were found
      before the lockpick
    * Fixed a bug that causes the locked gates to continuously respawn
    * Balancing: reduced enemy starting gold and keep size
  * E1S2
    * Fixed an 'unknown unit' error
    * Prevented the scenario from ending when all enemies are dead, but before the swarm

* Lua
  * Fixed a bug where it was possible to infinitely pick up an item with the quantity
    addition acting up each time
  * Fixed [unlock_gates] using the wrong SUF for the catch-all locked gated filter
  * GUI
    * Fixed a bug that appeared when opening the inventory when another allied hero unit
      was adjacent
    * Completed help dialog and added 2 topic for it (so far)

* Code
  * Made locked gates actually remove when killed
  * Made game scroll to and float some text over locked gates when they get unlocked
  * Fixed a bug where error appear when a unit who hadn't picked up an item killed
    an enemy unit

* Sound Effects
  * Added new thunder sounds, each with a near and far variation
  * Added two new wind sounds
  * Added three new rain variations - two for indoors (soft and loud) and one outdoors
    variation
Sorry for not getting this out earlier, I had been hoping to get another scenario done for this release, but that didn't work out, so hopefully there'll be in the next one. ;)

As you can see, this release if mostly about fixing some major bugs I wish I had caught in time for 0.2.9 (which was also largely a bugfix release...). Anyway, I *HOPE* scens 1 and 2 are now playable without bugs, and as I said I'll try to get a few more scenarios done for the next release :)

Thanks for playing.
Creator of Shadows of Deception (for 1.12) and co-creator of the Era of Chaos (for 1.12/1.13).
SurvivalXtreme rocks!!!
What happens when you get scared half to death...twice?

User avatar
vultraz
Community Manager
Posts: 958
Joined: February 7th, 2011, 12:51 pm
Location: Dodging Daleks

Re: NX-RPG/Revenge from the Shadows 0.2.9 [Wesnoth 1.9.10+]

Post by vultraz »

Happy New Year, everyone :)

Been forever since I worked on this. Not much done since the last release, except the completion of E1S3, which is in Wesnoth UMC-Dev trunk, but as yet, untested. I am beginning E1S4, but, as this is taking forever, I have henceforth decided to abandon support for 1.10 and below, and develop this on 1.11. This means that all future releases after 0.3.0, including svn versions, will not work in 1.10 and below.

Maybe this year I'll have time to work on this more. Probably not, since I anticipate I'll be busy this year, but who knows. ;)

Thanks again to whoever out there has played this.
Creator of Shadows of Deception (for 1.12) and co-creator of the Era of Chaos (for 1.12/1.13).
SurvivalXtreme rocks!!!
What happens when you get scared half to death...twice?

MR-Wose
Posts: 4
Joined: July 21st, 2013, 12:41 pm

Re: NX-RPG/Revenge from the Shadows 0.3.0 [Wesnoth 1.10]

Post by MR-Wose »

just some tips, i think the Level 3 spider in the beginning is quite hard to kill, it might just be bad luck to me but the first time he attacked me i was allmost dead.
the aithe skelletons in the beginning use attacks you once and then just stops attacking as if they are petrified.
in the character development screen when you select liminal as an Alignment the special abilities(like Heal+X and soul steal are not visible) i don't know if that is on purpose
en every turn i get a message in pink that "Rhyan has maximum mana"

User avatar
vultraz
Community Manager
Posts: 958
Joined: February 7th, 2011, 12:51 pm
Location: Dodging Daleks

Re: NX-RPG/Revenge from the Shadows 0.3.0 [Wesnoth 1.10]

Post by vultraz »

MR-Wose wrote:just some tips, i think the Level 3 spider in the beginning is quite hard to kill, it might just be bad luck to me but the first time he attacked me i was allmost dead.
the aithe skelletons in the beginning use attacks you once and then just stops attacking as if they are petrified.
in the character development screen when you select liminal as an Alignment the special abilities(like Heal+X and soul steal are not visible) i don't know if that is on purpose
en every turn i get a message in pink that "Rhyan has maximum mana"
Thanks for taking a look, but the version on the 1.10 addons server at the moment is very outdated. It's been a year since I released it, and since then, I have made major changes to the stories and scenarios. There was awhile where I stopped working on it, which is why it's been so long, but I'm getting stuff done now. You can download the development version here (for Wesnoth 1.11.5 onward), while I work on getting a new release out.
Creator of Shadows of Deception (for 1.12) and co-creator of the Era of Chaos (for 1.12/1.13).
SurvivalXtreme rocks!!!
What happens when you get scared half to death...twice?

lu_zero
Posts: 196
Joined: April 16th, 2005, 10:25 am

Re: NX-RPG/Revenge from the Shadows 0.3.0 [Wesnoth 1.10]

Post by lu_zero »

I tried to fetch from svn directly to the add-ons directory and it complained

20130730 04:14:12 error general: The following add-on had errors and could not be loaded:
/home/lu_zero/.local/share/wesnoth/1.11/data/add-ons/NX-RPG/_main.cfg
ERROR DETAILS:
Macro/file '~add-ons/NX-RPG/episode1/maps/00_01_Eclipse.map' is missing at ~add-ons/NX-RPG/episode1/scenarios/00_Descry.cfg:6 included from ~add-ons/NX-RPG/_main.cfg:80 included from ~add-ons/NX-RPG/_main.cfg:116

User avatar
vultraz
Community Manager
Posts: 958
Joined: February 7th, 2011, 12:51 pm
Location: Dodging Daleks

Re: NX-RPG/Revenge from the Shadows 0.3.0 [Wesnoth 1.10]

Post by vultraz »

lu_zero wrote:I tried to fetch from svn directly to the add-ons directory and it complained

20130730 04:14:12 error general: The following add-on had errors and could not be loaded:
/home/lu_zero/.local/share/wesnoth/1.11/data/add-ons/NX-RPG/_main.cfg
ERROR DETAILS:
Macro/file '~add-ons/NX-RPG/episode1/maps/00_01_Eclipse.map' is missing at ~add-ons/NX-RPG/episode1/scenarios/00_Descry.cfg:6 included from ~add-ons/NX-RPG/_main.cfg:80 included from ~add-ons/NX-RPG/_main.cfg:116
Sorry about that, I forgot to mention I had switched to GitHub. The new place to fetch from is here. I will update the first post ASAP.
Creator of Shadows of Deception (for 1.12) and co-creator of the Era of Chaos (for 1.12/1.13).
SurvivalXtreme rocks!!!
What happens when you get scared half to death...twice?

User avatar
vultraz
Community Manager
Posts: 958
Joined: February 7th, 2011, 12:51 pm
Location: Dodging Daleks

Re: NX-RPG/Revenge from the Shadows 0.3.0 [Wesnoth 1.10]

Post by vultraz »

IMPORTANT: the versions of this add-on have just been removed from the 1.10 server. A new version will be uploaded to the 1.11 sever soon.
Creator of Shadows of Deception (for 1.12) and co-creator of the Era of Chaos (for 1.12/1.13).
SurvivalXtreme rocks!!!
What happens when you get scared half to death...twice?

lu_zero
Posts: 196
Joined: April 16th, 2005, 10:25 am

Re: NX-RPG/Revenge from the Shadows 0.3.0

Post by lu_zero »

20130730 12:20:53 error scripting/lua: ...esnoth/1.11/data/add-ons/NX-RPG/lua/gui/spellcasting.lua:9: attempt to index global 'lp8' (a nil value)
stack traceback:
...esnoth/1.11/data/add-ons/NX-RPG/lua/gui/spellcasting.lua:9: in function 'cmd'
/usr/share/games/wesnoth/data/lua/wml-tags.lua:297: in function </usr/share/games/wesnoth/data/lua/wml-tags.lua:261>

When trying to access the menu.

lu_zero
Posts: 196
Joined: April 16th, 2005, 10:25 am

Re: NX-RPG/Revenge from the Shadows 0.3.0

Post by lu_zero »

In the dwarvish trail is unclear how to unload the mined material.

and I keep getting

20130731 02:02:41 error scripting/lua: ...es/wesnoth/data/ai/micro_ais/ais/mai_guardian_engine.lua:117: attempt to index local 'unit' (a nil value)
stack traceback:
...es/wesnoth/data/ai/micro_ais/ais/mai_guardian_engine.lua:117: in function <...es/wesnoth/data/ai/micro_ais/ais/mai_guardian_engine.lua:113>
(...tail calls...)

lu_zero
Posts: 196
Joined: April 16th, 2005, 10:25 am

Re: NX-RPG/Revenge from the Shadows 0.3.0

Post by lu_zero »

lu_zero wrote:20130730 12:20:53 error scripting/lua: ...esnoth/1.11/data/add-ons/NX-RPG/lua/gui/spellcasting.lua:9: attempt to index global 'lp8' (a nil value)
stack traceback:
...esnoth/1.11/data/add-ons/NX-RPG/lua/gui/spellcasting.lua:9: in function 'cmd'
/usr/share/games/wesnoth/data/lua/wml-tags.lua:297: in function </usr/share/games/wesnoth/data/lua/wml-tags.lua:261>

When trying to access the menu.
Importing and reloading lp8 was enough.

Now I can't get the miners to end up in the state loaded and can't pickup the ring.

User avatar
8680
Moderator Emeritus
Posts: 742
Joined: March 20th, 2011, 11:45 pm
Location: The past

Re: NX-RPG/Revenge from the Shadows 0.3.0

Post by 8680 »

lu_zero wrote:20130730 12:20:53 error scripting/lua: ...esnoth/1.11/data/add-ons/NX-RPG/lua/gui/spellcasting.lua:9: attempt to index global 'lp8' (a nil value)
NX-RPG depends on 8680’s Lua Pack (internally known as “lp8”), which I suppose you did not have installed.

The old readme did not cover installation via Git, but only via Wesnoth’s add-on manager. The released versions of NX-RPG published to the official add-ons servers include a bundled copy of 8680’s Lua Pack, and it was assumed that everyone except vultraz and I would be using those released versions, so NX-RPG’s dependency upon 8680’s Lua Pack was not mentioned.

I have written a new readme, which covers installation via Git and the subsequently necessary installation of 8680’s Lua Pack.
lu_zero wrote:Importing and reloading lp8 was enough.
What do you mean by this? Did you install 8680’s Lua Pack and reload the game, or did you make some change to NX-RPG?

Merely installing 8680’s Lua Pack should not have been sufficient until my recent commit 0ef8402; until then, only the copy of 8680’s Lua Pack included with the released versions of NX-RPG was (or should have been) accessible to NX-RPG.

lu_zero
Posts: 196
Joined: April 16th, 2005, 10:25 am

Re: NX-RPG/Revenge from the Shadows 0.3.0

Post by lu_zero »

just populated the git submodule and resynced and that was enough.

Still looks like that scenario isn't exactly ready for the current version since both ring pickup, inventory (I picked up the gem) and the miners aren't working correctly.

User avatar
vultraz
Community Manager
Posts: 958
Joined: February 7th, 2011, 12:51 pm
Location: Dodging Daleks

Re: NX-RPG/Revenge from the Shadows 0.3.0

Post by vultraz »

lu_zero wrote:Still looks like that scenario isn't exactly ready for the current version since both ring pickup, inventory (I picked up the gem) and the miners aren't working correctly.
The inability to pick up the ring is a bug. Will fix it tonight. The gem, I still have to code and effect for (I left it since I assumed not many people would find it. As for the miners, I should probably add a more visual clue about the unloading.

Thank you for doing an early playtest, by the way. :)
Creator of Shadows of Deception (for 1.12) and co-creator of the Era of Chaos (for 1.12/1.13).
SurvivalXtreme rocks!!!
What happens when you get scared half to death...twice?

User avatar
8680
Moderator Emeritus
Posts: 742
Joined: March 20th, 2011, 11:45 pm
Location: The past

Re: NX-RPG/Revenge from the Shadows 0.3.0

Post by 8680 »

lu_zero wrote:just populated the git submodule and resynced and that was enough.
Ah okay, that would suffice. However, I may move away from including lp8 via a submodule in the future, so I don’t mention it in the readme.

lu_zero
Posts: 196
Joined: April 16th, 2005, 10:25 am

Re: NX-RPG/Revenge from the Shadows 0.3.0

Post by lu_zero »

20130731 21:19:28 error config: Macro/file '8680/lua-pack/path' is missing at ~add-ons/NX-RPG/lua/lp8/_main.cfg:16 included from ~add-ons/NX-RPG/_main.cfg:108 included from ~add-ons/NX-RPG/lua/lp8/_main.cfg:56 included from ~add-ons/NX-RPG/_main.cfg:108
20130731 21:19:28 error config: error reading usermade add-on '/home/lu_zero/.local/share/wesnoth/1.11/data/add-ons/NX-RPG/_main.cfg'
20130731 21:19:28 error general: The following add-on had errors and could not be loaded:
/home/lu_zero/.local/share/wesnoth/1.11/data/add-ons/NX-RPG/_main.cfg
ERROR DETAILS:
Macro/file '8680/lua-pack/path' is missing at ~add-ons/NX-RPG/lua/lp8/_main.cfg:16 included from ~add-ons/NX-RPG/_main.cfg:108 included from ~add-ons/NX-RPG/lua/lp8/_main.cfg:56 included from ~add-ons/NX-RPG/_main.cfg:108


Looks like some of your changes do not work as intended =/

Post Reply