Wesnoth GUI doesnt react

Having trouble with the game? Report issues and get help here. Read this first!

Moderator: Forum Moderators

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
Wesley
Posts: 2
Joined: November 16th, 2009, 9:31 am

Wesnoth GUI doesnt react

Post by Wesley »

hi there

my problem is that the GUI from wesnoth doesnt reacts on mouseclicks, you can see the pointer moving, you here the sound and you can even see the hovered buttons glow but you cant klick them. the only button that works is the mail button on the bottom right corner and the checkbox in the following menu.

following up are some informations that might help you catching the problem because as i googled after this issue i found out that im the only one that encounters this problem. (or i just didnt searched very well)

EDIT: i should mention that i wasnt building wesnoth with this package versions, i installed a already compiled version out of my repository.

Versions:
wesnoth 1.6.5
sdl 1.2.14
sdl_image 1.2.10
sdl_mixer 1.2.11
sdl_net 1.2.7
sdl_sound 1.0.3
sdl_ttf 2.0.9
libvorbis 1.2.3
fribidi 0.19.2
freetype2 2.3.11
gcc-libs 4.4.2
boost 1.39.0
pango 1.26.0

System:
ArchLinux
kernel26 2.6.31.6
AMD Athlon XP 1500+
nVidia GeForce FX 5200

xorg-server 1.7.1.901
xf86-input-mouse 1.5.0
nvidia-173xx 173.14.22
xorg.conf:

Code: Select all

[...]
Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection
[...]
Soliton
Site Administrator
Posts: 1654
Joined: April 5th, 2005, 3:25 pm
Location: #wesnoth-mp

Re: Wesnoth GUI doesnt react

Post by Soliton »

Downgrade SDL to 1.2.13.
"If gameplay requires it, they can be made to live on Venus." -- scott
Wesley
Posts: 2
Joined: November 16th, 2009, 9:31 am

Re: Wesnoth GUI doesnt react

Post by Wesley »

It worked, thank you.
will this problem be solved in a future version?
CAN this be solved or is it the fault of the sdl dev's?
i dont think downgrading packages is a clean solution for problems like this.
Post Reply