Frozen Cursor bug in Multiplayer

Having trouble with the game? Report issues and get help here. Read this first!

Moderator: Forum Moderators

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
Posts: 1
Joined: July 19th, 2017, 2:57 am

Frozen Cursor bug in Multiplayer

Post by Bluedragon13 »

The Battle for Wesnoth version 1.13.7
Running on Microsoft Windows 10 (10.0.15063)

Game paths

Data dir: C:\Program Files (x86)\Battle for Wesnoth 1.13.7
User config dir: C:\Users\Robert\Documents\My Games\Wesnoth1.13
User data dir: C:\Users\Robert\Documents\My Games\Wesnoth1.13
Saves dir: C:\Users\Robert\Documents\My Games\Wesnoth1.13/saves
Add-ons dir: C:\Users\Robert\Documents\My Games\Wesnoth1.13/data/add-ons
Cache dir: C:\Users\Robert\Documents\My Games\Wesnoth1.13\cache


Boost: 1.59
Cairo: 1.10.2 (runtime 1.10.2)
Pango: 1.30.1 (runtime 1.30.1)
SDL: 2.0.4 (runtime 2.0.4)
SDL_image: 2.0.0 (runtime 2.0.0)
SDL_mixer: 2.0.0 (runtime 2.0.0)
SDL_ttf: 2.0.12 (runtime 2.0.12)
libpng: 1.5.14 (runtime 1.5.14)


Experimental OpenMP support: yes
PNG screenshots: yes
Lua console completion: yes
Legacy bidirectional rendering: no
Win32 notifications back end: yes

First I log into Wesnoth successfully. Then I click on Multiplayer/Connect to Server and enter my dad's IP address. It works and I am taken to the lobby. He created a game and I joined it without a problem. Then when the game started, he took his turn but when it became my turn, I noticed that the yellow highlighting hex was not aligned with the arrow cursor. I scrolled around and found it, frozen in the same place that my cursor was before my turn started and the game centered me on my character. We waited minutes, still no progress. I uninstalled Wesnoth, I tried to host on my own server, I unplugged the mouse and tried the keypad, yet still the golden hex that is used for movement, recruiting, selecting and toggling units was frozen in place every time. Help would be much appreciated. A save file is attached to see the problem. Thank you,

Save File
(27.43 KiB) Downloaded 172 times
User avatar
Inactive Developer
Posts: 4453
Joined: November 26th, 2005, 7:41 am

Re: Frozen Cursor bug in Multiplayer

Post by Sapient »

I was having the same problem with 1.13.7 and opened a bug report at, but when I installed 1.13.8 it appeared to be fixed, so I closed the bug report. (The bug report is not visible now since only open issues were migrated to github).

However, someone else posted about a similar problem with 1.13.8. I do not see a bug report yet for the problem they were experiencing.

Try installing 1.13.8?

Also... It may be related to windowed mode. Try playing in fullscreen mode or adjust the window to a different size.

EDIT: I have opened bug report #1844 to track this issue. "Looks like your skills saved us again. Uh, well at least, they saved Soarin's apple pie."
General Code Maintainer
Posts: 1344
Joined: February 10th, 2013, 2:25 pm

Re: Frozen Cursor bug in Multiplayer

Post by gfgtdf »

Yes this is a known issue, unfortunately we don't know under which conditions it happens. To me here is happends rareley and randomly. We'd be happy about more information on this issue.

If anythigng 'special' in particular erromessages were observed before this happens please says so, even if they are just about syntaxerror in wml from 4 games eariler ago: unless you closed and restarted wesnoth.exe in between it could be related.
Scenario with Robots SP scenario (1.11/1.12), allows you to build your units with components, PYR No preperation turn 1.12 mp-mod that allows you to select your units immideately after the game begins.
Post Reply