Wesnoth 1.16.2

Get help with compiling or installing the game, and discuss announcements of new official releases.

Moderator: Forum Moderators

Locked
User avatar
Pentarctagon
Project Manager
Posts: 5061
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Wesnoth 1.16.2

Post by Pentarctagon »

Wesnoth 1.16.2 is out!
This is a regular maintenance release for the stable 1.16.x series, delivering bug fixes and translation updates. As is the norm for updates to the current stable series, this release is fully compatible with previous 1.16.x versions.

A full list of changes and new features added since version 1.14 can be found in the release notes for this series.


Downloads
Steam
The latest stable version of Wesnoth is published on Steam and regularly receives translation updates between releases.
Itch.io
The latest stable version of Wesnoth is also published on itch.io. A standalone portable download is also available.
Windows installer (442.9 MB)
SHA256 sum: c890bb91fbf38c26881ad1f2f5ceb3d9cb5b5565da8ccb43fac2bd407ce167b3
macOS package (487.1 MB)
SHA256 sum: fa5a5b192c0e475ccee629e867b206ffd7dab7ce5b4f8f8c7a1ba90b720199c3
Source code (474.8 MB)
SHA256 sum: 729fd0903a28af502240d08c0a27b9ff50e534677644b639d8fd33823a7a9799
Linux
All known Linux packagers have been contacted, and binaries for your distribution may have already been created. Information about where to get the respective binaries and how to install them, including via Flatpak, can be found on the Linux binaries page in the wiki.

Changes in this release

Read on for more details about the most notable fixes and additions since the previous stable release. A full list of changes may be found in our changelog.
General
  • Multi-turn planned moves shown to enemies
    Planned moves that will take multiple turns to complete are no longer visible to enemy players.
  • Out of sync the first time loading replay using custom units
    Replays using custom units from add-ons will no longer fail to play due to an out of sync error when when loaded from the main menu's Load Game dialog the first time.
  • Non-host players can't join multiplayer games using custom terrain
    When using an add-on that creates its own terrain types, the non-host players and observers will no longer be kicked from the game when it starts due to an unknown terrain type error.
  • CJK languages no longer take forever to connect to Wesnoth's servers
    Players using CJK languages will no longer need to wait 10+ minutes to connect to Wesnoth's multiplayer and add-ons servers.
  • The preference "Show joins of friends only" does nothing
    When in the lobby of a game, having the "Show joins of friends only" preference set will now function correctly and not continue showing all player joins.
  • Multiplayer server password storage
    When storing the password for multiple accounts the password file will no longer become corrupted.
Known Issues
General issues:
  • OneDrive can interfere with Wesnoth’s user config/data directory set-up, leading to all kinds of different manifestations of the issue. There’s no fix available yet. The recommendation for the time being is to avoid syncing the Wesnoth user directory with OneDrive.
General issues:
  • Preprocessor errors corrupt cache (issue #1924). If this happens you have to wipe your cache. That can be done in Preferences → Cache.
If you find any bugs, do not hesitate to report them, but please read the instructions on how to report bugs first! As bug reports in the forums tend to be forgotten, you will get better results using our bug tracker. We require your help for finding and fixing issues, no matter how obvious, trivial, or complicated they seem!

Have fun!
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code
vghetto
Posts: 755
Joined: November 2nd, 2019, 5:12 pm

Re: Wesnoth 1.16.2

Post by vghetto »

Did the build process change for 1.16.2?

I'm getting errors running cmake. Something about Fontconfig.

Code: Select all

cmake /mnt/SDB/src/wesnoth/build/wesnoth -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/home/amnesia/local/games/wesnoth/1.16 -DBINARY_SUFFIX=-1.16 -DCMAKE_CXX_COMPILER=clang++

Code: Select all

Replacing flags used for Debug build  -DDEBUG -ggdb3
-- Found VorbisFile: optimized;/usr/lib/x86_64-linux-gnu/libvorbisfile.so;debug;/usr/lib/x86_64-linux-gnu/libvorbisfile.so  
-- Found PkgConfig: /usr/bin/pkg-config (found version "1.6.0") 
CMake Error at CMakeLists.txt:481 (find_package):
  By not providing "FindFontconfig.cmake" in CMAKE_MODULE_PATH this project
  has asked CMake to find a package configuration file provided by
  "Fontconfig", but CMake did not find one.

  Could not find a package configuration file provided by "Fontconfig" with
  any of the following names:

    FontconfigConfig.cmake
    fontconfig-config.cmake

  Add the installation prefix of "Fontconfig" to CMAKE_PREFIX_PATH or set
  "Fontconfig_DIR" to a directory containing one of the above files.  If
  "Fontconfig" provides a separate development package or SDK, be sure it has
  been installed.


-- Configuring incomplete, errors occurred!
See also "/mnt/SDB/src/wesnoth/build/build-1.16/CMakeFiles/CMakeOutput.log".
See also "/mnt/SDB/src/wesnoth/build/build-1.16/CMakeFiles/CMakeError.log".
User avatar
Pentarctagon
Project Manager
Posts: 5061
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: Wesnoth 1.16.2

Post by Pentarctagon »

It looks like I backported part of a larger change that I shouldn't have. The change to how fontconfig is found only works with cmake 3.14+. I pushed a fix to the 1.16 branch just now which is to just delete line 481 (if you look a bit further down in the file the old way of checking for fontconfig is still there).
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code
vghetto
Posts: 755
Joined: November 2nd, 2019, 5:12 pm

Re: Wesnoth 1.16.2

Post by vghetto »

Ok thanks!
I deleted line 481 and now I'm getting a different error
I'm trying to build tag 1.16.2 and my cmake version is 3.13.4.

Code: Select all

Replacing flags used for Debug build  -DDEBUG -ggdb3
-- Found VorbisFile: optimized;/usr/lib/x86_64-linux-gnu/libvorbisfile.so;debug;/usr/lib/x86_64-linux-gnu/libvorbisfile.so  
-- Found PkgConfig: /usr/bin/pkg-config (found version "1.6.0") 
-- Checking for module 'sdl2>=2.0.8'
--   Found sdl2, version 2.0.9
-- Checking for module 'SDL2_image>=2.0.2'
--   Found SDL2_image, version 2.0.4
-- Checking for module 'SDL2_mixer>=2.0.0'
--   Found SDL2_mixer, version 2.0.4
-- Checking for module 'cairo>=1.10'
--   Found cairo, version 1.16.0
-- Checking for module 'pangocairo>=1.22.0'
--   Found pangocairo, version 1.42.3
-- Checking for module 'fontconfig>=2.4.1'
--   Found fontconfig, version 2.13.1
-- Checking for module 'pango>=1.22.0'
--   Found pango, version 1.42.3
-- Checking for module 'readline'
--   Package 'readline', required by 'virtual:world', not found
CMake Error at /usr/share/cmake-3.13/Modules/FindPkgConfig.cmake:452 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake-3.13/Modules/FindPkgConfig.cmake:622 (_pkg_check_modules_internal)
  CMakeLists.txt:502 (pkg_check_modules)


-- Configuring incomplete, errors occurred!
See also "/mnt/SDB/src/wesnoth/build/build-1.16/CMakeFiles/CMakeOutput.log".
See also "/mnt/SDB/src/wesnoth/build/build-1.16/CMakeFiles/CMakeError.log".
I've been using the same steps (and debian packages) to build everything from 1.12 to 1.16.1.
Are there new dependencies for 1.16.2?
User avatar
Pentarctagon
Project Manager
Posts: 5061
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: Wesnoth 1.16.2

Post by Pentarctagon »

Not new per se, just (lib)readline(-dev) are supposed to be optional instead of required. pkg_check_modules(LIBREADLINE REQUIRED readline) should be pkg_check_modules(LIBREADLINE readline).
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code
vghetto
Posts: 755
Joined: November 2nd, 2019, 5:12 pm

Re: Wesnoth 1.16.2

Post by vghetto »

strange, I have libreadline-dev installed already :/

Code: Select all

root@amnesia:~# apt-get install libreadline-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
libreadline-dev is already the newest version (7.0-5).
Removing REQUIRED worked for me. thanks again!
gnombat
Posts: 461
Joined: June 10th, 2010, 8:49 pm

Re: Wesnoth 1.16.2

Post by gnombat »

The download link on the home page is broken (at least for Windows users):

Code: Select all

https://sourceforge.net/projects/wesnoth/files/wesnoth-1.16/wesnoth-1.16.1/wesnoth-1.16.2-win64.exe/download
User avatar
Pentarctagon
Project Manager
Posts: 5061
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: Wesnoth 1.16.2

Post by Pentarctagon »

Thanks for letting us know, it's fixed now.
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code
ERROR1025
Posts: 8
Joined: February 23rd, 2020, 10:18 am

Re: Wesnoth 1.16.2

Post by ERROR1025 »

1.16.2 obs pwd game need use pwd is a bug?(1.14.* join can use pwd,but obs not use pwd)
User avatar
Pentarctagon
Project Manager
Posts: 5061
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: Wesnoth 1.16.2

Post by Pentarctagon »

Observers needing the password to observer a password protected game is intentional.
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code
Locked