Unreasonable high CPU usage (90-100%)

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
User avatar
Pentarctagon
Project Manager
Posts: 4429
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: Unreasonable high CPU usage (90-100%)

Post by Pentarctagon »

DumptyMcGanti wrote:
February 5th, 2019, 5:43 pm
Pentarctagon wrote:
February 5th, 2019, 1:03 am
Go to the Start Menu > right click on Computer > Advanced system settings > Advanced tab > click Environment variables. I don't use Windows anymore, but it was there when I used Windows 7.
thank you, although I still do not know what to do next :oops:
this is a snap shot of my screen.
Is 25% CPU consumption normal for Wesnoth?
screenshot:
Under "User variables" click the "New..." button, then put OMP_WAIT_POLICY for the variable name and passive for the value.

Wesnoth isn't able to use more than one core, and in that screenshot there are two-ish cores being used it looks like, so it doesn't appear that Wesnoth is the only thing running that's using a significant amount of the CPU. Looking for `wesnoth.exe` under the Processes tab would probably be more specific.
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code

User avatar
DumptyMcGanti
Posts: 7
Joined: February 2nd, 2019, 9:33 am

Re: Unreasonable high CPU usage (90-100%)

Post by DumptyMcGanti »

Pentarctagon wrote:
February 6th, 2019, 1:01 am
DumptyMcGanti wrote:
February 5th, 2019, 5:43 pm
Pentarctagon wrote:
February 5th, 2019, 1:03 am
Go to the Start Menu > right click on Computer > Advanced system settings > Advanced tab > click Environment variables. I don't use Windows anymore, but it was there when I used Windows 7.
thank you, although I still do not know what to do next :oops:
this is a snap shot of my screen.
Is 25% CPU consumption normal for Wesnoth?
screenshot:
Under "User variables" click the "New..." button, then put OMP_WAIT_POLICY for the variable name and passive for the value.

Wesnoth isn't able to use more than one core, and in that screenshot there are two-ish cores being used it looks like, so it doesn't appear that Wesnoth is the only thing running that's using a significant amount of the CPU. Looking for `wesnoth.exe` under the Processes tab would probably be more specific.
Thank you for your detailed answer.
The percentage dropped to 17% when playing normally and goes up 30% when continuously scrolling.
I apologize for not replying at the earliest for I was hoping that the fan would turn off.

Post Reply