[solved] Cannot post attachments with Firefox

Discussion of all aspects of the website, wiki, and forums, including support requests and new ideas.

Moderators: Forum Moderators, Developers

Post Reply
User avatar
Elvish_Hunter
Developer
Posts: 1380
Joined: September 4th, 2009, 2:39 pm
Location: Lintanir Forest...

[solved] Cannot post attachments with Firefox

Post by Elvish_Hunter » May 2nd, 2015, 8:53 am

Some days ago, I noticed a problem. I needed to attach a file to a post, so I clicked on the Browse button that can be found in the Upload attachment section of the posting form. To my surprise, nothing happened: the file selection dialog didn't appear, nor did I get an error message. Exactly nothing, like it was a button without a defined behavior.
This happens to me both on Linux Xubuntu, with Firefox 37.0.2, and on Windows 7, with Firefox Developer Edition 39.0.2a and no extensions installed. However, everything works fine on Xubuntu with Chrome 42.
Current maintainer of these add-ons:
1.14: The Sojournings of Grog, A Rough Life, The White Troll (co-author), Wesnoth Lua Pack
1.12: Children of Dragons

User avatar
shadowm
Site Administrator
Posts: 6547
Joined: November 14th, 2006, 5:54 pm
Location: Chile
Contact:

Re: Cannot post attachments with Firefox

Post by shadowm » May 2nd, 2015, 9:15 am

If you can see this it means it works for me on Firefox 37.0.2 on Debian 8.
If you can see this it means it works for me on Firefox 37.0.2 on Debian 8.
7902.png (95.83 KiB) Viewed 1734 times
Author of the unofficial UtBS sequels Invasion from the Unknown and After the Storm.

User avatar
Ravana
Moderator
Posts: 2176
Joined: January 29th, 2012, 12:49 am
Location: Estonia
Contact:

Re: Cannot post attachments with Firefox

Post by Ravana » May 2nd, 2015, 9:51 am

I believe this is browsers general problem, not related to forums. With chrome I have noticed that sometimes no upload OR download dialogs show up, at least until browser restart.

User avatar
Elvish_Hunter
Developer
Posts: 1380
Joined: September 4th, 2009, 2:39 pm
Location: Lintanir Forest...

Re: Cannot post attachments with Firefox

Post by Elvish_Hunter » May 2nd, 2015, 10:02 am

shadowm wrote:If you can see this it means it works for me on Firefox 37.0.2 on Debian 8.
Thanks, this was really useful because it restricted the issues to my setups. After you posted it, I remembered that, due to security reasons, I modified a settings in about:config in both installations. Namely, I emptied the dom.popup_allowed_events property, to block all popups: restoring it to the default value (change click dblclick mouseup reset submit touchend) fixed the issue. :oops:
That's weird, however, given that a file selection dialog isn't a popup... :roll:
Current maintainer of these add-ons:
1.14: The Sojournings of Grog, A Rough Life, The White Troll (co-author), Wesnoth Lua Pack
1.12: Children of Dragons

Post Reply