How to update wesnoth version? [Ubuntu]

Get help with compiling or installing the game, and discuss announcements of new official releases.

Moderator: Forum Moderators

Post Reply
Zubb
Posts: 13
Joined: October 13th, 2009, 6:25 pm

How to update wesnoth version? [Ubuntu]

Post by Zubb »

I'm using Ubuntu 10.04. I fail to update Wesnoth (from 1.8.0.) using apt-get.
Spoiler:
What am I doing wrong?
Last edited by Zubb on June 10th, 2011, 11:02 am, edited 2 times in total.
User avatar
Zaroth
Inactive Developer
Posts: 75
Joined: January 29th, 2011, 4:33 pm

Re: How to update wesnoth version? [Linux]

Post by Zaroth »

It depends on your distribution. Generally the preferred way to update wesnoth on linux for beginner linux users is to rely on their distribution's packaging. Therefore, try running apt-get, yum, emerge or whatever else update and upgrade.

However, if you have special needs (such as having several installations at once when your repository manager doesn't allow that) or want to use the bleeding edge of Wesnoth (version in repositories tend to be a bit outdated), your best shot is to compile wesnoth from source. More information about that can be found on the relevant wiki page.

Also, moved to the relevant forum section.
Zubb
Posts: 13
Joined: October 13th, 2009, 6:25 pm

Re: How to update wesnoth version? [Linux]

Post by Zubb »

Ubuntu distribution fails to upgrade 180 -> 185 with apt-get. It runs, but version stays the same.
User avatar
Zaroth
Inactive Developer
Posts: 75
Joined: January 29th, 2011, 4:33 pm

Re: How to update wesnoth version? [Linux]

Post by Zaroth »

Well, then it seems to be a problem with your Ubuntu package manager (or the way you are using it). Unless you are willing to try compiling on Ubuntu, you may have better luck asking your question in Ubuntu-related channels, e.g. ubuntu forums or #ubuntu channel on irc.freenode.net (if you never used irc before, you may try webirc to get there), if you prefer having live chat with whoever is trying to help you.

Also, try to learn how to ask your questions in a more informative way. If you do it the way you are doing now (the details of what happened have to be pulled out of you and you write one line responses), you are unlikely to get useful answers. Unless you get lucky and meet a kind soul who is willing to spend the time, that is. Compare this awesome guide on how to ask good questions (read the whole thing if you have the time, it's enormously useful when dealing with the more technical users of the internet).
Luther
Posts: 115
Joined: July 28th, 2007, 5:19 pm
Location: USA

Re: How to update wesnoth version? [Ubuntu]

Post by Luther »

Actually, Ubuntu 10.04 is an old release. (Although it's the latest LTS.) I'm sure they don't have the latest wesnoth. First, make sure you have the backports repository enabled. If that doesn't work, you have to either install wesnoth from source or upgrade Ubuntu.
User avatar
Zaroth
Inactive Developer
Posts: 75
Joined: January 29th, 2011, 4:33 pm

Re: How to update wesnoth version? [Ubuntu]

Post by Zaroth »

Just as Luther said, Lucid Lynx 10.04 doesn't have 1.8.5 in the repository (this is in fact one of the reasons I don't like Ubuntu or other release-based distributions; you have to wait ages for a new version to get new versions of your packages from the repository).
It has wesnoth (which is wesnoth 1.6.5) and wesnoth-1.8 (1.8.0 with ubuntu patches), which I assume you're using.

Probably the easiest way to proceed for you is to upgrade to a more recent version of Ubuntu (this should be quite easy, since Ubuntu aims to be user-friendly), since already Maverick Meerkat 10.10 has Wesnoth 1.8.5 in repository.
Anonymissimus
Inactive Developer
Posts: 2460
Joined: August 15th, 2008, 8:46 pm
Location: Germany

Re: How to update wesnoth version? [Ubuntu]

Post by Anonymissimus »

This seems odd. I have Lucid Lynx too. 1.8 is in its repository, this is supposed to be this way for all other versions of the same stable branch too then. If the latest stable release isn't there it's maybe not yet provided by the package maintainer.

I compile trunk there btw, it's not that hard on Linux, and it gives a top up-to-date version.
projects (BfW 1.12):
A Simple Campaign: campaign draft for wml startersPlan Your Advancements: mp mod
The Earth's Gut: sp campaignSettlers of Wesnoth: mp scenarioWesnoth Lua Pack: lua tags and utils
updated to 1.8 and handed over: A Gryphon's Tale: sp campaign
User avatar
averyimaginativename
Posts: 245
Joined: August 21st, 2010, 12:40 pm
Location: /dev/null

Re: How to update wesnoth version? [Ubuntu]

Post by averyimaginativename »

1.8 is in the "Universe" repository - are you sure you have this enabled?

If you're unsure how to do it, from inside synaptic click Settings>Repositories and make sure Community Maintained Open Source Software is selected.

You may also be interested in a PPA for 1.9:

https://launchpad.net/ubuntu/+source/wesnoth-1.9
UMC Story Images web gallery

On an indefinite Wesbreak for health reasons - please only try to get my attention for UMC story images website issues.
User avatar
pauxlo
Posts: 1047
Joined: September 19th, 2006, 8:54 pm

Re: How to update wesnoth version? [Ubuntu]

Post by pauxlo »

It looks like Lucid only has 1.8.3 in its wesnoth-1.8 package.

You can get an 1.8.5 from the lucid-backports repository, instead.

(Or, as said, you could update your whole system to natty, which has 1.8.5, too.)
Post Reply