Imperial Era Campaigns

Discussion and development of scenarios and campaigns for the game.

Moderators: Forum Moderators, Developers

User avatar
UnwiseOwl
Posts: 486
Joined: April 9th, 2010, 4:58 am

Re: Imperial Era Campaigns

Post by UnwiseOwl »

I have recently ported Up from Slavery and Gali's Contract to the current version of wesnoth. I haven't made major changes to either of these campaigns, but they are functional again, and as always, I'd appreciate feedback. I also hope to port Alfhelm at some point, though that's a bigger project and I'm currently working on getting my update to Fall of Silvium rolling again.
Maintainer of the Imperial Era and the campaigns Dreams of Urduk, Epic of Vaniyera, Up from Slavery, Fall of Silvium, Alfhelm the Wise and Gali's Contract.
But perhaps 'maintainer' is too strong a word.

OverlordTallin
Posts: 1
Joined: April 8th, 2020, 7:04 pm

Re: Imperial Era Campaigns

Post by OverlordTallin »

Hi UnwiseOwl, I just wanted to say first that I really enjoy the Imperial Era and the attached campaigns. I just downloaded Alfhelm the Wise for version 1.14.5, and recieved the error message that I will post below. I made sure both the Imperial Era and Alfhelm the Wise were at the current version. Please let me know what you think, Thank you.

The following add-on had errors and could not be loaded:
C:\Users\Elijah Michael\Documents\My Games\Wesnoth1.14/data/add-ons/Alfhelm_the_Wise/_main.cfg

Please report this to the author or maintainer of this add-on.

Details:

Macro/file 'NOTE_LEADERSHIP' is missing
at ~add-ons/Alfhelm_the_Wise/units/Alfhelm_Jarl.cfg:21
included from ~add-ons/Alfhelm_the_Wise/_main.cfg:76

User avatar
UnwiseOwl
Posts: 486
Joined: April 9th, 2010, 4:58 am

Re: Imperial Era Campaigns

Post by UnwiseOwl »

Hi Overlord Tallin, thanks for getting in touch and thanks for the report.

Looks like this was caused by something I changed in the latest version of the campaign to work with Wesnoth 1.15.3 that didn't backport into the 1.14 version of the IE properly. I've reverted this change for the 1.14 version and reuploaded it, and I think it should work again now. Please let me know if you come across this or any other problem.

I hope you continue to enjoy your visit to the Imperial Era,
wOl.
Maintainer of the Imperial Era and the campaigns Dreams of Urduk, Epic of Vaniyera, Up from Slavery, Fall of Silvium, Alfhelm the Wise and Gali's Contract.
But perhaps 'maintainer' is too strong a word.

Post Reply