Where can i get add ons of old version?

General feedback and discussion of the game.

Moderators: Forum Moderators, Developers

Fosprey
Posts: 254
Joined: January 25th, 2008, 8:13 am

Where can i get add ons of old version?

Post by Fosprey »

I`m especially interesting in finding TL archmage, siege wars and settlers of catalan. Also interested in any mod that have builidings and technology. TL archamge was from 1.5 i think , i`m not sure what versions are the other two.

Max
Posts: 1449
Joined: April 13th, 2008, 12:41 am

Re: Where can i get add ons of old version?

Post by Max »

if you don't have any old versions of wesnoth installed you can download them manually:
http://www.wesnoth.org/addons/1.4/
http://www.wesnoth.org/addons/1.5/
http://www.wesnoth.org/addons/1.6/

Fosprey
Posts: 254
Joined: January 25th, 2008, 8:13 am

Re: Where can i get add ons of old version?

Post by Fosprey »

Thanks!

Edit: It seems that TL archmage isn`t on the server.

Max
Posts: 1449
Joined: April 13th, 2008, 12:41 am

Re: Where can i get add ons of old version?

Post by Max »


User avatar
Turuk
Sithslayer
Posts: 5283
Joined: February 28th, 2007, 8:58 pm
Contact:

Re: Where can i get add ons of old version?

Post by Turuk »

If you need anything in particular that you cannot find, I have all the add-ons back to 1.2 stored, and some select ones from 1.0. Though you can still access the 1.2 server at http://www.wesnoth.org/addons/1.2
Mainline Maintainer: AOI, DM, NR, TB and THoT.
UMC Maintainer: Forward They Cried, A Few Logs, A Few More Logs, Start of the War, and Battle Against Time

User avatar
Hadiel
Posts: 3
Joined: June 12th, 2009, 7:58 pm

Re: Where can i get add ons of old version?

Post by Hadiel »

Can you get those old add-ons for 1.7.0?

Also is there a campaign focused on a Fencer?
or at least one where you can recruit them...

User avatar
Turuk
Sithslayer
Posts: 5283
Joined: February 28th, 2007, 8:58 pm
Contact:

Re: Where can i get add ons of old version?

Post by Turuk »

Hadiel wrote: Can you get those old add-ons for 1.7.0?
You can get the old add-ons and go through the code to update it to work with 1.7, yes.
Hadiel wrote:Also is there a campaign focused on a Fencer?
or at least one where you can recruit them...
I am sure there are campaigns that let you recruit fencers, but I cannot think of any off the top of my head, you should try poking around the add-on server.
Mainline Maintainer: AOI, DM, NR, TB and THoT.
UMC Maintainer: Forward They Cried, A Few Logs, A Few More Logs, Start of the War, and Battle Against Time

User avatar
Hadiel
Posts: 3
Joined: June 12th, 2009, 7:58 pm

Re: Where can i get add ons of old version?

Post by Hadiel »

Thanks,
There is a fencer campaign/one where you can recruit lvl0 units of them. "The Siege of Soroduc or 'soro sumthin'"

User avatar
Turuk
Sithslayer
Posts: 5283
Joined: February 28th, 2007, 8:58 pm
Contact:

Re: Where can i get add ons of old version?

Post by Turuk »

Hadiel wrote:There is a fencer campaign/one where you can recruit lvl0 units of them. "The Siege of Soroduc or 'soro sumthin'"
Yes, Siege of Soradoc is a good example.
Mainline Maintainer: AOI, DM, NR, TB and THoT.
UMC Maintainer: Forward They Cried, A Few Logs, A Few More Logs, Start of the War, and Battle Against Time

User avatar
Elvish_Hunter
Forum Moderator
Posts: 1421
Joined: September 4th, 2009, 2:39 pm
Location: Lintanir Forest...

Re: Where can i get add ons of old version?

Post by Elvish_Hunter »

I have installed Wesnoth 1.2.8, 1.4.7 and 1.6.4 on my notebook running WinXP SP3. In 1.2.8 if I try to press the Add-ons button I view the list for the 1.7 (trunk) series, obviously such add-ons aren't compatible with 1.2.8. I tried also changing the port using add-ons.wesnoth.org:15000 to 15010, but I can't view the 1.2 add-ons list.
With 1.4.7 and 1.6.4 all is working fine.
Any solution?
Attachments
Screenshot 1_2_8.PNG
Current maintainer of these add-ons:
1.14: The Sojournings of Grog, A Rough Life, The White Troll (co-author), Wesnoth Lua Pack
1.12: Children of Dragons

User avatar
ivanovic
Lord of Translations
Posts: 1146
Joined: September 28th, 2004, 10:10 pm
Location: Germany

Re: Where can i get add ons of old version?

Post by ivanovic »

Elvish_Hunter wrote:Any solution?
Sure. Don't try to download addons for 1.2 anymore. That addon server is shut down.

User avatar
Ken_Oh
Moderator Emeritus
Posts: 2176
Joined: February 6th, 2006, 4:03 am
Location: Baltimore, Maryland, USA

Re: Where can i get add ons of old version?

Post by Ken_Oh »

Download them manually: http://www.wesnoth.org/addons/1.2/

User avatar
Elvish_Hunter
Forum Moderator
Posts: 1421
Joined: September 4th, 2009, 2:39 pm
Location: Lintanir Forest...

Re: Where can i get add ons of old version?

Post by Elvish_Hunter »

ivanovic and Ken_Oh, thanks for your answers.
Ken_Oh wrote:Download them manually: http://www.wesnoth.org/addons/1.2/
I just tried to download some campaigns from the above address using Firefox, then unpacking them with 7-Zip and finally putting the folders of the campaigns in \userdata\data\campaigns. However, I'm not able to do anything because the tar.bz2 files that I downloaded seem to be missing the cfg file.
For example, in AngelsFearToTread.tar.bz2 there is a folder called AngelsFearToTread containing all the data and subfolders, but there isn't the AngelsFearToTread.cfg file. The same happens for Flight_Freedom_1_x.tar.bz2, Legend_of_Wesmere.tar.bz2, Saving_Elensefar.tar.bz2, The_Mage_University.tar.bz2 and probably others that I haven't yet tried.
Now the questions are, am I doing something wrong? If not, where can I download the cfg files for these and the other 1.2 addons?
Current maintainer of these add-ons:
1.14: The Sojournings of Grog, A Rough Life, The White Troll (co-author), Wesnoth Lua Pack
1.12: Children of Dragons

User avatar
Iris
Site Administrator
Posts: 6617
Joined: November 14th, 2006, 5:54 pm
Location: Chile
Contact:

Re: Where can i get add ons of old version?

Post by Iris »

Um, I don't remember if 1.2 already supported the _main.cfg syntax; in such case, add-ons with an ...\Addon_Name\_main.cfg file should have worked fine.

For the Legend of Wesmere case: We encourage you to play it in 1.6 or 1.7 instead - it's in mainline, with much better text, graphics and player stats balancing. ;)
Author of the unofficial UtBS sequels Invasion from the Unknown and After the Storm.

User avatar
Elvish_Hunter
Forum Moderator
Posts: 1421
Joined: September 4th, 2009, 2:39 pm
Location: Lintanir Forest...

Re: Where can i get add ons of old version?

Post by Elvish_Hunter »

shadowmaster wrote:Um, I don't remember if 1.2 already supported the _main.cfg syntax; in such case, add-ons with an ...\Addon_Name\_main.cfg file should have worked fine.
AFAIK, the Addon_Name.cfg file is mandatory for 1.2, main.cfg isn't supported.
Anyway, I looked with Google for "AngelsFearToTread.cfg", and found that the file, and all the other cfg, are available in http://www.wesnoth.org/files/addons/1.2/unpacked/ . But trying to load the page I gain only a "Forbidden" error...
shadowmaster wrote:For the Legend of Wesmere case: We encourage you to play it in 1.6 or 1.7 instead - it's in mainline, with much better text, graphics and player stats balancing. ;)
[off topic mode on]
Yes, yes, I know... Already played and won :mrgreen: By spamming Elvish Shydes and Sylphs against Landar... And with a strange bug: in Bounty Hunters if Anduilas is already level 3 he won't be recalled, despite being loyal, and will be left by Kalenz to defend the Ka'lian. This happened me in 1.6a, and I deleted the savegame and the replay to NOT level Anduilas... Maybe should I use :debug to generate a savegame?
And thanks for creating my favourite unit! I hope that one day Elvish Hunters go in mainline...
[/off topic mode off]
Current maintainer of these add-ons:
1.14: The Sojournings of Grog, A Rough Life, The White Troll (co-author), Wesnoth Lua Pack
1.12: Children of Dragons

Post Reply