problem ubuntu 9.04 codeblocks

Get help with compiling or installing the game, and discuss announcements of new official releases.

Moderator: Forum Moderators

Post Reply
pi149
Posts: 2
Joined: May 24th, 2009, 4:44 pm

problem ubuntu 9.04 codeblocks

Post by pi149 »

Whenever I try to compile v1.7.0 in codeblocks using the codeblocks-scons project files it fails, with the following build log

Code: Select all

scons: Reading SConscript files ...
Saved options: default_targets = 'test,wesnoth,wesnothd'
Checking whether C++ compiler works (g++ version >= 3.3 required)... (cached) yes
Checking for Gettext's libintl... (cached) libc built-in
Checking for Boost iostreams library version >= 1.33.0... 
(cached) yes
Checking for gzip support in Boost Iostreams... 
(cached) yes
Checking for Boost smart_ptr library... (cached) yes
Checking for Simple DirectMedia Layer library version >= 1.2.7... 
(cached) yes
Checking for SDL_net library... 
(cached) yes
Checking for Pango with cairo backend... (cached) yes
Checking for fontconfig... (cached) yes
Checking for Lua development files version 5.1... 
(cached) no
Client prerequisites are not met. wesnoth, cutter and exploder cannot be built.
Checking for C library X11... (cached) yes
Checking for fribidi_utf8_to_unicode(NULL,0,NULL) in C library fribidi... 
(cached) yes
Checking for C header file poll.h... (cached) yes
Checking for C header file sys/poll.h... (cached) yes
Checking for C header file sys/select.h... (cached) yes
Checking for C header file sys/sendfile.h... (cached) yes
Checking for C function sendfile()... (cached) yes
Checking for C function round()... (cached) yes
Unit tests are disabled because their prerequisites are not met.
If any config checks fail, look in build/config.log for details
If a check fails spuriously due to caching, use --config=force to force its rerun
scons: *** [wesnoth] Target disabled because its prerequisites are not met
scons: done reading SConscript files.
scons: Building targets ...
error_action(["wesnoth"], [])
scons: building terminated because of errors.
Process terminated with status 2 (0 minutes, 3 seconds)
0 errors, 0 warnings
can anyone help?
Soliton
Site Administrator
Posts: 1635
Joined: April 5th, 2005, 3:25 pm
Location: #wesnoth-mp

Re: problem ubuntu 9.04 codeblocks

Post by Soliton »

Well, do you have Lua installed?
"If gameplay requires it, they can be made to live on Venus." -- scott
ilor
Inactive Developer
Posts: 129
Joined: March 24th, 2008, 9:05 pm

Re: problem ubuntu 9.04 codeblocks

Post by ilor »

as a hint, the package name is liblua.... not lua...
pi149
Posts: 2
Joined: May 24th, 2009, 4:44 pm

Re: problem ubuntu 9.04 codeblocks

Post by pi149 »

ilor wrote:as a hint, the package name is liblua.... not lua...
Thank you. That was the problem.
User avatar
TofuOgre
Posts: 23
Joined: April 25th, 2009, 12:25 am

Re: problem ubuntu 9.04 codeblocks

Post by TofuOgre »

pi149 wrote:
ilor wrote:as a hint, the package name is liblua.... not lua...
Thank you. That was the problem.
Same problem with 1.7, I had lua5.1 installed, but cmake and scons could not find it. I looked at the script for cmake and scons where it was looking for the file, and they were there.

Somewhere after running

sudo aptitude install lua

to see what was available in deb packages, I installed

sudo apt-get install lua5.1-policy-dev

and then

sudo apt-get install lua5.1

again.

Then it said boost was not installed (it was, but it needed more packages).

So, sometime after (I do not know which was the fix)

sudo apt-get install libboost-python-dev
sudo apt-get install libboost-program-options-dev
sudo apt-get install kregexpeditor
sudo apt-get install libboost-regex-dev

I got cmake to work (scons made packages but did not fully install them, missing the
/usr/local/bin/wesnoth file.

Someone needs to rewrite the minimum requirements.
User avatar
loonycyborg
Windows Packager
Posts: 280
Joined: April 1st, 2008, 4:45 pm
Location: Russia/Moscow

Re: problem ubuntu 9.04 codeblocks

Post by loonycyborg »

AFAIK all requirements lists already include both boost-regex and boost-iostreams. Listing -dev packages as requirements would be rather misleading since not all distros have -dev packages.
What is the method you're using to create packages?
"meh." - zookeeper
Post Reply