Flatpak 1.14.13 cursor anomaly

Having trouble with the game? Report issues and get help here. Read this first!

Moderator: Forum Moderators

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
User avatar
Atreides
Posts: 122
Joined: March 30th, 2019, 10:38 pm
Location: Lost in dreamland

Flatpak 1.14.13 cursor anomaly

Post by Atreides »

Hi, I'm running it under Debian 9 (which still has 1.12 as latest official!) and all in all it runs very smoothly and well except for one peculiarity I've noted so far. The cursor is monochrome and lacks detail. The hourglass cursor for example is just a silhouette as are the boots, etc.

It's not very pretty. Is this normal for the flatpak versions or is there something I can tweak to make it look nice?

I noted that flatpak installed something called opendesk and runs it under that. I normally use KDE (Gnome also installed).
--
Any typos are the fault of my laptop keyboard!
User avatar
Pentarctagon
Project Manager
Posts: 4516
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: Flatpak 1.14.13 cursor anomaly

Post by Pentarctagon »

It's a known issue (#4024) and is a problem affecting some flatpak apps generally. The linked Wesnoth issue also has a a link to the upstream flatpak issue.
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code
User avatar
Atreides
Posts: 122
Joined: March 30th, 2019, 10:38 pm
Location: Lost in dreamland

Re: Flatpak 1.14.13 cursor anomaly

Post by Atreides »

I found a workaround! Turn off colour cursors in the advanced menu and they return to normal. Well they're still mono obvi (but black not beige now), but the detail is back.

p.s. Incredible coincidence. Colour Cursor is default off in 1.12 and 1.14.5 yet works great now that I've tried them in those versions while it defaults to on in 1.14.13 which I installed via flatpak and has a problem with them... Madness I say, Madness! They are quite pretty in the 2 older versions and not at all slow (as they were advertised as being).
--
Any typos are the fault of my laptop keyboard!
Post Reply