Choppy Windmill in the editor.

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
vghetto
Posts: 167
Joined: November 2nd, 2019, 5:12 pm

Choppy Windmill in the editor.

Post by vghetto »

Hi,

This relates to placing a windmill item image in the editor, and not ^Wm or ^Vwm.

When the windmill scenery is placed on the map, it looks choppy and broken compared to the one placed with ^Wm
You get the image of the static windmill and another image of it turning at a strange rate.

This is what the editor code would translate to, note that the images for the halo go from 1 to 14, instead of 1 to 18 and the rate is set to 150 instead of 70.

Code: Select all

[item]
        halo="scenery/windmill-[01~14].png:150"
        image="scenery/windmill-01.png"
        visible_in_fog=yes
        x=6
        y=4
[/item]
This seems to fix it and make it look closer to ^Wm, but doing that will no longer show the windmill on the map while in editor mode.

Code: Select all

[item]
        halo="scenery/windmill-[01~18].png:70"
        image=""
        visible_in_fog=yes
        x=6
        y=6
[/item]
To reproduce, start the editor. File->New Scenario. Then click "Item Tool" -> Scenery -> Windmill and place it on the map.
Then Save Scenario As.

wesnoth version 1.14.12
thanks.

User avatar
octalot
Developer
Posts: 480
Joined: July 17th, 2010, 7:40 pm

Re: Choppy Windmill in the editor.

Post by octalot »

Changing the corresponding line in data/core/editor/items.cfg should make the non-choppy windmill visible, and the choppy windmill invisible.

I'm not submitting a bug fix for this - I feel it should go a bit further and support fixing scenario that already have the choppy windmill, and the scenario editor isn't an area that I want to start working on.

Post Reply