Wesnoth suddenly crashes on loading a save

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
ShadowWalker
Posts: 6
Joined: July 18th, 2013, 12:15 pm

Wesnoth suddenly crashes on loading a save

Post by ShadowWalker »

Today Wesnoth started crashing, when I click the load button in the main menu, the game also crashes when I start a new campaign after the opening dialogue is finished. Yesterday everything worked without any problems and neither the game version nor the operating system changed, so I have no clue where to look for the cause.

I would be thankful for any insight into what the problem is.

Here my system information:

Code: Select all

The Battle for Wesnoth version 1.14.11
Running on Apple OS X 10.11.6 (15G22010)
Distribution channel: Steam

Game paths
==========

Data dir:        /Users/USER/Library/Application Support/Steam/steamapps/common/wesnoth/The Battle for Wesnoth.app/Contents/Resources
User config dir: /Users/USER/Library/Containers/org.wesnoth.Wesnoth/Data/Library/Application Support/Wesnoth_1.14
User data dir:   /Users/USER/Library/Containers/org.wesnoth.Wesnoth/Data/Library/Application Support/Wesnoth_1.14
Saves dir:       /Users/USER/Library/Containers/org.wesnoth.Wesnoth/Data/Library/Application Support/Wesnoth_1.14/saves
Add-ons dir:     /Users/USER/Library/Containers/org.wesnoth.Wesnoth/Data/Library/Application Support/Wesnoth_1.14/data/add-ons
Cache dir:       /Users/USER/Library/Containers/org.wesnoth.Wesnoth/Data/Library/Application Support/Wesnoth_1.14/cache

Libraries
=========

Boost:     1.71
Cairo:     1.16.0 (runtime 1.16.0)
Pango:     1.40.1 (runtime 1.40.1)
SDL:       2.0.10 (runtime 2.0.10)
SDL_image: 2.0.5  (runtime 2.0.5)
SDL_mixer: 2.0.4  (runtime 2.0.4)
SDL_ttf:   2.0.15 (runtime 2.0.15)

Features
========

JPEG screenshots:               yes
Lua console completion:         yes
Legacy bidirectional rendering: no
Cocoa notifications back-end:   yes
And here is the log:

Code: Select all

-bash: /Users/Beide/Library/Application Support/Steam/steamapps/common/wesnoth/The Battle for Wesnoth.app: is a directory
Battle for Wesnoth v1.14.11
Started on Sat Apr  4 11:06:35 2020

Automatically found a possible data directory at /Users/USER/Library/Application Support/Steam/steamapps/common/wesnoth/The Battle for Wesnoth.app/Contents/Resources

Data directory:               /Users/USER/Library/Application Support/Steam/steamapps/common/wesnoth/The Battle for Wesnoth.app/Contents/Resources
User configuration directory: /Users/USER/Library/Containers/org.wesnoth.Wesnoth/Data/Library/Application Support/Wesnoth_1.14
User data directory:          /Users/USER/Library/Containers/org.wesnoth.Wesnoth/Data/Library/Application Support/Wesnoth_1.14
Cache directory:              /Users/USER/Library/Containers/org.wesnoth.Wesnoth/Data/Library/Application Support/Wesnoth_1.14/cache

Setting mode to 1280x1024
20200404 11:06:47 warning general: no location found for 'data/add-ons/A_Northern_Village/translations', skipping textdomain
20200404 11:06:47 warning general: no location found for 'data/add-ons/Affably_Evil/translations', skipping textdomain
20200404 11:06:47 warning general: no location found for 'data/add-ons/Kill_the_King/translations', skipping textdomain
20200404 11:06:47 warning general: no location found for 'data/add-ons/The_Beatiful_Child/translations', skipping textdomain
Checking lua scripts... ok
Caught general 'N5boost10wrapexceptINS_9iostreams10gzip_errorEEE' exception:
gzip error: unspecified iostream_category error
Battle for Wesnoth v1.14.11
Started on Sat Apr  4 11:10:44 2020

Automatically found a possible data directory at /Users/USER/Library/Application Support/Steam/steamapps/common/wesnoth/The Battle for Wesnoth.app/Contents/Resources

Data directory:               /Users/USER/Library/Application Support/Steam/steamapps/common/wesnoth/The Battle for Wesnoth.app/Contents/Resources
User configuration directory: /Users/USER/Library/Containers/org.wesnoth.Wesnoth/Data/Library/Application Support/Wesnoth_1.14
User data directory:          /Users/USER/Library/Containers/org.wesnoth.Wesnoth/Data/Library/Application Support/Wesnoth_1.14
Cache directory:              /Users/USER/Library/Containers/org.wesnoth.Wesnoth/Data/Library/Application Support/Wesnoth_1.14/cache

Setting mode to 1280x1024
20200404 11:10:50 warning general: no location found for 'data/add-ons/A_Northern_Village/translations', skipping textdomain
20200404 11:10:50 warning general: no location found for 'data/add-ons/Affably_Evil/translations', skipping textdomain
20200404 11:10:50 warning general: no location found for 'data/add-ons/Kill_the_King/translations', skipping textdomain
20200404 11:10:50 warning general: no location found for 'data/add-ons/The_Beatiful_Child/translations', skipping textdomain
Checking lua scripts... ok
Caught general 'N5boost10wrapexceptINS_9iostreams10gzip_errorEEE' exception:
gzip error: unspecified iostream_category error

ShadowWalker
Posts: 6
Joined: July 18th, 2013, 12:15 pm

Re: Wesnoth suddenly crashes on loading a save

Post by ShadowWalker »

Okay it turns out the problem was the save index, that somehow got corrupted. Wesnoth rebuilding the file after I deleted it resolved the issue.

User avatar
DukeSwampy
Posts: 126
Joined: June 26th, 2019, 2:20 pm
Location: Indonesia

Re: Wesnoth suddenly crashes on loading a save

Post by DukeSwampy »

Me feeling too, I think that sometimes happens (or because playing Wesnoth about more than one hour) :(
Sorry for my english, I'm not english native.
Regards, Swampy.

(Already mastered the LotI as 4 times until the end, so wanna me to play it again!?)

Post Reply