Wesnoth Screen Tearing and Map Breaking Down/Crashing with Debug Mode

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
KenM
Posts: 3
Joined: October 23rd, 2019, 3:31 pm

Wesnoth Screen Tearing and Map Breaking Down/Crashing with Debug Mode

Post by KenM » October 27th, 2019, 4:05 pm

Hello, I've been playing Wesnoth since around 1.0.2 and I don't play online much, but I love to host local lobbies and play with the debug mode and explore addons. I've done this forever, but recently in the past year I've had an issue running the game which makes this impossible.

I'll load up a lobby game with bots, open up the debug unit spawner menu, and within maybe 5 minutes the game starts to... break down. See screen shots below, but basically the screen starts to tear and mirror itself if I move anywhere (clicking sortof refreshes the screen) and unit/terrain description pages start to overlay their texts. Staying in the game will cause a crash with a popup (see below) claiming an "Assertion Failed!" error occurred - this is almost always a "surf" or a "dst" error. If instead I try to exit to main menu, the game crashes with no popup message but Wesnoth will begin a download lasting about 10 seconds on Steam. If I click to exit the whole game, the game wont have a popup like before, but the Steam download update will only last about 2-4 seconds. All of what I've described is extremely consistent and very reproducible.

To contrast the above, if I simply don't use the debug menu then I won't have issues at all with this; I should note that I have some memory of months ago where exploring unit descriptions only would cause the exact same issue, but I am unsure if this still happens.

Now I should point out that I use a lot of mods (mostly eras) and a big reason why I've been so hesitant to put the time into making a post is because I'm afraid the issue is going to be this is a memory issue - Wesnoth can only utilize so much for what I'm trying to do - and I'll have to uninstall era addons which is gonna be a big bummer if I have to do - but I'd suck it up. It's just that I remember back in the day and on a way worse computer (at the moment I have 16gb of 3200mhz ram, i7 8700k, rtx 2070), I just never had these issues doing the same things I'm doing now. As a side note, I've tried purging and clearing the cache in the Preferences menu - this seems to have little to no effect.

Exploring the logs will have a couple messsages that regularly popup:

Code: Select all

Could not create a new surface in get_surface_portion()
Could not create surface to scale onto
failed to make neutral surface
The first line seems to repeat to varying degrees in each log, between 1-30 times.
The second line always occurs and appears once per crash.
The third line is an occasional message but always pops up after the second line, if it does at all.
Each line will always appear only at the end of a crash log.
wesnoth-20191027-112020-17980.log
(89.75 KiB) Downloaded 38 times


The Battle for Wesnoth version 1.14.9 (9eba78f-Modified)
Running on Microsoft Windows 10 (10.0.18362)

Game paths
==========

Data dir: D:\SSteam Library\steamapps\common\wesnoth
User config dir: C:\Users\USER\Documents\My Games\Wesnoth1.14
User data dir: C:\Users\USER\Documents\My Games\Wesnoth1.14
Saves dir: C:\Users\USER\Documents\My Games\Wesnoth1.14\saves
Add-ons dir: C:\Users\USER\Documents\My Games\Wesnoth1.14\data\add-ons
Cache dir: C:\Users\USER\Documents\My Games\Wesnoth1.14\cache

Libraries
=========

Boost: 1.66
OpenSSL/libcrypto: 1.1.0f (runtime 1.1.0f)
Cairo: 1.10.2 (runtime 1.10.2)
Pango: 1.30.1 (runtime 1.30.1)
SDL: 2.0.8 (runtime 2.0.8)
SDL_image: 2.0.3 (runtime 2.0.3)
SDL_mixer: 2.0.2 (runtime 2.0.2)
SDL_ttf: 2.0.14 (runtime 2.0.14)

Features
========

JPG screenshots: yes
Lua console completion: yes
Legacy bidirectional rendering: no
Win32 notifications back end: yes
wesnoth-20191027-112020-17980.log
(89.75 KiB) Downloaded 38 times
wesnoth-20191027-112020-17980.log
(89.75 KiB) Downloaded 38 times
wesnoth-20191027-112020-17980.log
(89.75 KiB) Downloaded 38 times
Attachments
Text Overlay.png
Assertion Failed dst.png
Screen Tearing.png

KenM
Posts: 3
Joined: October 23rd, 2019, 3:31 pm

Re: Wesnoth Screen Tearing and Map Breaking Down/Crashing with Debug Mode

Post by KenM » October 27th, 2019, 4:07 pm

Just including the mods I'm using:
Mod list 1.png
Mod list 2.png

User avatar
Ravana
Forum Moderator
Posts: 2262
Joined: January 29th, 2012, 12:49 am
Location: Estonia
Contact:

Re: Wesnoth Screen Tearing and Map Breaking Down/Crashing with Debug Mode

Post by Ravana » October 27th, 2019, 4:30 pm

That is impressive. Even with little more than ageless, opening create unit menu is quite slow (4078 types).

Just curious, how many unit types you have? :lua wesnoth.message(#wesnoth.unit_types)

KenM
Posts: 3
Joined: October 23rd, 2019, 3:31 pm

Re: Wesnoth Screen Tearing and Map Breaking Down/Crashing with Debug Mode

Post by KenM » October 28th, 2019, 1:06 am

9982! Maybe it's just my adhd but I like feeling like there's always more stuff I can play around with haha

Post Reply