Super-fast unit animations bug [with videos]

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
User avatar
WhiteWolf
Forum Regular
Posts: 522
Joined: September 22nd, 2009, 7:48 pm
Location: Hungary

Super-fast unit animations bug [with videos]

Post by WhiteWolf » June 27th, 2019, 1:37 pm

Hello,

This is one of those issues that appeared when I ported my campaigns to 1.14.0 It's just a "graphical glitch" so to say, so I labeled it a known bug and focused on other stuff ever since.
However, I came round to it now, and is still an issue in Wesnoth 1.14.5. And I am posting to technical instead of WML Workshop, because I checked, and this is an issue in mainline as well, and thus seems independent of my UMC's.

The issue is that all unit animations that play between [message]'s are super fast. Can't even see them propery. Video footage of the issue: (non-listed, only available through the link)
https://youtu.be/Q-dxe_QdJl8

However, I have discovered that this only happens when I click through the messages slower than a certain speed.
Here is a second attempt of me rapidly clicking through the messages, and notice how the animations then play properly:
I've disabled the audio to let you hear how fast I am clicking. Sorry for the background noise, it's just a phone camera...
https://youtu.be/8Qw8g5g7XlE


And this is mainline, without any installed mods. But the exact same issue had been plaguing my campaign's animations ever since 1.14. Is this an already known issue, or is this somehow specific to my build?

This is Wesnoth 1.14.5 on Debian.
Build info:
However, I must note, I have been getting the same results on Windows IIRC. I wonder why no one else has raised this issue before though. (searching the forum yielded no results)

Here is the saved game I've been using as the example above:
SoF-Towards the Caves.gz
(10.19 KiB) Downloaded 50 times
Author of the Underness Series, consisting of V parts: The Desolation of Karlag, The Blind Sentinel, The Stone of the North, The Invasion Of The Western Cavalry, Fingerbone of Destiny
Standalone works: The Ravagers - now for 1.14, with new bugs!

User avatar
Pentarctagon
Forum Administrator
Posts: 3947
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: Super-fast unit animations bug [with videos]

Post by Pentarctagon » June 28th, 2019, 12:13 am

It looks like maybe the animation is still running, even though the screen isn't being updated between [message]s?
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code

User avatar
WhiteWolf
Forum Regular
Posts: 522
Joined: September 22nd, 2009, 7:48 pm
Location: Hungary

Re: Super-fast unit animations bug [with videos]

Post by WhiteWolf » June 28th, 2019, 8:45 am

Yeah, it looks like 90% of the animation is played in the blink of an eye, then the next message is shown. When I click through that, the rest of the animation is "still playing" before the next message.
Author of the Underness Series, consisting of V parts: The Desolation of Karlag, The Blind Sentinel, The Stone of the North, The Invasion Of The Western Cavalry, Fingerbone of Destiny
Standalone works: The Ravagers - now for 1.14, with new bugs!

User avatar
WhiteWolf
Forum Regular
Posts: 522
Joined: September 22nd, 2009, 7:48 pm
Location: Hungary

Re: Super-fast unit animations bug [with videos]

Post by WhiteWolf » August 3rd, 2019, 2:09 pm

Accidentaly I noticed something today, still relating to this: the [print] text is also crazy fast in the exact same way.

And when I was reading though the wiki, I found this:
duration: (default=50) the length of time to display the text for. This is measured in the number of 'frames'. A frame in Wesnoth is usually displayed for around 30ms.
And I think therein lies the solution: usually. How do you examine how fast your Wesnoth frame is on a computer, and how do you set it?
Author of the Underness Series, consisting of V parts: The Desolation of Karlag, The Blind Sentinel, The Stone of the North, The Invasion Of The Western Cavalry, Fingerbone of Destiny
Standalone works: The Ravagers - now for 1.14, with new bugs!

User avatar
Pentarctagon
Forum Administrator
Posts: 3947
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: Super-fast unit animations bug [with videos]

Post by Pentarctagon » August 4th, 2019, 4:48 pm

You can show the fps with the :fps command in-game. There's also the --max-fps <number> command line argument.
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code

User avatar
WhiteWolf
Forum Regular
Posts: 522
Joined: September 22nd, 2009, 7:48 pm
Location: Hungary

Re: Super-fast unit animations bug [with videos]

Post by WhiteWolf » August 5th, 2019, 3:41 pm

Sadly it didn't help much :hmm: The drawn fps window doesn't refresh between shown messages, and limiting the max fps also didn't do anything. It's the same as in the videos in the original post.

For the sake of clarity: this happens here on a Lenovo T450 on Debian since 1.14.0, without change till the currently installed BfW 1.14.5, but does not happen on Win7 with the Steam build (same laptop, I have two OS's installed). On Win7, animations are fine and work as expected. However, this same issue also happens on another PC desktop, with Win 7 Steam build. (This PC also produces this issue by the way).
Author of the Underness Series, consisting of V parts: The Desolation of Karlag, The Blind Sentinel, The Stone of the North, The Invasion Of The Western Cavalry, Fingerbone of Destiny
Standalone works: The Ravagers - now for 1.14, with new bugs!

Post Reply