Libvorbis.dll crashes ver 1.14.5 on win 7[edit]

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Mawmoocn
Posts: 95
Joined: March 16th, 2019, 3:54 pm

Re: Libvorbis.dll crashes ver 1.14.5 on win 7[edit]

Post by Mawmoocn » July 28th, 2019, 5:24 pm

Hello WhiteWolf,

I saw some possibilities that there are issues with old sound drivers.

This is often common with "dated" sound drivers if you're using Windows.

Some fixes include:
  • Update sound drivers to a new version
  • Revert to a generic sound driver
  • Change sound settings, to use less power or limit/lower the settings (I don’t know how to do this)
  • Uninstall sound drivers and restart or mute sound
I think it’s related with this?
What changes were made to the [music] tag ?

User avatar
WhiteWolf
Forum Regular
Posts: 522
Joined: September 22nd, 2009, 7:48 pm
Location: Hungary

Re: Libvorbis.dll crashes ver 1.14.5 on win 7[edit]

Post by WhiteWolf » August 1st, 2019, 9:18 am

Mawmoocn wrote:
July 28th, 2019, 5:24 pm
  • Update sound drivers to a new version
  • Revert to a generic sound driver
  • Change sound settings, to use less power or limit/lower the settings (I don’t know how to do this)
  • Uninstall sound drivers and restart or mute sound
Sorry for always answering late, as said, it's not my own PC and I'm not always around it. It would be just good to know what causes this, because if it can happen there, it could possibly happen for other users. I'll try some time and see if the sound driver is outdated for some reason, or what could done there.
However, I hardly see muting the sound as a solution. It's more of a workaround, but we already have that: disable the code that loads music anywhere other than main scenario files.
I think it’s related with this?
What changes were made to the [music] tag ?
Hmm, it could very well be. Maybe I'll post a notice there, see if there are any similarities between the two machines.

EDIT:
I have not yet managed to check back on that PC, but I've read on some forums, that OneDrive might cause pathing problems in Wesnoth. Maybe that issue could be related to this? As soon as I'm around, I'll check if disabling it solves anything.
Author of the Underness Series, consisting of V parts: The Desolation of Karlag, The Blind Sentinel, The Stone of the North, The Invasion Of The Western Cavalry, Fingerbone of Destiny
Standalone works: The Ravagers - now for 1.14, with new bugs!

User avatar
josteph
Developer
Posts: 631
Joined: August 19th, 2017, 6:58 pm

Re: Libvorbis.dll crashes ver 1.14.5 on win 7[edit]

Post by josteph » August 11th, 2019, 5:34 pm

Sorry for the late answer, I've been away for a couple of weeks.
WhiteWolf wrote:
July 23rd, 2019, 11:16 am
josteph wrote:
July 21st, 2019, 8:32 pm
Minimal_Crash_Macro does not load: error config: Macro/file '~add-ons/Minimal_Crash/utils' is missing at ~add-ons/Minimal_Crash_Macro/_main.cfg:36. I renamed the directory to Minimal_Crash and then it still failed to load, with error general: Failed to load the scenario (that's a really poor error message...)
Right, sorry, I forgot to replace some path names in main. Your Failed to load scenario probably comes from the map data, if you didn't replace the path there.
I can't reproduce that. If I intentionally use a wrong path in the map_data="{~add-ons/...}" line, I get the expected error message, Macro/file '...' is missing. I see where it's generated, though: https://github.com/wesnoth/wesnoth/blob ... ls.cpp#L62
WhiteWolf wrote:
July 23rd, 2019, 11:16 am
Here it is "fixed":
Minimal_Crash_Macro2.zip
For the next part: this crashes after the story Hello World text.
I installed this campaign, started it, and played the story all the way to the main map. I tried both 1.14 and 1.15 and neither crashed.
WhiteWolf wrote:
July 23rd, 2019, 11:16 am
josteph wrote: The computer that the crashes happen on, what might be unique about it? Does it run a different language, or does it have a lot of addons installed, or does it have a different version of libvorbis or libsdl, for example?
Nothing really special. The system language is Hungarian, but I have Wesnoth on other HU computers without issues. I've removed other add-ons for this duration.
Wesnoth is a Steam build with libsdl 2.0.8, I don't know how to locate the libvorbis version. In Features is says legacy bidirectional rendering is red, if that helps...
In the meantime I downloaded 1.12.6 from sourceforge, and the issue is the same as with the 1.14.7 Steam build.
"bidirectional" in this context refers to support for rendering right-to-left text, like Hebrew and Arabic. I don't think it's relevant.

Post Reply