[SOLVED] Possible bug: could stuck in The Underlevels

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
Posts: 2
Joined: September 20th, 2018, 12:09 am

[SOLVED] Possible bug: could stuck in The Underlevels

Post by Elfnet » September 20th, 2018, 1:08 am

I hesitate to call it a bug, but it caused me (and possible others) great frustration.

The problem appeared in the TheHammerofThursagan campaign's last playable map; 12. The Underlevels.

After start, the player reach a closed door on the lower middle side of the map, but after further playing, on the top of the map can unlock the door and there are runes, witch can teleport the units on the other side of the (now unlocked, but still closed) door. It is easy (and logical) to teleport the whole team to the other side of the door, but than the player is screwed.
Possibly only have some units, so can't finish the map (there are still about 50 enemies left at that point), inside all 3 forts are occupied, so can't recruit more units unless kill those enemies and
can't go back, because the teleporter rune only works one way and the player couldn't open the door from the inside, only from the outside.

The Underlevels is an extremly long map - I realized this problem after more than 150 turns and couldn't even reload an earlier stage, because at first I was preoccupied with the battle and the vanilla settings only keeps the last 10 turns.

(I attached one of my earlier save, the still closed door is next to a lone dwarf, Zamak)

Possible easy fix: allow the player, to open the door from the inside too and/or change the runes to allow teleporting back and forth, not just one way.

(in this case, the following and the hungarian language is irrelevant)

The Battle for Wesnoth version 1.14.5 (48bd45d-Modified)
Running on Microsoft Windows 8.1 (6.3.9600)

Game paths

Data dir: C:\Program Files (x86)\Steam\steamapps\common\wesnoth
User config dir: C:\Users\Elfnet\Documents\My Games\Wesnoth1.14
User data dir: C:\Users\Elfnet\Documents\My Games\Wesnoth1.14
Saves dir: C:\Users\Elfnet\Documents\My Games\Wesnoth1.14\saves
Add-ons dir: C:\Users\Elfnet\Documents\My Games\Wesnoth1.14\data\add-ons
Cache dir: C:\Users\Elfnet\Documents\My Games\Wesnoth1.14\cache


Boost: 1.66
OpenSSL/libcrypto: 1.1.0f (runtime 1.1.0f)
Cairo: 1.10.2 (runtime 1.10.2)
Pango: 1.30.1 (runtime 1.30.1)
SDL: 2.0.8 (runtime 2.0.8)
SDL_image: 2.0.3 (runtime 2.0.3)
SDL_mixer: 2.0.2 (runtime 2.0.2)
SDL_ttf: 2.0.14 (runtime 2.0.14)


Kísérleti OpenMP támogatás: yes
JPG képernyőképek: yes
Lua konzol kiegészítő: yes
Régi kétirányú renderelés: no
Win32 értesítéskezelő: yes
ThP-Az alsó bugyrok Kör 145.gz
The map in question (in hungarian, but that isn't affect the problem)
(171.62 KiB) Downloaded 89 times
Last edited by Elfnet on September 21st, 2018, 9:00 am, edited 1 time in total.

User avatar
Posts: 443
Joined: August 19th, 2017, 6:58 pm

Re: Possible bug: could stuck in The Underlevels

Post by josteph » September 20th, 2018, 10:30 pm

Sorry you got frustrated. From a gameplay perspective I agree that opening the door once someone teleports behind it would be convenient: it would save the player having to wait ~20 turns watching dwarves walking from the NW room to the locked door. However, the scenario is being massively rewritten using a new map. The rewrite will solve this problem in a different way.

In 1.14 you can load your savegame as a replay and press the "Continue Play" button to continue playing from any point in the middle, even further than 10 turns into the past.

Welcome to the forums!

Posts: 2
Joined: September 20th, 2018, 12:09 am

Re: Possible bug: could stuck in The Underlevels

Post by Elfnet » September 21st, 2018, 9:00 am

Thanks for the answer.

Post Reply