Steam error

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
EnergiaX
Posts: 17
Joined: May 12th, 2018, 10:59 am

Steam error

Post by EnergiaX » May 19th, 2018, 9:13 am

I created an add-on and I have a problem with him. I don't know why is it Steam error:

Image


I tested the version add-on on old Wesnoth (1.12) and error don't exist.
Can anyone help? Add-on is ready to download (survival map-pack by EnergiaX)

I see this error when i try created game, if i delate my addaon, error don't exist.

User avatar
Celtic_Minstrel
Developer
Posts: 1149
Joined: August 3rd, 2012, 11:26 pm
Contact:

Re: Steam error

Post by Celtic_Minstrel » May 20th, 2018, 2:38 pm

For the record, that's not a Steam error. It's an assertion failure in Wesnoth. I'm not exactly sure why it's happening, but it'll be looked into.
Author of The Black Cross of Aleron campaign and Default++ era.
Maintainer of Steelhive.

EnergiaX
Posts: 17
Joined: May 12th, 2018, 10:59 am

Re: Steam error

Post by EnergiaX » May 21st, 2018, 11:16 am

I do not know what "nature" this error.
Can someone try to download the add-on and see if the error is the same? Then I will know that it's a problem with adding

User avatar
beetlenaut
Developer
Posts: 2185
Joined: December 8th, 2007, 3:21 am
Location: Washington State
Contact:

Re: Steam error

Post by beetlenaut » May 23rd, 2018, 8:04 am

On my computer anyway, the crash is caused by the map for Save the World. There are a lot of custom map tiles, and you don't have the definitions for those. Deleting that map stops the crash from happening. (Wesnoth shouldn't crash because of this, so it is still bug, but that map wasn't going to work the way it is anyway.)

There is also an invisible character at the beginning of Save_The_World.cfg that is causing another error, though not a crash. I suspect that someone saved it with a word processor (like Microsoft Word) instead of a text editor (like notepad). I removed it for you because it might not be obvious how to do it.
Attachments
Save_The_World.cfg
(8.17 KiB) Downloaded 40 times
Campaigns: Dead Water
The Founding of Borstep
Secrets of the Ancients

EnergiaX
Posts: 17
Joined: May 12th, 2018, 10:59 am

Re: Steam error

Post by EnergiaX » May 24th, 2018, 3:06 pm

beetlenaut wrote:
May 23rd, 2018, 8:04 am
There are a lot of custom map tiles, and you don't have the definitions for those.
I use only deafult titles... How can I fix this?


Thx for files, I check.
In the comment there were special characters that could cause an error, it is also possible to vary the utf -8 formatting (previous version have UTF 8 +BOM)

However, despite the upload of your file, the same error occurs.

User avatar
beetlenaut
Developer
Posts: 2185
Joined: December 8th, 2007, 3:21 am
Location: Washington State
Contact:

Re: Steam error

Post by beetlenaut » May 24th, 2018, 11:08 pm

EnergiaX wrote:
May 24th, 2018, 3:06 pm
I use only deafult titles... How can I fix this?
error config: map could not be loaded: Unknown tile in map: (SpaY) 'SpaY'

There are many other unknown tiles too.
EnergiaX wrote:
May 24th, 2018, 3:06 pm
(previous version have UTF 8 +BOM)
Wesnoth doesn't like the BOM, but it doesn't cause a crash.
EnergiaX wrote:
May 24th, 2018, 3:06 pm
However, despite the upload of your file, the same error occurs.
Yes, because the map causes the crash. I used a different map in the Save_The_World.cfg, and both add-ons loaded.
Campaigns: Dead Water
The Founding of Borstep
Secrets of the Ancients

EnergiaX
Posts: 17
Joined: May 12th, 2018, 10:59 am

Re: Steam error

Post by EnergiaX » May 27th, 2018, 1:01 pm

I did some tests.
Generally, the map was normally opened in the editor. But, when i delete add-on, I have such an error [like yours].
In the editor, I had to accidentally use a tile that is defined in another add-on.
Only that, in this way I do not have given coordinates of this field, also I do not know from which addition I took it [I use "all"]
I do a manual search, but it takes a while.

Ok, i find one tiles. Is "BrYm" - Marble Bricks (flat), it's nice and I would not like to replace it. What can I do with it, since I "see" this tile?

EnergiaX
Posts: 17
Joined: May 12th, 2018, 10:59 am

Re: Steam error

Post by EnergiaX » May 27th, 2018, 4:51 pm

I think I understood.
This tile is not defined for me, so if I try to launch my map, this is a mistake.
After a long search I found these tiles. "UTP Archaic Resources" there is this Angeless Era or UMC_Terrain_Pack.
so I added to my server.pbl file "dependencies" - UMC_Terrain_Pack.

It was very difficult.
Can you check now? There should be no errors with the map. Unfortunately, the error still exists.

User avatar
beetlenaut
Developer
Posts: 2185
Joined: December 8th, 2007, 3:21 am
Location: Washington State
Contact:

Re: Steam error

Post by beetlenaut » May 27th, 2018, 6:07 pm

EnergiaX wrote:
May 27th, 2018, 4:51 pm
I added to my server.pbl file "dependencies" - UMC_Terrain_Pack....Unfortunately, the error still exists.
Putting the dependency in the .pbl file just requires people to download the dependency if they download your add-on. You still need to connect your add-on to the terrain pack. Put a line in your _main.cfg file to load the UMC_Terrain_Pack folder like you load your own util or map folders.
Campaigns: Dead Water
The Founding of Borstep
Secrets of the Ancients

EnergiaX
Posts: 17
Joined: May 12th, 2018, 10:59 am

Re: Steam error

Post by EnergiaX » May 28th, 2018, 8:44 am

Okay, I do not know how.

If add at section #ifdef MULTIPLAYER in _main.cfg:
{~add-ons/UMC_Terrain_Pack}
Still error.

If add at section [multiplayer] in Save_the_World.cfg
{~add-ons/UMC_Terrain_Pack}
Still error.

If add single file {~add-ons/UMC_Terrain_Pack\utils\Archaic_Resources\AR_terrain.cfg}
Still error.

Help!

User avatar
Pentarctagon
Forum Administrator
Posts: 3460
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: Steam error

Post by Pentarctagon » May 28th, 2018, 2:46 pm

I think he meant to use [binary_path].
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code

User avatar
Ravana
Moderator
Posts: 1795
Joined: January 29th, 2012, 12:49 am
Location: Estonia

Re: Steam error

Post by Ravana » May 28th, 2018, 3:04 pm

Binary path only affects resources, not using it doesnt cause errors.

User avatar
beetlenaut
Developer
Posts: 2185
Joined: December 8th, 2007, 3:21 am
Location: Washington State
Contact:

Re: Steam error

Post by beetlenaut » May 28th, 2018, 4:38 pm

EnergiaX wrote:
May 28th, 2018, 8:44 am
Okay, I do not know how.
Try {~add-ons/UMC_Terrain_Pack/utils/Archaic_Resources} in _main.cfg. I didn't know the structure of the terrain pack before. That's why I just told you to add the folder instead of being more specific. Now I can see what the folder you are trying to include is called. Actually, including the single .cfg file probably would have worked too, but you mixed slashes with back slashes, and BfW expects slashes.
Campaigns: Dead Water
The Founding of Borstep
Secrets of the Ancients

EnergiaX
Posts: 17
Joined: May 12th, 2018, 10:59 am

Re: Steam error

Post by EnergiaX » May 28th, 2018, 8:56 pm

beetlenaut wrote:
May 28th, 2018, 4:38 pm
Try {~add-ons/UMC_Terrain_Pack/utils/Archaic_Resources} in _main.cfg.
Near.

But that's a bit of my fault. When creating a different map, I discovered that the order matters. Earlier I thought that it did not matter, because once I was programming. How? I set [side] side=2 {bla} [/side] [side] side=1 {bla} [/side]. And I wondered why player 1 is a player, if Ai should be. How I changed the order [side] side=1 {bla} [/side]. [side] side=2 {bla} [/side] it worked properly.

What does this have to do with the topic? Well in my file: (before)

Code: Select all

#ifdef MULTIPLAYER
{~add-ons/EnergiaX_Survival/macros}
{~add-ons/EnergiaX_Survival/map_cfg}
{~add-ons/UMC_Terrain_Pack/utils/Archaic_Resources}
#endif
how I changed to

Code: Select all

#ifdef MULTIPLAYER
{~add-ons/UMC_Terrain_Pack/utils/Archaic_Resources}
{~add-ons/EnergiaX_Survival/macros}
{~add-ons/EnergiaX_Survival/map_cfg}
#endif
Second map (I created new map with a bad tile for testing) loaded in multiplayer mode without error!
Unfortunately, there was no tile, only a black field and map Save_the_word still generated errors.
That's why I wrote "Near".

I'll do more tests to eliminate the error altogether. However, I am wondering why it does not load this tile, instead there is a black field.


Ok tests went faster than I thought. Finally, after looking at the exact files, it was enough to do:

Code: Select all

#ifdef MULTIPLAYER
{~add-ons/UMC_Terrain_Pack/load_UTP.cfg}
{~add-ons/EnergiaX_Survival/macros}
{~add-ons/EnergiaX_Survival/map_cfg}
#endif

Interestingly, {~add-ons/UMC_Terrain_Pack} it does not work itself.

The tiles are displayed and there are no more "steam error". problem solved.
Thank all very much for your commitment. I would not think about it myself. Again thank you very much !

User avatar
beetlenaut
Developer
Posts: 2185
Joined: December 8th, 2007, 3:21 am
Location: Washington State
Contact:

Re: Steam error

Post by beetlenaut » May 28th, 2018, 11:02 pm

EnergiaX wrote:
May 28th, 2018, 8:56 pm
I'll do more tests to eliminate the error altogether. However, I am wondering why it does not load this tile, instead there is a black field.
This is because terrains need two tags, which are probably in different files. One tag has the terrain definition (which you were loading), the other tag tells what graphics to display (which you were apparently not loading).
EnergiaX wrote:
May 28th, 2018, 8:56 pm
But that's a bit of my fault. When creating a different map, I discovered that the order matters.
Oh, yes. You have to include the terrain definitions before the map that uses them. I probably should have mentioned that.
EnergiaX wrote:
May 28th, 2018, 8:56 pm
Interestingly, {~add-ons/UMC_Terrain_Pack} it does not work itself.
Including a folder includes all the files within it, but not the subfolders.
EnergiaX wrote:
May 28th, 2018, 8:56 pm
Again thank you very much !
You're welcome. Have fun.
Campaigns: Dead Water
The Founding of Borstep
Secrets of the Ancients

Post Reply