last devel not working 03/31/2018 label 1.15

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
phocasbyz
Posts: 12
Joined: February 4th, 2018, 12:31 pm

last devel not working 03/31/2018 label 1.15

Post by phocasbyz » March 31st, 2018, 2:17 pm

hello

with a fresh build from the git
git pull
scons

Code: Select all

version 1.15.0-dev (d0a2fde2-Modified)
Running on Ubuntu 17.10

Libraries
=========
Boost:             1.62
OpenSSL/libcrypto: 1.0.2g  (runtime 1.0.2g)
Cairo:             1.14.10 (runtime 1.14.10)
Pango:             1.40.12 (runtime 1.40.12)
SDL:               2.0.6   (runtime 2.0.6)
SDL_image:         2.0.1   (runtime 2.0.1)
SDL_mixer:         2.0.1   (runtime 2.0.1)

Features
========
Experimental OpenMP support:    no
JPG screenshots:                no
Lua console completion:         yes
Legacy bidirectional rendering: yes
D-Bus notifications back-end:   yes
the game is "half working"

i have no cache, no add-on no saved game from a previous version

* the main screen seems as usual (preferences, tutorial, campaign, ...)
* you can start a new campaign (i tried with 3 differents with the same result)
* the intro screens with the story runs fine

!!! but the game screen is broken
! all the top counters have 0 value (villages, gold,...)
! the menu and action buttons are not working
! il you select a unit it is not showd n the right column
! if you right-clic to recrut a unit it will be build but not in the hex where you made the click

i tried the flakpak version with the same result

i tried scons -force build with the same result

here is an exemple
Image

i tried a debug too

Code: Select all

Reading symbols from ./wesnoth...(no debugging symbols found)...done.
(gdb) run
Starting program: /home/phocas/wesnoth-dev/wesnoth 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffe863b700 (LWP 8677)]
Battle for Wesnoth v1.15.0-dev (d0a2fde2-Modified)
Started on Sat Mar 31 15:31:41 2018

Automatically found a possible data directory at /home/USER/wesnoth-dev

Data directory:               /home/USER/wesnoth-dev
User configuration directory: /home/USER/.config/wesnoth
User data directory:          /home/USER/.local/share/wesnoth/1.15
Cache directory:              /home/USER/.cache/wesnoth

[New Thread 0x7fffd4f5c700 (LWP 8678)]
[New Thread 0x7fffd4f1b700 (LWP 8679)]
Setting mode to 1920x1031
[New Thread 0x7fffbffff700 (LWP 8680)]
[Thread 0x7fffbffff700 (LWP 8680) exited]
Checking lua scripts... ok
[New Thread 0x7fffbffff700 (LWP 8682)]
[Thread 0x7fffbffff700 (LWP 8682) exited]
[New Thread 0x7fffbffff700 (LWP 8683)]
[Thread 0x7fffbffff700 (LWP 8683) exited]
[New Thread 0x7fffbffff700 (LWP 8684)]
[Thread 0x7fffbffff700 (LWP 8684) exited]

<< after using the mouse ==>>
20180331 15:33:19 warning gui/event: distributor mouse button right [game_ui]: SDL right button up. The mouse button is already up, we missed an event.
20180331 15:52:43 warning gui/event: distributor mouse button left [game_ui]: SDL left button up. The mouse button is already up, we missed an event.
20180331 15:52:48 warning gui/event: distributor mouse button left [game_ui]: SDL left button up. The mouse button is already up, we missed an event.
20180331 15:56:18 warning gui/event: distributor mouse button right [game_ui]: SDL right button up. The mouse button is already up, we missed an event.
20180331 15:56:28 warning gui/event: distributor mouse button right [game_ui]: SDL right button up. The mouse button is already up, we missed an event.

^C
Thread 1 "wesnoth" received signal SIGINT, Interrupt.
0x00007ffff707e99e in __pthread_mutex_unlock_usercnt (decr=1, mutex=0x555558ef3190)
    at pthread_mutex_unlock.c:55
55	pthread_mutex_unlock.c: Aucun fichier ou dossier de ce type.

User avatar
Pentarctagon
Forum Administrator
Posts: 3517
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: last devel not working 03/31/2018 label 1.15

Post by Pentarctagon » March 31st, 2018, 2:34 pm

Current master is in the process of getting rewritten to use hardware acceleration for rendering, so it's not really playable at the moment and will likely stay that way for a time. Sticking to the 1.14 branch would be a better idea, at least until everything gets sorted out and completed.
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code

phocasbyz
Posts: 12
Joined: February 4th, 2018, 12:31 pm

Re: last devel not working 03/31/2018 label 1.15

Post by phocasbyz » March 31st, 2018, 2:39 pm

thanks for the explanation

good luck on the 1.15 road

Post Reply