[BUG]Wesnoth 1.10.7 - Lobby sounds in Preferences

Having trouble with the game? Report issues and get help here. Read this first!

Moderator: Forum Moderators

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
Iceblade
Posts: 13
Joined: June 19th, 2014, 1:35 pm

[BUG]Wesnoth 1.10.7 - Lobby sounds in Preferences

Post by Iceblade »

The lobby sounds can still be heard when "Preferences" -> "Advanced" -> "Lobby Sounds" is set to "no".

Windows XP Professional, SP3
Language US English or System Default
User avatar
iceiceice
Developer
Posts: 1056
Joined: August 23rd, 2013, 2:10 am

Re: [BUG]Wesnoth 1.10.7 - Lobby sounds in Preferences

Post by iceiceice »

I tested this and looked at the code, it seems that that preference is only designed to silence some of the sounds you hear in the lobby, and it is successfully silencing those. I'm not sure if we should regard the others as a bug or not...

The others can be silenced by muting User interface sounds, in Preferences -> Sounds.

Edit: Actually, I was wrong, the preference doesn't affect the lobby that you actually see in the game, it doesn't appear to do anything right now.
I have made a patch to fix this for the next 1.11 series release.

Edit: Committed. After this patch, the lobby sounds feature will block the "arrive" and "leave" sounds in the lobby. You will still get sounds for
  • Server messages
  • Whispers to you
  • Chats from friends
in the lobby. You will still get "arrive" and "leave" sounds if you have joined or hosted a game which is still waiting to start, since that state is considered different from the lobby.
Post Reply