Wesnoth 1.9.8 crashes on first campaign on OS X Lion

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
ionux
Posts: 2
Joined: August 9th, 2011, 9:47 pm

Wesnoth 1.9.8 crashes on first campaign on OS X Lion

Post by ionux » August 9th, 2011, 10:03 pm

Hello, new forum user here. I just updated my slightly older Macbook Pro to Lion and downloaded Wesnoth 1.9.8. First of all, it won't run at all in fullscreen mode. In windowed mode, it runs but sporadically crashes. I've attached the last three crash reports from today where I was attempting the first single player campaign.

On another note, the sound stutters pretty badly any time a unit is killed. The entire game pauses for a second or two before it plays the death sound. Don't know if that's related, but wanted to include that info for your debugging pleasure.
Attachments
Wesnoth_2011-08-09-131107.txt
(40.62 KiB) Downloaded 51 times
Wesnoth_2011-08-09-125235.txt
(39.45 KiB) Downloaded 54 times
Wesnoth_2011-08-09-121600.txt
(38.66 KiB) Downloaded 48 times

User avatar
Dunno
Posts: 773
Joined: January 17th, 2010, 4:06 pm
Location: Behind you

Re: Wesnoth 1.9.8 crashes on first campaign on OS X Lion

Post by Dunno » August 9th, 2011, 10:16 pm

Have you tried any other Wesnoth versions? You see, there was a similar thread, but concerning Wesnoth 1.8.6. link
Besides, playing unstable version of game on unstable (or barely stable) version of OS is just asking for trouble :wink:
Oh, I'm sorry, did I break your concentration?

ionux
Posts: 2
Joined: August 9th, 2011, 9:47 pm

Re: Wesnoth 1.9.8 crashes on first campaign on OS X Lion

Post by ionux » August 9th, 2011, 10:17 pm

Yes, just downloaded 1.8.6 and it does the same thing. :(

ozean
Posts: 90
Joined: September 27th, 2005, 5:19 pm
Location: Norway
Contact:

Re: Wesnoth 1.9.8 crashes on first campaign on OS X Lion

Post by ozean » August 10th, 2011, 8:52 am

The issue affects all Wesnoth versions under Lion. There have been a few posts on this in the SDL developer forums: http://forums.libsdl.org/viewforum.php?f=1

Post Reply