Quick loading in mp campaigns messes up side info

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
User avatar
Bob_The_Mighty
Posts: 813
Joined: July 13th, 2006, 1:15 pm

Quick loading in mp campaigns messes up side info

Post by Bob_The_Mighty »

Whilst working on a multiplayer campaign, jb and I discovered that infomation such as gold, recalls and unit xp are lost if the following steps are taken:

1. play a turn of a mp campaign in local game mode
2. reload to a previous turn from the drop-down menu
3. complete the scenario

Once the next scenario begins, the player sides have reverted to how they were at the moment of the save.

However, if you reload the game from the main wesnoth title screen this problem does not occur.

I have replicated this bug on Legend of Wesmere. I'm using Windows XP and Wesnoth 1.8.4.

I've posted a bug report here: https://gna.org/bugs/index.php?18269.
My current projects:
MP pirate campaign: The Altaz Mariners
RPG sequel: Return to Trent
MP stealth campaign: Den of Thieves

User avatar
jb
Multiplayer Contributor
Posts: 496
Joined: February 17th, 2006, 6:26 pm
Location: Chicago

Re: Quick loading in mp campaigns messes up side info

Post by jb »

I not 100% sure, but I think the problem is specifically if you reload an MP campaign game without refreshing the cache.
My MP campaigns
Gobowars
The Altaz Mariners - with Bob the Mighty

mich
Translator
Posts: 134
Joined: November 11th, 2008, 8:54 am
Location: Italy

Re: Quick loading in mp campaigns messes up side info

Post by mich »

Bob_The_Mighty wrote: However, if you reload the game from the main wesnoth title screen this problem does not occur.
If I recall correctly, the bug is still present if you reload from the title screen. The only "correct" way to reload a multiplayer campaign is to choose "multiplayer" from the main menu, and then load the game from the "create game" screen.
I'm not sure, but probably this was already reported in the past, cause I found the workaround in at least a couple of tread in the forum.
Surely it can became quickly boring to pass by the multiplayer load screen when you play a local game (especially during test and debug)....

User avatar
Bob_The_Mighty
Posts: 813
Joined: July 13th, 2006, 1:15 pm

Re: Quick loading in mp campaigns messes up side info

Post by Bob_The_Mighty »

Yes, what I meant to say was it works if you return to the title screen then do Multiplayer>Local Game>Load Game. It doesn't work if you load directly from the title screen or load it from the in-game menu.

So to clarify, I have found that you do not need to restart Wesnoth; returning to the title screen is enough to ensure the save loads properly.
My current projects:
MP pirate campaign: The Altaz Mariners
RPG sequel: Return to Trent
MP stealth campaign: Den of Thieves

Post Reply