Missing WML child

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
Molean
Posts: 157
Joined: July 25th, 2009, 7:11 pm

Missing WML child

Post by Molean » April 27th, 2010, 10:48 am

I was in a game with other players, suddenly I was unable to move and and noone would reply, in short the game had dropped me and not told me.

So I go back into the game, after waiting a long time to get past the reply, I was reassigned my spot. Someone had left and I was assigned their spot, but I couldn't move the unit.

Shortly after this I got the following error which disconnected me again. (I think that is generally what happened, I haven't been able to connect to the forum either, and I am really tired and finding it hard to recall, but I wrote down the error exactly)
Error while reading the WML:
Mandatory WML child is missing yet untested for please report.

Mastix
Posts: 13
Joined: April 6th, 2010, 3:06 am

Re: Missing WML child

Post by Mastix » April 27th, 2010, 11:08 am

Me, and many, MANY others already reported this bug, and it's already fixed for the next version of the game:
http://forums.wesnoth.org/viewtopic.php?f=4&t=29487

User avatar
Devas
Posts: 51
Joined: April 22nd, 2009, 4:35 pm

Re: Missing WML child

Post by Devas » April 29th, 2010, 5:51 pm

The bug I just experienced isn't a "missing child error" but it's related to it, and I don't want to open a new thread just for it.
So, err, I was playing some survival and one of my spearmen had 8/24XP. I decided to level it up so I managed to get it to kill a Troll Rocklobber, but right at the finish blow I got a missing child error which made me quit. When I came back, the host gave me my side back and that spearman had 24/24XP but whithout option to level him up.
I am reporting this bug (which I think is more of a glitch than a bug) because it angered me that a mage spawned right when I ended my turn and killed the spearman before my next turn.

RustyGator334
Posts: 1
Joined: June 10th, 2018, 4:04 am

Re: Missing WML child

Post by RustyGator334 » June 18th, 2018, 4:16 pm

every time i try to create a game with one of my custom maps the game gives me the same error message. what does it even mean

Shiki
Developer
Posts: 231
Joined: July 13th, 2015, 9:53 pm
Location: Germany

Re: Missing WML child

Post by Shiki » June 18th, 2018, 4:46 pm

Welcome to the Forums

Please fill an bug report at https://bugs.wesnoth.org and include a map which causes this issue.
And are you using 1.14.x or a version of the 1.13.x series — if so, please retry with 1.14.3, as such a bug has been fixed during 1.13.x.

In the future, please start a new thread instead of writing in an 8 years old one — people may have talked about a different bug in wesnoth 1.8.x.
Maintainer of Era of Myths.
Introduction to WML filtering and WML variables.

Post Reply