Little problem with ambush (1.7.6)

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
mich
Translator
Posts: 134
Joined: November 11th, 2008, 8:54 am
Location: Italy

Little problem with ambush (1.7.6)

Post by mich »

Playing without fog, the hidden unit isn't suddenly displayed when it has an enemy unit near, but only after you click on another unit or scroll the screen. Probably the screen isn't refreshed after the ambush event. The problem doesn't show always, but most of the time (without fog). A screenshot of the problem
ambush.jpg
As you can see, the red elvish ranger in the forest isn't displayed (but he appears if I click on any units).
Not a big problem after all.
Operating system windows vista (not tried on linux, I will try it in the afternoon). The bug is absent from the 1.6.x line.

AI
Developer
Posts: 2394
Joined: January 31st, 2008, 8:38 pm

Re: Little problem with ambush (1.7.6)

Post by AI »

If you don't want to upload a big file, please crop your image rather than scaling it. An image scaled down this much is hard to read.

mich
Translator
Posts: 134
Joined: November 11th, 2008, 8:54 am
Location: Italy

Re: Little problem with ambush (1.7.6)

Post by mich »

Well, there isn't much to see, but here it's a cropped image.
ambushproblem.jpg
ambushproblem.jpg (20.86 KiB) Viewed 796 times
As you can see the wose isn't displayed (until I click on some other units). I wasn't able to reproduce it on linux.
I have also noted that for leaders ambush doesn't work on turn 1 (this happens in 1.7.6 but also in the 1.6 line). There was already a bug report for this at gna, but it's marked as fixed and it's really old (2005). An image to show the problem
ambush_not_working_on_turn1.jpg
ambush_not_working_on_turn1.jpg (15.04 KiB) Viewed 796 times

Alink
Inactive Developer
Posts: 181
Joined: March 5th, 2007, 6:45 am
Location: Belgium

Re: Little problem with ambush (1.7.6)

Post by Alink »

The first 1.7.6 bug is now fixed in svn-trunk (r39124). Thanks, for the report. Indeed, we refreshed his hex before mark it as now visible.

I confirm the other leader bug. Really weird, but I didn't hunt the bug yet.

Alink
Inactive Developer
Posts: 181
Joined: March 5th, 2007, 6:45 am
Location: Belgium

Re: Little problem with ambush (1.7.6)

Post by Alink »

The second bug about leader is now also fixed in svn-trunk (r39125)
The old hack about using hidden=yes to avoid this bug, is now useless.

Post Reply