1.6.4 Dialog/Menu Item text display issues?

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
Aerylle
Posts: 3
Joined: July 10th, 2009, 6:57 pm

1.6.4 Dialog/Menu Item text display issues?

Post by Aerylle »

Not sure if I'm correctly following the guidelines for technical help as my problem isn't exactly a bug, but anyway....

I just recently uninstalled BfW 1.6.2, downloaded BfW 1.6.4, and installed it. Didn't exactly know how to copy userdata over to the new installation, so I moved the folder userdata into the new directory, and hoped everything would work. It did, but suddenly all dialog, and most menu items displayed text in boxes. (images attached)

I tried removing the userdata folder (it might be irrelevant), uninstalling and reinstalling 1.6.4, but the problem persisted. I have no idea what's causing the problem, maybe language/regional issues...? I'm running Windows Vista Business SP1.

Any help would be much appreciated!
Attachments
campaigndialog.jpg
multiplayermenu.jpg
addonmenu.jpg

penguin
macOS Packager
Posts: 239
Joined: April 17th, 2004, 5:16 pm
Location: Ontario, Canada
Contact:

Re: 1.6.4 Dialog/Menu Item text display issues?

Post by penguin »

Looks like Pango didn't find a font to use. What language are you using?

EDIT: Turuk pointed out you're probably using English. The problem is still the same though, and I don't know anything more - this is loonycyborg's domain.

Aerylle
Posts: 3
Joined: July 10th, 2009, 6:57 pm

Re: 1.6.4 Dialog/Menu Item text display issues?

Post by Aerylle »

Well, the system locale for non-unicode programs is set to Japanese on my computer... but I'm not really sure that's the issue. I checked the stderr.txt just in case and it says "Could not open 'C:/Program Files/Battle for Wesnoth 1.6.4/userdata/preferences' for reading." Is that the problem...?

User avatar
loonycyborg
Windows Packager
Posts: 280
Joined: April 1st, 2008, 4:45 pm
Location: Russia/Moscow

Re: 1.6.4 Dialog/Menu Item text display issues?

Post by loonycyborg »

Aerylle wrote:Not sure if I'm correctly following the guidelines for technical help as my problem isn't exactly a bug, but anyway....

I just recently uninstalled BfW 1.6.2, downloaded BfW 1.6.4, and installed it. Didn't exactly know how to copy userdata over to the new installation, so I moved the folder userdata into the new directory, and hoped everything would work. It did, but suddenly all dialog, and most menu items displayed text in boxes. (images attached)
Copying userdata shouldn't be necessary provided that you chose to place userdata in Documents/My Games in the installer and run wesnoth with the start menu shortcut.
I tried removing the userdata folder (it might be irrelevant), uninstalling and reinstalling 1.6.4, but the problem persisted. I have no idea what's causing the problem, maybe language/regional issues...? I'm running Windows Vista Business SP1.
Could you try uninstalling and installing 1.6.2 again to confirm whether its a bug introduced between 1.6.2 and 1.6.4?
"meh." - zookeeper

Aerylle
Posts: 3
Joined: July 10th, 2009, 6:57 pm

Re: 1.6.4 Dialog/Menu Item text display issues?

Post by Aerylle »

I'll do that, though it seems the "problem" exists in 1.7.1 as well. The same thing occurred with a fresh install of 1.7.1. I'll see if reverting back to 1.6.2 solves it.

DarthChef
Posts: 2
Joined: June 5th, 2009, 3:48 am

Re: 1.6.4 Dialog/Menu Item text display issues?

Post by DarthChef »

I've got the same problem. Cant see text in most of the pop up windows. Just downloaded 1.6.4 twice today with the same problem. Didn't have any of this with 1.6.3.

I'm using the English language setting, but my windows default language is Korean. Maybe the problem is because of the Korean Windows XP interface?

Hmmmm.. thankfully, I restarted my computer today and Wesnoth 1.6.4 is running just fine now.

Statue
Posts: 10
Joined: May 15th, 2008, 2:21 pm

Re: 1.6.4 Dialog/Menu Item text display issues?

Post by Statue »

Same issue for me running 1.6.4 on XP Pro SP3. Had just uninstalled 1.6.3 prior to installing 1.6.4, the issue was not present in the previous 1.6.3 installation of Wesnoth. Doubt text localization is involved, as my PC windows default language is English.

I have noted something odd regarding the userdata folder in 1.6.4. The previous 1.6.3 installation stored userdata preferences and saves in Documents\My Games\Wesnoth 1.6. During installation of 1.6.4, I selected the option to store user data in My Documents\My Games\Wesnoth 1.6, but I note the following: nothing changed in Documents\My Games\Wesnoth 1.6 (guess that's to be expected and is desired, the idea being my saves and preferences from 1.6.3 would be retained for the new 1.6.4 installation), however, trying to load a saved game in the newly installed 1.6.4 results in Wesnoth reporting no saved games being available, and a check within Wesnoth 1.6.4's main installation directory shows a userdata folder - the last two points leading me to believe that either something different about 1.6.4's installation or the already existing Wesnoth 1.6 folder in Documents\My Games\ prevented 1.6.4 from creating/using it, and it somehow defaulted to creating a brand new user folder in the game's main installation directory and set itself to look there for user content. I'm not at all sure whether this behaviour has anything at all to do with the garbled font issue, but it might be involved (and is certainly a separate issue for me to deal with as I have loads of user created campaigns and saves I need - I suspect I can as a workaround just copy and paste the contents of my old Documents\My Games\Wesnoth 1.6 into the userdata folder 1.6.4 created?

Statue
Posts: 10
Joined: May 15th, 2008, 2:21 pm

Re: 1.6.4 Dialog/Menu Item text display issues?

Post by Statue »

The stderr.txt file reports the following:

Battle for Wesnoth v1.6.4
Started on Fri Aug 07 12:57:26 2009

Automatically found a possible data directory at H:/Program Files/Battle for Wesnoth 1.6.4
20090807 12:57:26 error filesystem: Could not open 'H:/Program Files/Battle for Wesnoth 1.6.4/userdata/preferences' for reading.

Data directory: H:/Program Files/Battle for Wesnoth 1.6.4
User configuration directory: H:/Program Files/Battle for Wesnoth 1.6.4/userdata

Checking video mode: 1024x768x32...
setting mode to 1024x768x32

That shows a problem opening the preferences file, and also confirms my installation has despite my installation options designated a newly created userdata folder within the main install folder as the location for user data.

Statue
Posts: 10
Joined: May 15th, 2008, 2:21 pm

Re: 1.6.4 Dialog/Menu Item text display issues?

Post by Statue »

Apologies for the triple post, second post contents wouldn't fit in first post and this 3rd post is a hopefully useful update.

Uninstalled and rebooted, then reinstalled and everything working as intended now (fonts not garbled, and it is correctly looking for saves and preferences in the old Wesnoth 1.6 folder in Documents/My Games/

Can only guess that problems occured because I played and uninstalled 1.6.3 in the same session as installing 1.6.4, so anyone experiencing similar font or user directory issues when installing 1.6.4 might want to try simply uninstalling and doing a reboot prior to a clean install. Not sure why the reboot should be needed but appears it was for me *shrugs*.

Post Reply