Broken dependencies when installing Wesnoth in Ubuntu Gutsy

Having trouble with the game? Report issues and get help here. Read this first!

Moderator: Forum Moderators

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
User avatar
TheChosenOne
Posts: 245
Joined: April 7th, 2006, 8:26 am
Location: Royal Palace, Weldyn St. 01, Wesnoth 123 456

Broken dependencies when installing Wesnoth in Ubuntu Gutsy

Post by TheChosenOne »

I'm not sure if this is the right place to post this, but since this concerns Wesnoth also, I suppose I can post it here.

For some unfathomable reason, my WIndows XP is unable to connect to the internet, even when the modem, connection and everything else are perfectly fine. Hence, I have decided to stick to my Ubuntu from now on.

I have Ubuntu Gutsy 7.1 (quite old, I know) which has 1.2.6 ready to be installed in the Synaptic Packager, but of course what I want to install is 1.6.

So I downloaded the installer from getdeb.net, and installed wesnoth-data and wesnoth-music successfully. However, when I tried to install the wesnoth-core file, it gives this error:
"Error: Dependency is not satisfiable: libboost-regex-dev"

OK, so I downloaded it from the Ubuntu website and attempted to install it, a similar error comes"
"Error: Dependency is not satisfiable: libboost-dev"

I then downloaded this file as well and attempted to install it. Everything seemed fine...except in the end, when it gives this error
"Error: Failed to satisfy all dependencies (broken cache)

Upon checking the broken file using the 'broken' filter in Synaptic Manager, I found out that it was the libboost-serialization-dev file, which was attached to the libboost-dev file. I have tried to remove it completely, reinstalled it, downloaded it directly from the Ubuntu website, but to no avail.

Could someone please help me? I would really hate to stop playing Wesnoth just because of an installation fix that I was not aware of.

Thanks in advance.
Numbers do not win a battle
---Konrad III
(A loyal member of the pro-loyalists)

Would you like to translate the Battle of Wesnoth into Indonesian? Then come and join us at http://www.wesnoth.org/wiki/IndonesianTranslation
User avatar
TofuOgre
Posts: 23
Joined: April 25th, 2009, 12:25 am

Re: Broken dependencies when installing Wesnoth in Ubuntu Gutsy

Post by TofuOgre »

I had the same error using Kubuntu 8.04, except I could not find it on Synaptic Manager.

I had to download and compile from http://www.boost.org/

Not too sure what Boost does, but it about 200Mb in size.

As for the newest Ubuntu 9.04 version, I would not upgrade to that seeing how many people are posting problems with SDL libraries.
Post Reply