Problem with wesnoth (images cannot be found).

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
uzytkownik
Posts: 126
Joined: April 19th, 2008, 7:12 pm
Contact:

Problem with wesnoth (images cannot be found).

Post by uzytkownik » August 18th, 2008, 7:52 am

I've played before weekend an campaign (unstoppable legion). During weekend I was out and when I returned I keep getting errors when I try to load:

Code: Select all

error general: An error due to possible invalid WML occured
The error message is :
Could not get image for terrain: Hh.
 
When reporting the bug please include the following error message :
Condition 'false' failed at minimap.cpp:88 in function 'getMinimap'.
Other strange errors are:

Code: Select all

error display: Could not find game logo
What's wrong?

User avatar
anakayub
Moderator Emeritus
Posts: 518
Joined: May 3rd, 2007, 12:44 pm
Location: Malaysia
Contact:

Re: Problem with wesnoth (images cannot be found).

Post by anakayub » August 18th, 2008, 8:36 am

Have you tried reinstalling? Which OS are you using? Which version?
Take a breath.

uzytkownik
Posts: 126
Joined: April 19th, 2008, 7:12 pm
Contact:

Re: Problem with wesnoth (images cannot be found).

Post by uzytkownik » August 18th, 2008, 9:54 am

1. No (well - I've just run emerge -1 wesnoth)
2. GNU/Linux
3. Gentoo 2008.0 Developer ~x86

uzytkownik
Posts: 126
Joined: April 19th, 2008, 7:12 pm
Contact:

Re: Problem with wesnoth (images cannot be found).

Post by uzytkownik » August 18th, 2008, 10:51 am

1. Yes. Nothing changed.

Blues
Posts: 32
Joined: March 25th, 2008, 1:37 am

Re: Problem with wesnoth (images cannot be found).

Post by Blues » August 18th, 2008, 12:28 pm

Same here. For instance PNG images in terrain directory are corrupted. I tried to install 1.4.2, 1.4.4 and 1.5.2+svn. All the same. Tarballs in Gentoo portage pass integrity check. Does it mean decompression software is broken? Something wrong with libpng? I'm totally baffled.

User avatar
loonycyborg
Windows Packager
Posts: 273
Joined: April 1st, 2008, 4:45 pm
Location: Russia/Moscow

Re: Problem with wesnoth (images cannot be found).

Post by loonycyborg » August 18th, 2008, 12:34 pm

Yes. It's broken libpng:
http://bugs.gentoo.org/show_bug.cgi?id=234916

That's why I run stable branch :)
"meh." - zookeeper

uzytkownik
Posts: 126
Joined: April 19th, 2008, 7:12 pm
Contact:

Re: Problem with wesnoth (images cannot be found).

Post by uzytkownik » August 18th, 2008, 3:01 pm

loonycyborg wrote:Yes. It's broken libpng:
http://bugs.gentoo.org/show_bug.cgi?id=234916

That's why I run stable branch :)
~x86 is much more fun ;)

Blues
Posts: 32
Joined: March 25th, 2008, 1:37 am

Re: Problem with wesnoth (images cannot be found).

Post by Blues » August 19th, 2008, 12:13 pm

Yep, if you want the thrill go with ~. Everybody decides for themselves.

BTW, the problem is fixed in libpng-1.2.31.

Post Reply