SLOW Performance Issues: post here to report

Having trouble with the game? Report issues and get help here. Read this first!

Moderator: Forum Moderators

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
Posts: 5
Joined: August 24th, 2007, 8:39 am

Post by MageRain »

For the games which load all right and play ok: 120 KB.
For the games with freezing problems: 1.2 MB.
Posts: 5
Joined: August 24th, 2007, 8:39 am

Post by MageRain »

Also when I load this huge save and try to recall units, recall list is allright. But when I save this game and then reload, then recall list has 7 duplicates of each unit I can recall. Including 7 replicas of Etheileil and Minister Someone who are actually heroes. And when I recall them they have that blue shield too. Don't know what happens if you lose duplicate Etheilel, but I guess you lose.
User avatar
Drake General
Posts: 103
Joined: July 23rd, 2007, 2:38 pm

Post by Drake General »

I have also noticed the problem with lag time before selecting units, but on 1.3.7. I think part of the lag in between turns and on your turn might be the idle animations. I've almost never seen a smooth, finished idle animation. they always jerk back to the position they were standing. The autosaves are also nice, but like mentioned, they lag the game.
Windows XP
Unsure about the rest of the data, sorry :(
I don't rock the world.
How can I rock the world if I don't understand all of it?
Posts: 1
Joined: October 5th, 2007, 6:21 pm

Post by Ojczul »

Version 1.2.6
Win XP
2.52ghz Celeron
Problem:When i try to join official server it takes long(1min or sth like that) when i play Survivals/rpg's its takes long when my turn starts(like 30sec) And quitting official server is long too.
Posts: 1017
Joined: January 29th, 2007, 1:05 am
Location: Oregon

Post by Weeksy »

you've got too many saves and too many addons, and it's taking a while with your cache. It's going to happen, but you could ease it some by deleting some scenarios that you know you're not going to host games with, or eras you aren't going to play, or campaigns you aren't going to play.
If enough people bang their heads against a brick wall, The brick wall will fall down
Posts: 1
Joined: November 12th, 2007, 9:05 pm

Post by bladios »

BFW 1.2.7
AMD XP2200+

Ok, the slowdown thing that made me stop playing the game a year or so ago (or was it two? just after the transition to 1.x, I think) is back. I'm playing the South Guard campaign now aftef finishing Heir To The thron without any similar problems.

I think it started on the first map with the fog of war, when I have to choose between the elves and the outlaws. The autosaves start taking 10+ seconds to save and likewise the loading. The size of the sutosaves increase noticably from one turn to the next too. This got ridiculous on the map where I'm in the mines finishing off the lich, with autosave times of over 50 seconds near the end!

I think the first autosave there has a size around 500kb and after finally finishing it (I hate autosaves when I have to wait over a whole minute at the beginning of each turn near the end) it's up to 2MB. The first one in the next scenario is now over 3.260 MB and stderr.txt shows it took 80105 ms for the last save...

The task manager shows wesnoth.exe's memory usage steadily increasing during the autosave up to around 150MB and then drop suddenly to <10 when the autosave process is over.

I'd attach the save but that would take forever on this connection. :p So just adding the stderr.txt to see the autosave times for now.
(2.86 KiB) Downloaded 682 times
User avatar
Inactive Developer
Posts: 4453
Joined: November 26th, 2005, 7:41 am

Post by Sapient »

maybe some poorly-thought WML coding there if the filesize is increasing that rapidly; you can disable autosaves with the :nosaves command, btw. "Looks like your skills saved us again. Uh, well at least, they saved Soarin's apple pie."
User avatar
Posts: 556
Joined: March 23rd, 2007, 4:56 pm
Location: Kamloops, Canada

Post by DDR »

I have a copy of wesnoth 1.3.9 with all the add-ons. It takes 1-2 hours to load MP. I have a second copy, which has no add-ons. It takes about 30 sec to load. :?

I can think of no remedy, but I thought I should register the problem anyways.
Retired Developer
Posts: 1365
Joined: March 27th, 2004, 12:25 am
Location: Germany

Post by torangan »

DDR wrote:I can think of no remedy, but I thought I should register the problem anyways.
Add the updates one at a time until you find the badly done ones and warn others about them?
WesCamp-i18n - Translations for User Campaigns:

Translators for all languages required: contact me. No geek skills required!
Posts: 3
Joined: March 25th, 2008, 6:29 pm

Re: SLOW Performance Issues: post here to Help

Post by Meowler »

Hi. I have an iBook G4 and I downloaded wesnoth version 1.4. Everything is working well except for the speed of the game. The game slows down when I try to move a unit. In fact, every time i move a unit, I get the "pinwheel of death" and wesnoth will not do anything for about 1 1/2 minutes. I have tried disabling all animations of any kind and sounds of any kind and the problem has still continued.
Posts: 3
Joined: May 27th, 2008, 10:22 pm

Re: SLOW Performance Issues: post here to Help

Post by nagopaleen »

I have the same problem as Meowler, above, with only a couple details different. I also have an iBook G4, and the game worked perfectly for several campaigns until this problem came up. Halfway through the Under the Burning Suns campaign, the game began to freeze for about 20 seconds every time I move a unit. No amount of fooling around with the preferences menu or deleting saved games seems to help. I haven't yet tried starting another campaign or loading a game to see if the problem is game wide (so far this has been happening for two scenarios).
User avatar
Inactive Developer
Posts: 753
Joined: February 15th, 2007, 8:44 am
Location: Milton Keynes, UK

Re: SLOW Performance Issues: post here to Help

Post by Mist »

Have you taken 'charisma' or 'camouflage' AMLA with Kaleh befor the performance detoriated?
Somewhere, between the sacred silence and sleep.
Posts: 3
Joined: May 27th, 2008, 10:22 pm

Re: SLOW Performance Issues: post here to Help

Post by nagopaleen »

Yes, I did choose camouflage the first time he leveled up. This problem didn't come up until a couple scenarios after that, though, and since then I've only chosen 'better swordsmanship' twice.

(thanks for the quick response :))

EDIT: actually, I'm not positive about when exactly the problem started - it could well have appeared along with Kaleh's camouflage.
Posts: 66
Joined: September 10th, 2008, 5:45 pm

Re: SLOW Performance Issues: post here to Help

Post by fareley »

Hi i have a Intel Pentium 4 with 1.80 GHz and 256MB RAM
Windows XP, SP3
At Version 1.5.4 i have some big problems with - Thunderer! I don't know why but everytime i recruit,select,deselect or move one of them the game has huge lags. It's the same with the Thunderguard and the level-3-Thunderer
well and if the AI has too much possibilities to attack it may take a few seconds for my computer to work the best out but that's okay i think
and the bug with the savegames - it seems as if the game would load all of them into the RAM... The more you have the slower it is
So i usually play with only up to 10 Autosaves and 1-3 "normal" saves (one for the Beginning of the scenario and 2 if i need to - if i quit playing or try a risky thing or somethin' like that...)
i played the last scenarios playing dwarves without using thunderer - i had to do everything with my melee dwarves (it's the campaign, you don't have any outlaws) because using only 1 of my 2 Thunderguards would have cost minutes each Turn...
i even looked into their Files for something unusual but wasn't able to find anything
Posts: 1
Joined: October 26th, 2008, 4:26 am

Re: SLOW Performance Issues: post here to Help

Post by Grievous »

Hi Im running Windows XP SP2
1.5gigs of ram
amd athlon xp 3200+ 2.2ghz
Nvidia Geforce 7300 gt 512mb
and the only problem I have is when I scroll the map its very...chuggy I guess is the best word for it. Im pretty sure I have a good enough system to not have this problem but I could be wrong. Is there anyway to fix this?


Post Reply