Graphic glich under OSX.4.5 and Wesnoth 1.1.2

Having trouble with the game? Report issues and get help here. Read this first!

Moderator: Forum Moderators

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
Kirit
Posts: 60
Joined: July 25th, 2004, 2:13 pm
Location: Zurich, CH
Contact:

Graphic glich under OSX.4.5 and Wesnoth 1.1.2

Post by Kirit »

I was just on the MP-Server and noticed something that never occured before.
Many little black Triangles appeared on the screen, mainly next to the names in the chatlines and at the end of the chatlines.
Also: the damage numbers leave a trail. sometimes red, sometimes black and sometimes both.

Im under Mac OS X 10.4.5 with Wesnoth v1.1.2

here is a screenshot of what i meant. anyone else getting this problem?
Attachments
Clear Circels show the glich
Clear Circels show the glich
screen.jpg (58.53 KiB) Viewed 2974 times
scott
Posts: 5242
Joined: May 12th, 2004, 12:35 am
Location: Alexandria, VA

Post by scott »

I get that too. No one in #wesnoth-dev can replicate it.

Edit:
I get that too in single player. No one in #wesnoth-dev can replicate it.
Last edited by scott on March 23rd, 2006, 2:55 am, edited 1 time in total.
Hope springs eternal.
Wesnoth acronym guide.
User avatar
Noyga
Inactive Developer
Posts: 1790
Joined: September 26th, 2005, 5:56 pm
Location: France

Post by Noyga »

I was in this game ;)
None of the player seemed to have this bug, but at least 2 observers had it.
Maybe it is related to observers ?

(me had Linux)
Last edited by Noyga on March 23rd, 2006, 8:14 am, edited 1 time in total.
fonebone
Posts: 1
Joined: February 25th, 2006, 12:36 pm
Location: Winterthur, CH

Post by fonebone »

The same here.
played the south guard-campaign

(OSX 10.4.5; wesnoth 1.1.2 (lwa's build from the forum))
Kirit
Posts: 60
Joined: July 25th, 2004, 2:13 pm
Location: Zurich, CH
Contact:

Post by Kirit »

Noyga wrote:I was in this game ;)
None of the player seemed to have this bug, but at least 2 observers had it.
Maybe it is related to observers ?

(me had Linux)
one player had this too. Loky or so. He was under OS X as well.

seems to be an OS-related problem...
lwa
Inactive Developer
Posts: 271
Joined: June 11th, 2005, 8:19 am
Location: Paris, France

Post by lwa »

Maybe it's related to the SDL libraries in my build (cvs version compiled for universal binary). Does someone see the same glich with a home compiled version?
User avatar
Eleazar
Retired Terrain Art Director
Posts: 2481
Joined: July 16th, 2004, 1:47 am
Location: US Midwest
Contact:

Post by Eleazar »

I've been getting similar glitches from HP numbers for months in my home compiled version. Mac Os 10.4.5 (and earlier)

i hadn't noticed the glitches on the left until recently, but i seldome play MP.
Feel free to PM me if you start a new terrain oriented thread. It's easy for me to miss them among all the other art threads.
-> What i might be working on
Attempting Lucidity
User avatar
ivanovic
Lord of Translations
Posts: 1147
Joined: September 28th, 2004, 10:10 pm
Location: Germany

Post by ivanovic »

I am having the same probs on my mac. These probs are there for months already. I don't know when it was introduced nor do i know what could cause it. But I definatly know that it was there pre 10.4.5 already. Probably related to probs with SDL.
egg
Posts: 1
Joined: February 20th, 2006, 9:05 pm

Post by egg »

I have it too, using Iwa's build. I'm on 10.3.9. I did NOT have using Iwa's build of 1.1.1 or 1.0.2, though. For me it's new with 1.1.2.
scott
Posts: 5242
Joined: May 12th, 2004, 12:35 am
Location: Alexandria, VA

Post by scott »

ivanovic wrote:Probably related to probs with SDL.
But SDL hasn't ever been updated.
Hope springs eternal.
Wesnoth acronym guide.
Skippy
Posts: 85
Joined: February 10th, 2006, 2:09 am
Location: Sydney

Post by Skippy »

I can see similar effects on the main menu page (at the end of the explanations of the menu items at the bottom of the screen) and with HP indicators as they float away. It was not there in 1.1.1 and is there in 1.1.2, both were running under 10.4.5.
Attachments
Glitches.jpg
Glitches.jpg (73.01 KiB) Viewed 2840 times
radoz
Art Contributor
Posts: 51
Joined: March 18th, 2006, 11:38 am

Post by radoz »

Having those glitches on OS X 10.4.5 since 1.1.2 (they also happen in 1.1.2a). Never had them in prior versions. They are some pixels left over from the red hitpoints moving up from the attacked.

The error disappears if you change from fullscreen to windowed or vice versa.

When I start the game fullscreen, the glitches are there. Pressing cmd-F going into windowed, the error is gone. And it never comes back, no matter if I switch back to fullscreen, start a new round or whatever.

To make the glitches appear again, I have to close and restart BFW. Doesn't matter if I start in fullscreen or windowed, though. The change between these two makes the glitches go away for as long as BFW is running.
There are only 10 types of people in the world: Those who understand binary, and those who don't ...
Post Reply