Under the Burning Suns

This is the place for discussing development of mainline campaigns, reporting bugs in them and providing overall feedback.

Moderators: Forum Moderators, Developers

Post Reply
quartex
Inactive Developer
Posts: 2258
Joined: December 22nd, 2003, 4:17 am
Location: Boston, MA

Post by quartex »

Thanks, these were both fixed before the release of version 1.1.3.

User avatar
Ankka
Posts: 594
Joined: January 2nd, 2005, 2:40 pm
Location: Finland

Post by Ankka »

quartex wrote:Thanks, these were both fixed before the release of version 1.1.3.
Not in the mac release, at least... I just downloaded the Mac OS X package and UtBS is broken... no matter what scenario you try to open, it exits because of the broken line in scenario 9..

EDIT:

Ok, that wasn't a problem after I found out how I got to a certain line in vim.

But, it appears the game crashes when Zurg leaves to report to the great leader in the "Hunting Dwarves" - scenario. Happened twice, so it is reproduceable.

quartex
Inactive Developer
Posts: 2258
Joined: December 22nd, 2003, 4:17 am
Location: Boston, MA

Post by quartex »

I'm sorry, I thought the fix had been made before 1.1.3 got compiled.

Annka, you are right that when Zurg leaves in "In the Domain of the Dwarves" the game crashes. It's not an WML conflict, but a problem with the game engine. I'll have to look into it.

For the WML there are three files where you should change a line of code. Here's the code that needs changing. Simply replace the (-) line with the (+) line.

Code: Select all

Index: data/campaigns/Under_the_Burning_Suns/units/Desert_Hunter9.cfg
===================================================================
 [unit]
 #textdomain wesnoth-utbs
-	id=Desert Hunter8
+	id=Desert Hunter9
 	name= _ "Desert Hunter"
 	race=elf
 	gender=male,female

Index: data/campaigns/Under_the_Burning_Suns/scenarios/8_Frying_Pan.cfg
===================================================================	
 	# chest of gold in human outpost at cave mouth
-	(PUT_IMG items/chest-plain-open.png 17 21}
+	{PUT_IMG items/chest-plain-open.png 17 21}
 	
 	# kill Elyssa to keep her from being recruited
 
Index: data/campaigns/Under_the_Burning_Suns/scenarios/9_Water.cfg
===================================================================
 		message= _ "Oh Tanstafaal, I pity you. This battle was never about you."
 	[/message]
 
-	[then]
+	[/then]
 [/if]
 
 [/event]
Last edited by quartex on May 27th, 2006, 5:16 am, edited 1 time in total.

quartex
Inactive Developer
Posts: 2258
Joined: December 22nd, 2003, 4:17 am
Location: Boston, MA

Post by quartex »

It looks like fixing the bug in the scenario: "In the Domain of the Dwarves" is going to take some time. I'm sorry. In the meantime I suggest you go back and ally with the dwarves in the previous scenario.

User avatar
Ankka
Posts: 594
Joined: January 2nd, 2005, 2:40 pm
Location: Finland

Post by Ankka »

quartex wrote:It looks like fixing the bug in the scenario: "In the Domain of the Dwarves" is going to take some time. I'm sorry. In the meantime I suggest you go back and ally with the dwarves in the previous scenario.
Ok.

Thanks for those two other lines that needed fixing, now I'll get recruiting working in the last scenario.

Prometheus
Posts: 117
Joined: March 15th, 2006, 10:50 am

Post by Prometheus »

I find this campaign plays very slowly now- at the end of a unit move, there is a long pause, and the same if a unit is spotted, and some other circumstances. This isn't true of other campaigns, and it wasn't true of UTBS in earlier versions of Wesnoth either.

My guess is WML processing has been changed in some way, so it takes a lot longer to process WML events that used to be the case. This only becomes noticeable in scenarios with a lot of WML. Whatever the case, it makes UTBS effectively unplayable.

quartex
Inactive Developer
Posts: 2258
Joined: December 22nd, 2003, 4:17 am
Location: Boston, MA

Post by quartex »

Prometheus wrote:I find this campaign plays very slowly now- at the end of a unit move, there is a long pause, and the same if a unit is spotted, and some other circumstances. This isn't true of other campaigns, and it wasn't true of UTBS in earlier versions of Wesnoth either.

My guess is WML processing has been changed in some way, so it takes a lot longer to process WML events that used to be the case. This only becomes noticeable in scenarios with a lot of WML. Whatever the case, it makes UTBS effectively unplayable.
I'm sorry to hear that. A lot of things have changed with the wesnoth engine in 1.1.3 and this is something we'll have to work on.
Last edited by quartex on June 26th, 2006, 1:22 am, edited 1 time in total.

mastalouist
Posts: 9
Joined: October 5th, 2005, 4:31 pm
Location: Great White North

Post by mastalouist »

Prometheus wrote:I find this campaign plays very slowly now- at the end of a unit move, there is a long pause, and the same if a unit is spotted, and some other circumstances. This isn't true of other campaigns, and it wasn't true of UTBS in earlier versions of Wesnoth either.
I have the same problem. Very clunky! Otherwise, I'm loving this campaign so far.

I'm also having another bug: Some units in the first mission have negative movement and no weapons. However, if they are attacked, the automaticly level up, fixing the problem, and giving me second level units on turn 3 :) This seemed to mainly happed with spawning archers.

The second level had a similar problem, where some units, when taking "sun" damage, would also loose all weapons, have their max hp largely decreased, and would, again, have negative movement.

Other than these bugs, I'm really enjoying the campaign. Its unique and athe customized day/night and rulesets are fun.

bignall
Posts: 82
Joined: April 20th, 2006, 12:25 pm

Post by bignall »

mastalouist wrote: I'm also having another bug: Some units in the first mission have negative movement and no weapons. However, if they are attacked, the automaticly level up, fixing the problem, and giving me second level units on turn 3 :) This seemed to mainly happed with spawning archers.
I'm having almost the same problem, but it only happened with Seela (so far). Unfortunately, getting attacked isn't causing her to level up and she hasn't taken enough hits to level (and since she can't attack, that will take a very long time).

Edit: Okay, the strangest thing happened. I loaded a save and the next turn Seela got attacked, leveled and got movement and weapons. But about 5 of my other units can no longer move and don't have weapons any more. Saving and reloading didn't help, and in fact resulted in more units losing movement and weapons. Then Seela got attacked again, leveled again, and was able to move again. I'm trying to get those other units to be attacked and hopefully level up, but with only one mudcrawler left, that will be difficult.

Oh, and BTW, this is version 1.1.5

User avatar
Elvish_Pillager
Posts: 8129
Joined: May 28th, 2004, 10:21 am
Location: Everywhere you think, nowhere you can possibly imagine.
Contact:

Post by Elvish_Pillager »

in Out of the Frying Pan, if the last human is killed by drowning, odd dialogue ensues.
It's all fun and games until someone loses a lawsuit. Oh, and by the way, sending me private messages won't work. :/ If you must contact me, there's an e-mail address listed on the website in my profile.

Na'enthos
Posts: 401
Joined: June 13th, 2004, 8:02 pm
Location: Netherlands

Post by Na'enthos »

bignall wrote:
mastalouist wrote: I'm also having another bug: Some units in the first mission have negative movement and no weapons. However, if they are attacked, the automaticly level up, fixing the problem, and giving me second level units on turn 3 :) This seemed to mainly happed with spawning archers.
I'm having almost the same problem, but it only happened with Seela (so far). Unfortunately, getting attacked isn't causing her to level up and she hasn't taken enough hits to level (and since she can't attack, that will take a very long time).

Edit: Okay, the strangest thing happened. I loaded a save and the next turn Seela got attacked, leveled and got movement and weapons. But about 5 of my other units can no longer move and don't have weapons any more. Saving and reloading didn't help, and in fact resulted in more units losing movement and weapons. Then Seela got attacked again, leveled again, and was able to move again. I'm trying to get those other units to be attacked and hopefully level up, but with only one mudcrawler left, that will be difficult.

Oh, and BTW, this is version 1.1.5
Just experienced the same. The loading and saving and Seela. Not sure what version.. but I assume it's the latest since I downloaded the campaign only a few days ago. Oh and I'm using the Mac version.
He who would travel happily must travel light.
-Antoine de Saint-Exupery

quartex
Inactive Developer
Posts: 2258
Joined: December 22nd, 2003, 4:17 am
Location: Boston, MA

Post by quartex »

This is a bug with the new "random_traits=yes" WML command that I started using in 1.1.5. It seems that there is a bug with the command, many units, like Seela can be created with four traits instead of two, which causes other strange behaviors.

To fix this bug in 1.1.5, go to the "Under the Burning Suns" campaign folder, and go to the "utils" folder. From there open macros.cfg and delete the line of code that says "random_traits_yes". The desert elves will no longer be created with traits, but you problem will be solved.

I believe the "random_traits=yes" command has been fixed in 1.1.7.

Graboid
Posts: 1
Joined: July 26th, 2005, 7:54 am

segmentation fault on Desert Shyde levelup

Post by Graboid »

Hi!
I am not sure if it is a bug in your campaign, but as it never happened to me before, i post it here.
I allways get a segmentation fault when my "desert Shyde" advances to a "desert Star".
This happens btw after wesnoth complains that it can't load an Image, which is the Halo-image for the "desert Star" as i found out.
But copying the Halo-Image into the Campaign-Directory doesn't prevent Wesnoth from crashing with this segmentation fault...
I am using the 1.1.7 SuSE RPM.
Any clue?

Elestel
Posts: 61
Joined: February 8th, 2006, 1:09 pm
Location: Valladolid, España

Post by Elestel »

Good news! I've finally translated utbs to spanish... at time for 1.2... a hard work since february, and costant changes from quartex... but it was a great experience! (and it will... this is not ended... :wink: )
Ignacio Dadoverde Elestel
Nada es lo que parece, y lo que parece nada es...
Always there's more you can't see than you can...


Spanish translator of UTBS, TB, SPMPP

doctored
Posts: 48
Joined: March 21st, 2006, 11:40 pm
Location: Wilbur's shed

Post by doctored »

cool campaign i just finished it on hard with no losses and no recruits other then a few hiccups for bugs around ver 1.1.4 it was very cool i think maybe you could cut down the story line a little bit but gameplay itself was very good i would say the best out there besides heir to the throne
I'm not a doctor but I do play one on TV.

Post Reply