Succubus wont load :cry:

The place to post your WML questions and answers.

Moderators: Forum Moderators, Developers

Forum rules
  • Please use [code] BBCode tags in your posts for embedding WML snippets.
  • To keep your code readable so that others can easily help you, make sure to indent it following our conventions.
Post Reply
lightningbold
Posts: 4
Joined: August 1st, 2020, 8:48 pm

Succubus wont load :cry:

Post by lightningbold »

hi guys im out of ideas :cry: .... first i thougt it was because of the id not beeing unique then i thought it was because the names are beeing used ... then i discovered, the units sprites didnt have the right size... but now i dont know whats wrong because the game crashes when i try to start with my succubus as a choosen unit. here is the code for the succubus ...its not spectacular but well ...

i uploaded the whole era as is without the implemented succubus it is available only as script
era: A new human era
uploader: lightning

#textdomain wesnoth-My_Era
[unit_type]
id=EMMR_Succubus
name= _ "Succubus"
race=human
gender=female
image="units/humans/Succubus.png"
profile="portraits/humans/Succubus.png"
hitpoints=32
movement_type=smallfoot
movement=5
experience=70
level=2
alignment=neutral
advances_to=null
cost=20
usage=mixed fighter
description= _ "Succubus. Resists fire."
die_sound={SOUND_LIST:HUMAN_FEMALE_DIE}
{DEFENSE_ANIM "units/humans/Succubus-defend.png" "units/humans/Succubus.png" {SOUND_LIST:HUMAN_FEMALE_HIT} }
[resistance]
fire=80
cold=100
arcane=100
[/resistance]

[attack]
name=seduce
description=_"seduce"
icon=attacks/staff-magic.png
type=fire
range=melee
damage=2
number=1
[/attack]

[attack]
name=whisp_attack
description=_"whisp attack"
icon=attacks/staff-magic.png
type=fire
range=ranged
[specials]
{WEAPON_SPECIAL_MAGICAL}
[/specials]
damage=7
number=5
[/attack]

[attack_anim]
[filter_attack]
name=whisp_attack
[/filter_attack]
start_time=-575
[frame]
image="units/humans/Succubus.png:50"
[/frame]
[frame]
image="units/humans/Succubus-wisp-attack[1~3}.png:[150,150,100]"
sound=wail-sml.wav
[/frame]
[frame]
image="units/humans/Succubus.png:75"
[/frame]
[/attack_anim]

[attack_anim]
[filter_attack]
name=seduce
[/filter_attack]
start_time=-575
[frame]
image="units/humans/Succubus.png:50"
[/frame]
[frame]
image="units/humans/Succubus-seduce[1,2].png:[150,150]"
sound=kiss.wav
[/frame]
[frame]
image="units/humans/Succubus.png:75"
[/frame]
[/attack_anim]


[/unit_type]
Last edited by lightningbold on August 1st, 2020, 9:33 pm, edited 2 times in total.

User avatar
Lord-Knightmare
Forum Regular
Posts: 1156
Joined: May 24th, 2010, 5:26 pm
Location: Somewhere in the depths of Irdya, gathering my army to eventually destroy the known world.
Contact:

Re: Succubus wont load

Post by Lord-Knightmare »

Can you upload a screenshot of the error message? The message which is displayed just before Wesnoth executes the crash?

Additionally,

Code: Select all

image="units/humans/Succubus-wisp-attack[1~3}.png:[150,150,100]"
Should be:

Code: Select all

image="units/humans/Succubus-wisp-attack[1~3].png:[150,150,100]"

User avatar
Pentarctagon
Project Manager
Posts: 4427
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: Succubus wont load

Post by Pentarctagon »

Moved to the WML Workshop, since this is an issue with the WML rather than the actual images.
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code

lightningbold
Posts: 4
Joined: August 1st, 2020, 8:48 pm

Re: Succubus wont load :cry:

Post by lightningbold »

the crash is without an error it just closes...

lightningbold
Posts: 4
Joined: August 1st, 2020, 8:48 pm

Re: Succubus wont load

Post by lightningbold »

Lord-Knightmare wrote:
August 1st, 2020, 8:59 pm
Can you upload a screenshot of the error message? The message which is displayed just before Wesnoth executes the crash?

Additionally,

Code: Select all

image="units/humans/Succubus-wisp-attack[1~3}.png:[150,150,100]"
Should be:

Code: Select all

image="units/humans/Succubus-wisp-attack[1~3].png:[150,150,100]"
where is the difference?

User avatar
Lord-Knightmare
Forum Regular
Posts: 1156
Joined: May 24th, 2010, 5:26 pm
Location: Somewhere in the depths of Irdya, gathering my army to eventually destroy the known world.
Contact:

Re: Succubus wont load :cry:

Post by Lord-Knightmare »

where is the difference?
Third-level parentheses instead of the second-level parentheses.
[1~3]

User avatar
Pentarctagon
Project Manager
Posts: 4427
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: Succubus wont load :cry:

Post by Pentarctagon »

lightningbold wrote:
August 1st, 2020, 9:35 pm
the crash is without an error it just closes...
If you're on Windows, there's a log you can look at as well: https://forums.wesnoth.org/viewtopic.php?f=4&t=46166
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code

User avatar
Lord-Knightmare
Forum Regular
Posts: 1156
Joined: May 24th, 2010, 5:26 pm
Location: Somewhere in the depths of Irdya, gathering my army to eventually destroy the known world.
Contact:

Re: Succubus wont load :cry:

Post by Lord-Knightmare »

Solved.
Spoiler:
Spoiler:
I recommend using a text editor with the WML syntax enabler package as it displays the mistake in your code quite distinctly.

lightningbold
Posts: 4
Joined: August 1st, 2020, 8:48 pm

Re: Succubus wont load :cry:

Post by lightningbold »

Lord-Knightmare wrote:
August 1st, 2020, 9:40 pm
where is the difference?
Third-level parentheses instead of the second-level parentheses.
[1~3]
OMG i would never see that ... that was it actually xD

Post Reply