Error loading map - Illegal Characters

The place to post your WML questions and answers.

Moderator: Forum Moderators

Forum rules
  • Please use [code] BBCode tags in your posts for embedding WML snippets.
  • To keep your code readable so that others can easily help you, make sure to indent it following our conventions.
Post Reply
Devrailis Colandore
Posts: 76
Joined: April 22nd, 2007, 3:16 am
Location: Canada

Error loading map - Illegal Characters

Post by Devrailis Colandore »

Hi everyone. I've run into an odd problem that I've never encountered before while using the map editor.

I'm unable to load new maps that I create with the editor. I keep getting the following error:

Code: Select all

The game map could not be loaded: Illegal character found in map. The scenario cannot be loaded.
I only run into this problem loading maps that I've created using Wesnoth v1.6.0. I haven't updated to v1.6.1 yet. This isn't a problem when I load previous maps that I made using Wesnoth v1.4.x. When I initially checked my stderr.txt file, it would pop up the code of a piece of terrain. After I changed the terrain in the map, I would try loading the map again and get the same error with a different terrain code poping up in stderr.txt. This is the stderr.txt output:

Code: Select all

20090429 22:03:01 error config: Illegal character in map: (Cr) 'Cr'
20090429 22:03:01 error general: The game map could not be loaded: Illegal character found in map. The scenario cannot be loaded.
This happens for almost any type of terrain, savannah tiles, castle walls, cave walls, etc...

I also thought that the problem might be (somehow) because I'm running on Vista, but the same problem happens when I run the program in XP.

I'm not sure why this is happening. Is this a bug that was addressed in v1.6.1? I've attached a map file for the scenario that I'm currently trying to load. The only thing that is preventing me from loading it is the mapping error so I'd like to get it resolved as soon as possible.

Also:

Out of curiousity, are the codes in http://www.wesnoth.org/wiki/TerrainCodesWML, current and up to date? I do notice that the codes I get in stderr.txt do not correspond with those in the TCWML page. If so, why is the map editor using outdated codes?

Thanks in advance for the help!
Attachments
11_Building_Debts.zip
(426 Bytes) Downloaded 106 times
User avatar
Mist
Inactive Developer
Posts: 753
Joined: February 15th, 2007, 8:44 am
Location: Milton Keynes, UK

Re: Error loading map - Illegal Characters

Post by Mist »

In inverse order.

Yes, the TerrainCodesWML is current in the sense that all codes listed there are valid, it might not be up to date as in not listing all currently present core terrains, I don't really feel like checking this though ;)

Now to the map itself. I don't know why 1.6.0 editor would write incorrect terrain codes for you, as far as I know nobody reported such behaviour before. Both 1.6.0 and 1.6.1 editors worked fine for me (also Vista if you're curious) and I can't think of any reason for the behaviour you describe. The map you attached works fine after replacing all twelve Cr occurences with Chr inside the file. I'd say do an update, maybe your wesnoth installation is/got somehow corrupt.
Somewhere, between the sacred silence and sleep.
Disorder.
Devrailis Colandore
Posts: 76
Joined: April 22nd, 2007, 3:16 am
Location: Canada

Re: Error loading map - Illegal Characters

Post by Devrailis Colandore »

Thanks for the reply! Actually, I had reached the same conclusion that you had a little while ago and uninstalled my version of 1.6.0. I installed 1.6.1 and remade the map without running into any problems. I suspect I must not have properly transitioned from 1.4.x to 1.6.0, which might be why my editor wasn't working properly.

In fact, I should have tried re-installing before I posted. *head bang* :roll:

Thanks for the help!
Post Reply