Compatibility-breaking changes between 1.12 and 1.13/1.14

The place to post your WML questions and answers.

Moderator: Forum Moderators

Forum rules
  • Please use [code] BBCode tags in your posts for embedding WML snippets.
  • To keep your code readable so that others can easily help you, make sure to indent it following our conventions.
User avatar
egallager
Posts: 34
Joined: November 19th, 2020, 7:27 pm
Location: Concord, New Hampshire
Contact:

Re: Compatibility-breaking changes between 1.12 and 1.13/1.14

Post by egallager »

Development Team wrote: November 18th, 2017, 5:34 pm Deprecated or removed feature:
  • scenario_generation=cave, that is the built-in cave map generator is now deprecated and will be removed in 1.14 or 1.15. Scenarios that previously used it should change to the new Lua cave map generator. To do this, use map_generation=lua with create_map = << return wesnoth.require("lua/cave_map_generator.lua").generate_map(...) >>.
Is that code snippet something I can copy and paste verbatim, or am I supposed to put something in the "..." part? Asking because I am trying to port The Earth's Gut from 1.12 to 1.14 and have been running into this issue in scenario 10, Old Friends: https://github.com/cooljeanius/The_Earths_Gut/issues/1
User avatar
Pentarctagon
Project Manager
Posts: 4573
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: Compatibility-breaking changes between 1.12 and 1.13/1.14

Post by Pentarctagon »

It should be verbatim, I think. From the Gather Materials scenario of SoF, line 22: create_map = << return wesnoth.require("cave_map_generator").generate_map(...) >>.
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code
User avatar
egallager
Posts: 34
Joined: November 19th, 2020, 7:27 pm
Location: Concord, New Hampshire
Contact:

Re: Compatibility-breaking changes between 1.12 and 1.13/1.14

Post by egallager »

Pentarctagon wrote: November 21st, 2020, 11:31 pm It should be verbatim, I think. From the Gather Materials scenario of SoF, line 22: create_map = << return wesnoth.require("cave_map_generator").generate_map(...) >>.
OK, I tried that, but now I get a different error:
Image
(there is no text in the entire error message even if you scroll all the way down)
Edit: After some further tinkering to bring it closer to the code found in the "Gathering Materials" scenario mentioned, I now get yet another different error:
Image
User avatar
Pentarctagon
Project Manager
Posts: 4573
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: Compatibility-breaking changes between 1.12 and 1.13/1.14

Post by Pentarctagon »

I've never done anything with map generation, so I really don't know.
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code
User avatar
egallager
Posts: 34
Joined: November 19th, 2020, 7:27 pm
Location: Concord, New Hampshire
Contact:

Re: Compatibility-breaking changes between 1.12 and 1.13/1.14

Post by egallager »

OK with some help from Knyghtmare we got things worked out; it required removing the deprecated [settings] and [items] tags
Post Reply