The Reign of the Lords

It's not easy creating an entire faction or era. Post your work and collaborate in this forum.

Moderators: Forum Moderators, Developers

Post Reply
Konrad2
Forum Moderator
Posts: 2219
Joined: November 24th, 2010, 6:30 pm

Re: The Reign of the Lords

Post by Konrad2 »

Reign of the Lords Advancement mod is checked by default when hosting any mp game and even if you uncheck it, it apparently still is activated for the hosted game.

User avatar
The_Gnat
Posts: 2100
Joined: October 10th, 2016, 3:06 am
Contact:

Re: The Reign of the Lords

Post by The_Gnat »

Konrad2 wrote:
July 31st, 2019, 9:30 pm
Reign of the Lords Advancement mod is checked by default when hosting any mp game and even if you uncheck it, it apparently still is activated for the hosted game.
That is unique :lol: I don't think I get that problem on with the game though. Perhaps that is a bug or cache error?
Creator of: The Reign of The Lords Era,The Gnats Franken Dungeon
Co-designer of the (not-wesnoth) space combat video game Planet Bounce.

cronos8989
Posts: 2
Joined: August 27th, 2019, 2:29 pm

Re: The Reign of the Lords

Post by cronos8989 »

I used this mod with legend of the invincibles.
After unit reached max level, when gain enough experience to level up don't follow the normal LotI advancement.
There is a way to "fix" this?

Konrad2
Forum Moderator
Posts: 2219
Joined: November 24th, 2010, 6:30 pm

Re: The Reign of the Lords

Post by Konrad2 »

Don't use this mod with LotI. The advancement paths are defined for LotI units, which you don't have, because you've chosen TRotL units.

cronos8989
Posts: 2
Joined: August 27th, 2019, 2:29 pm

Re: The Reign of the Lords

Post by cronos8989 »

Konrad2 wrote:
August 27th, 2019, 5:09 pm
Don't use this mod with LotI. The advancement paths are defined for LotI units, which you don't have, because you've chosen TRotL units.

there is any plan to make it compatible?

User avatar
EarthCake
Posts: 360
Joined: March 29th, 2019, 1:57 pm
Location: Meereen

Re: The Reign of the Lords

Post by EarthCake »

cronos8989 wrote:
August 27th, 2019, 9:02 pm
Konrad2 wrote:
August 27th, 2019, 5:09 pm
Don't use this mod with LotI. The advancement paths are defined for LotI units, which you don't have, because you've chosen TRotL units.

there is any plan to make it compatible?
I guess they can't be compatible.

Konrad2
Forum Moderator
Posts: 2219
Joined: November 24th, 2010, 6:30 pm

Re: The Reign of the Lords

Post by Konrad2 »

Unknown unit type : ROLElvish Vendicator
(That's something that turned up in my log. Maybe it's relevant?)

Verbatov
Posts: 9
Joined: October 5th, 2019, 5:33 pm

Re: The Reign of the Lords

Post by Verbatov »

Hi, I found some bugs. Abomination "feeding greater" does not work. In the "pick your recruits" modification, the error "found a unittype with an invalid race elemental" appears when choosing" reign of lords ". Can you fix it?

User avatar
The_Gnat
Posts: 2100
Joined: October 10th, 2016, 3:06 am
Contact:

Re: The Reign of the Lords

Post by The_Gnat »

Verbatov wrote:
October 24th, 2019, 6:34 pm
Hi, I found some bugs. Abomination "feeding greater" does not work. In the "pick your recruits" modification, the error "found a unit type with an invalid race elemental" appears when choosing" reign of lords ". Can you fix it?
Hi Verbatov! Thanks for reporting those! I have not been around for a while but I will see if I can fix that for you :)

Konrad2 wrote:
September 10th, 2019, 7:41 pm
Unknown unit type : ROLElvish Vendicator
(That's something that turned up in my log. Maybe it's relevant?)
Hi Konrad2, hmmm, that is interesting. I will look into that as well.
Creator of: The Reign of The Lords Era,The Gnats Franken Dungeon
Co-designer of the (not-wesnoth) space combat video game Planet Bounce.

Verbatov
Posts: 9
Joined: October 5th, 2019, 5:33 pm

Re: The Reign of the Lords

Post by Verbatov »

Thanks :) I have still found a problem with some units. you cannot buy units from this graphic. Could you do something about it? By the way, it's a great mod ;)
https://www.wesnoth.org/forum/download/ ... =80407&t=1

Konrad2
Forum Moderator
Posts: 2219
Joined: November 24th, 2010, 6:30 pm

Re: The Reign of the Lords

Post by Konrad2 »

Those are protagonists of mainline campaigns.
From bottom-left to top-right:
The Rise of Wesnoth
Dead Water
Heir to the Throne
The Rise of Wesnoth
Heir to the Throne
The South Guard

Verbatov
Posts: 9
Joined: October 5th, 2019, 5:33 pm

Re: The Reign of the Lords

Post by Verbatov »

It is a pity that they are not in the main game. I have a question, I found a very similar mod "clash of heroes". How are they different?

Konrad2
Forum Moderator
Posts: 2219
Joined: November 24th, 2010, 6:30 pm

Re: The Reign of the Lords

Post by Konrad2 »

The unit id ROLAir_Avatar does not match the other unit ids you use. (Those are basically the same, but instead of the underscore you used a whitespace, e.g. ROLAir Elemental.)

User avatar
The_Gnat
Posts: 2100
Joined: October 10th, 2016, 3:06 am
Contact:

Re: The Reign of the Lords

Post by The_Gnat »

Konrad2 wrote:
December 2nd, 2019, 2:20 am
The unit id ROLAir_Avatar does not match the other unit ids you use. (Those are basically the same, but instead of the underscore you used a whitespace, e.g. ROLAir Elemental.)
Ah... That's strange! :hmm: I would fix it, except somehow I have managed to lose the password for the add-on :lol: :lol: when I have time again I will see if I can find it in my archives ;)
Verbatov wrote:
November 13th, 2019, 9:50 pm
It is a pity that they are not in the main game. I have a question, I found a very similar mod "clash of heroes". How are they different?
Sorry about the late reply. :) Glad you like the units Verbatov! I didn't add them into the main game mainly because they are a bit OP and there are not any cool ones for the other races.

I haven't played clash of heroes before (I would guess this is what you are talking about) perhaps you can ask Papasmurfreloaded, who made that add-on? My one is primarily focused on adding new 4th and 5th level advancements for all the units in the game. :D
Creator of: The Reign of The Lords Era,The Gnats Franken Dungeon
Co-designer of the (not-wesnoth) space combat video game Planet Bounce.

User avatar
WhiteWolf
Forum Regular
Posts: 594
Joined: September 22nd, 2009, 7:48 pm
Location: Hungary

Re: The Reign of the Lords

Post by WhiteWolf »

Hello,

There's a bug in Eternal Lich that manifests itself so that it always includes a variation of the Ancient Lich into any singleplayer campaign, regardless of the modification being enabled or not.
I didn't take an extensive look at how your macros work, I suspect that the {ADVANCE_IFHAVEANDCAMPAGIN (Ancient Lich)} line in Eternal Lich somehow introduces the variation of the Ancient Lich which has an implicit advancefrom to the core Lich.
Here's a screenshot: my campaign uses the extra_define of ENABLE_ANCIENT_LICH for the core ancient lich, but there is a variation available as well, if Reign of the Lords is installed. The mod here is disabled. If it helps, if you open the unit description of the variation, you can see that it is created by taking the core Ancient Lich as a base_unit.
Screenshot at 2019-12-21 15-40-54.png
A sidenote as an add-on creator who uses debug mode a lot: I'm not sure if unconditionally loading all units to the game path is a good idea. This means that if I have RotL installed, when I'm debugging my own stuff, all your units are there, causing all kinds of confusion (is this my variation or one from another add-on? Is this weapon special included from here or from there?). Therefore I have to relocate the RotL folder to somewhere else, and only put it back when I want to play something.
I'd suggest that the mod uses its own path and only loads the units when the mod is actually enabled. Note that I don't know if this is possible, I didn't look into how the mod works, this is just a suggestion :)
Author of the Underness Series, consisting of V parts: The Desolation of Karlag, The Blind Sentinel, The Stone of the North, The Invasion Of The Western Cavalry, Fingerbone of Destiny
Standalone works: The Ravagers - now for 1.14, with new bugs!

Post Reply