Wesnoth's Unit Database

Discussion of all aspects of the website, wiki, and forums, including support requests and new ideas.

Moderators: Forum Moderators, Developers

User avatar
TyBonzer
Translator
Posts: 13
Joined: February 8th, 2019, 12:26 pm
Location: Netherlands
Contact:

Re: Wesnoth's Unit Database

Post by TyBonzer » March 20th, 2019, 6:44 am

Soliton wrote:
March 19th, 2019, 5:24 pm
Just wait for the next update. Your translation was committed a bit after the last update of the unit db.
Thanks for your answer! I'm just too excited to see the changes.

avtandil-games
Posts: 1
Joined: April 5th, 2019, 5:30 pm

Re: Wesnoth's Unit Database

Post by avtandil-games » April 5th, 2019, 5:46 pm

I was hoping to knock out https://github.com/wesnoth/wesnoth/issues/3949

So I'm trying to build the units db locally and it looks like there's some sort of issue with the 'Under the Burning Suns' campaign? Their defined custom unit_movement is erroring out ./wmlunits
The {WOODLAND_RESISTANCE} tag doesn't appear to be defined in time to resolve in the campaign's units.cfg.

I'm super new so I'm not familiar enough to troubleshoot, I'll ping back if I figure it out. In the meantime, I wonder if there's a safe commit in 1.15 I can roll back to? I'll try defining WOODLAND_RESISTANCE in the campaign file too.

Edit1: Okay, adding WOODLAND_RESISTANCE explicitly to the units file fixed the problem, but I assume that's not a desirable long term solution.
Now I'm just got a KeyError on the Dwarvish Rune Lord. I assume the unit id isn't defined in some necessary and appropriate space.

Edit2: Figured it out, ignore me. The script is just picky about its input parameters, and imagemagick is a missing listed dependency maybe?

Post Reply