Need linux/apache help seting up a website.

The place for chatting and discussing subjects unrelated to Wesnoth.

Moderator: Forum Moderators

Post Reply
Computer_Player
Posts: 120
Joined: March 16th, 2008, 6:39 am

Need linux/apache help seting up a website.

Post by Computer_Player »

Hi, I am currently trying to install Koha (a library management system) through windows subsystem for linux 1 (WSL1). However being a complete noob with linux and apache, I hit a road block. I've tried asking in other places, but haven't had luck so far (or replies for that matter) so please, I know the wesnoth community will not let me down!

I followed the instructions here: https://wiki.koha-community.org/wiki/Koha_on_Debian and managed to get up to installing apache2.
I then set up the domain through virtual hosts using this: https://wiki.koha-community.org/wiki/Ho ... e_for_Koha. So debian /etc/hosts file was setup correctly.

I also input the wifi ip and domain in the windows /etc/hosts file.

However when I try to access it through the browser Firefox says "Connection was reset." localhost works correctly (showing apache default page) however when I input the ip of the website directly, it loads the default apache2 web page instead.

apache2ctl -S shows the proper domain (rootfile) relationships:

VirtualHost configuration:
*:80 is a NameVirtualHost
default server LAPTOP.localdomain (/etc/apache2/sites-enabled/000-default.conf:1)
port 80 namevhost LAPTOP.localdomain (etc/apache2/sites-enabled/000-default.conf:1)
port 80 namevhost library.mydomain.org (/etc/apache2/sites-enabled/library.conf.:4)
port 80 namevhost library-intra.mydomain.org(/etc/apache2/sites-enabled/library.conf:22)

apache2/error.log shows the following whenever I try to connect through browser:
[timestamp] [mpm_itk:warn] [pid 82] (itkmpm:pid=82 uid=33, gid=33) itk_post_perdir_config() : initgroups(library-koha), 1001) : Operation not permitted
[timestamp] [mpm_itk:warn] [pid 82] Couldn't set uid/gid/priority, closing connection.

When I start apache2 it shows:
apache2[timestamp] [core:warn] [pid139] (92)Protocol not available : AH00076: Failed to enable APR_TCP_DEFER_ACCEPT
.ok

However since it shows green ok, I figured that particular warning is ok to ignore..? localhost default webpage works correctly anyhow.
I use Debian 10 on my laptop using windows 10 ver.1903 (build 18362.900) and wsl1 as a test for installing it in my library.

I'm pretty much stuck on what to do, could someone please provide me some help on how I proceed? I don't need ssh connection (through that would be a bonus), just need it to work locally (hence the use of /etc/hosts). Any help would be much appreciated, thank you!
gnombat
Posts: 308
Joined: June 10th, 2010, 8:49 pm

Re: Need linux/apache help seting up a website.

Post by gnombat »

To be honest, I would recommend running Debian in VirtualBox for something like this. WSL is a strange hybrid abomination combining two different operating systems and it can be difficult to use and troubleshoot. If you need to run a web application on a Windows system for testing/development purposes, it's generally easier to just run Linux in a virtual machine.
Every time I use WSL, I am reminded of this:
User avatar
Elvish_Hunter
Forum Moderator
Posts: 1446
Joined: September 4th, 2009, 2:39 pm
Location: Lintanir Forest...

Re: Need linux/apache help seting up a website.

Post by Elvish_Hunter »

Computer_Player wrote: July 19th, 2020, 1:52 am When I start apache2 it shows:
apache2[timestamp] [core:warn] [pid139] (92)Protocol not available : AH00076: Failed to enable APR_TCP_DEFER_ACCEPT
.ok
That seems to be a bug specific to WSL1: https://github.com/microsoft/WSL/issues/1953. You'll probably have to upgrade to WSL2 to fix it.
Current maintainer of these add-ons:
1.14: The Sojournings of Grog, A Rough Life, The White Troll (co-author), Wesnoth Lua Pack
1.12: Children of Dragons
Post Reply