Level 9 Technomancer vs. Ubuntu blues

The place for chatting and discussing subjects unrelated to Wesnoth.

Moderators: Forum Moderators, Developers

Post Reply
User avatar
Midnight_Carnival
Posts: 836
Joined: September 6th, 2008, 11:08 am
Location: On the beach at sunset, gathering coral

Level 9 Technomancer vs. Ubuntu blues

Post by Midnight_Carnival »

I'm just complaining here, not totally unusual.
Getting Wesnoth to work again would be only one aspect of what I'm trying to do, hence posting here.
I have Ubuntu Lucid installed at home, but no internet: I'm presently in an internet cafe which has windoes installed. I have my brother's repostiroy dvds at home, but my brother's cat got Lucid disk 4 and Lucid disk 1 looks like it tried to install itself in a working food processor, neither are read by my computer.
Of the -I don't know how many- websites I have visited which promise me the repostiroy, none have delivered! It looks like I'd need to download the entire repositry and then burn it all to disk, preferably after installing Ubuntu (they are like certain evangelical churches who send people to your door in this respect :twisted: ). Is there a Level 9 or upwards Technomancer around who can direct me to a site where I can simply click "download/write disk1" and "download/write disk 4"? without installing Ubuntu on the internet cafe computer (they wouldn't like that) or downloading the entire repository (I don't have that much money, I still have to pay for DVDs and writing)?

Othewise just complaining.
...apparenly we can't go with it or something.

uncleshelby
Posts: 427
Joined: May 10th, 2011, 7:20 pm

Re: Level 9 Technomancer vs. Ubuntu blues

Post by uncleshelby »

First of all, you should really upgrade your version of Ubuntu, or switch to a different distro. An old version like Lucid Lynx will make it harder to get the latest versions of Wesnoth. It's not totally required, but it may make your life easier. You can browse and download .deb files from http://packages.ubuntu.com/ e.g. http://packages.ubuntu.com/lucid/games/wesnoth-1.8. At the bottom of the page there is a download link labeled "all". It'll take you to a mirrors page, choose a mirror in your region, and then install the .deb file.

I don't know about making CDs/DVDs of repos, but take a look at this: http://ubuntuforums.org/showthread.php?t=352460
Timshel

User avatar
alexanderthegre
Posts: 193
Joined: December 8th, 2011, 3:23 am
Location: nowhere

Re: Level 9 Technomancer vs. Ubuntu blues

Post by alexanderthegre »

I'm a little tired right now, so excuse me if I misunderstand your problem, but different versions of distros (and even different distros) are, generally, binary-compatible.
So if you only have access to the internet on a remote machine, you could in all probability get the package from packages.ubuntu.com .
I use arch, so I'm not sure how up-to-date their wesnoth package is. If they don't provide 1.10, you could get a package from a different distribution and use it-- as I said, they're binary compatible.

If I'm completely missing the point, and you're looking for an installer, I would strongly recommend not using lucid-- it's very old, probably doesn't receive many updates, etc.
In that case, you should check out debian (supports old hardware), linux mint (if you like gnome2), puppy (very small, I've never used it), or arch (again, small. not newbie-friendly).

Anyway, I hope that helps.

User avatar
Midnight_Carnival
Posts: 836
Joined: September 6th, 2008, 11:08 am
Location: On the beach at sunset, gathering coral

Re: Level 9 Technomancer vs. Ubuntu blues

Post by Midnight_Carnival »

Thanks to both! I'm pretty much going package by package, downloading the .deb files individually. Sure I will become best friends with the guy who runs the internet cafe...

@ alexanderthegre:
No, you aren't missing the point, missing the point would be something like starting a huge linux vs windows flamewar and getting the thread locked before anyone posted anything useful. Then I'd be in trouble with the mods for starting <excrement> when all I actually wanted was help :augh:

I know Lucid is old, I like old things - as I write this I'm wearing a big black trench coat and black bowler hat - that's just how I roll. Anyway, I should probalby upgrade my computer before upgrading my Ubuntu.

Thanks hugely.
...apparenly we can't go with it or something.

User avatar
enchilado
Posts: 100
Joined: March 25th, 2011, 8:44 pm
Location: Australia

Re: Level 9 Technomancer vs. Ubuntu blues

Post by enchilado »

Midnight_Carnival wrote: I know Lucid is old, I like old things - as I write this I'm wearing a big black trench coat and black bowler hat - that's just how I roll.
Cool, why don't you try using Warty?

Post Reply