Search found 76 matches

by Devrailis Colandore
March 26th, 2008, 12:50 am
Forum: Scenario & Campaign Development
Topic: Campaign: Autumn Kingdoms - Prologue (V.0.1.4)
Replies: 17
Views: 4375

Re: Campaign: Autumn Kingdoms - Prologue

I'm really enjoying the campaign so far, but I'm running into a fairly major problem in scenario 3 (could very well be that bug you mentioned earlier in the thread). Around turn 15 the princess is killed, (this is before I have even found her, excluding her escape cut-scene). So the scenario is fai...
by Devrailis Colandore
March 25th, 2008, 12:18 pm
Forum: Scenario & Campaign Development
Topic: Campaign: Autumn Kingdoms - Prologue (V.0.1.4)
Replies: 17
Views: 4375

Re: Campaign: Autumn Kingdoms - Prologue

I've reposted the campaign with a quick bug fix that I hope will remove any issues when playing Scenario 3. Please let me know if anyone runs into any further problems. I can't really talk for anyone else, but personally I tend to simply skip campaigns and settings outside of the world of Wesnoth. I...
by Devrailis Colandore
March 25th, 2008, 2:11 am
Forum: Scenario & Campaign Development
Topic: Campaign: Autumn Kingdoms - Prologue (V.0.1.4)
Replies: 17
Views: 4375

Re: Campaign: Autumn Kingdoms - Prologue

Thanks for the feedback, it's encouraging to hear from you! I can understand that it bugs you that the units don't have any attack animations. I was undecided about taking them out at first but the reason why I removed them was simply because in too many cases the attack animations available simply ...
by Devrailis Colandore
March 23rd, 2008, 3:51 am
Forum: Scenario & Campaign Development
Topic: Campaign: Autumn Kingdoms - Prologue (V.0.1.4)
Replies: 17
Views: 4375

Campaign: Autumn Kingdoms - Prologue (V.0.1.4)

Hello everyone. After uncounted dozens of man-hours spread across several months (I began this project late May of 2007), I've come close to finishing the first 6 scenarios of a new campaign. The Setting: The setting is new, something that I've created from scratch specifically for the story I want ...
by Devrailis Colandore
March 22nd, 2008, 4:44 am
Forum: WML Workshop
Topic: Saved games cannot be loaded within a scenario
Replies: 7
Views: 1264

Re: Saved games cannot be loaded within a scenario

My goodness, that's exactly what it was. I had side 2 set to human control in the previous scenario. I completely missed that. Thanks for the help, I really appreciate it.
by Devrailis Colandore
March 22nd, 2008, 2:33 am
Forum: WML Workshop
Topic: Saved games cannot be loaded within a scenario
Replies: 7
Views: 1264

Re: Saved games cannot be loaded within a scenario

In my case, I haven't been using any arrays. In my case, I suspect the problem is here: # Store all generic units [while] [have_unit] description="unit" [/have_unit] [do] [store_unit] [filter] description="unit" [/filter] variable="unit"_store kill=yes [/store_unit] [/d...
by Devrailis Colandore
March 21st, 2008, 6:21 pm
Forum: WML Workshop
Topic: Saved games cannot be loaded within a scenario
Replies: 7
Views: 1264

Saved games cannot be loaded within a scenario

I've been having problems with a certain scenario. The scenario loads fine from scratch and all of the events within the scenario work without any problems so far. When I save a turn in that scenario and then attempt to load it again, I get the following error message: The game could not be loaded: ...
by Devrailis Colandore
May 21st, 2007, 3:12 am
Forum: WML Workshop
Topic: Application error when using [unstore_unit]
Replies: 4
Views: 1560

I've been fiddling with the code for the unstore_unit command and it definitely seems to be a problem with the variable that's being unstored. Am I supposed to set the unit variables before using the store_unit command? I know that the command works because the mainline campaigns work fine when they...
by Devrailis Colandore
May 17th, 2007, 11:10 pm
Forum: WML Workshop
Topic: Application error when using [unstore_unit]
Replies: 4
Views: 1560

I think the problem is with the [unstore_unit] tag. I've stripped the scenario file down to its bare bones and I still get the same error, but only when the [unstore_unit] tag is called. If I use [unstore_unit] but I call the wrong variable, I get no error, it's only when I call on the stored unit t...
by Devrailis Colandore
May 17th, 2007, 12:25 am
Forum: WML Workshop
Topic: Application error when using [unstore_unit]
Replies: 4
Views: 1560

Application error when using [unstore_unit]

I'm trying to remove a character from the map during a dialogue scene, which I do by using: [store_unit] variable=test_store [filter] description=Test Unit [/filter] kill=yes [/store_unit] This works fine and removes the unit from the map. However, I tried to recall the unit to the map by doing the ...
by Devrailis Colandore
May 12th, 2007, 2:16 am
Forum: WML Workshop
Topic: Changing terrain types and timing
Replies: 2
Views: 954

Alright, I'll give that a shot then. Thanks, I appreciate your help.
by Devrailis Colandore
May 11th, 2007, 11:46 pm
Forum: WML Workshop
Topic: Changing terrain types and timing
Replies: 2
Views: 954

Changing terrain types and timing

I have a question about changing terrain. I'm trying to set up an event so that I remove a cave wall, reveal a neutral character, and then have the previously neutral character switch to the player's side and speak. Fog of war and shroud are both present but the revealed character will always be in ...
by Devrailis Colandore
April 29th, 2007, 2:24 am
Forum: WML Workshop
Topic: I am having problems with the MOVE_UNIT macro
Replies: 2
Views: 904

Oh wow, now that I look at it, I'm surprised I didn't catch that myself. I've spent an entire day just trying to figure it out. Thank you very much for your help, I really appreciate it.
by Devrailis Colandore
April 29th, 2007, 1:42 am
Forum: WML Workshop
Topic: I am having problems with the MOVE_UNIT macro
Replies: 2
Views: 904

I am having problems with the MOVE_UNIT macro

I'm having trouble getting the MOVE_UNIT macro to work. I copied the macro from the WMLwiki (it's MOVE UNIT 2): # Moves a unit from its current location to the given location along a # relatively straight line displaying the movement just like [move_unit_fake] # does. # # Note that setting the desti...
by Devrailis Colandore
April 26th, 2007, 5:19 pm
Forum: Scenario & Campaign Development
Topic: Campaign Coding Question: Problem with .cfg file
Replies: 3
Views: 1179

Thank you both for the quick replies. It turns out that it was a small line of text in the Normal difficulty line. I had typed it as this: ";*" + {MENU_IMG_TXT "../data/campaigns/Autumn_Kingdoms_Prologue/images/lieutenant.png" (_"Lieutenant") (_"(Normal)")} + ...