Attempting to Use Old Water Types for UMC; Trouble with TerrainWML

The place to post your WML questions and answers.

Moderators: Forum Moderators, Developers

Forum rules
  • Please use [code] BBCode tags in your posts for embedding WML snippets.
  • To keep your code readable so that others can easily help you, make sure to indent it following our conventions.
Post Reply
User avatar
Shield
Posts: 57
Joined: January 23rd, 2011, 5:58 pm

Attempting to Use Old Water Types for UMC; Trouble with TerrainWML

Post by Shield » November 3rd, 2019, 11:22 pm

A hopeful "hello" to anyone reading this-- I am attempting to make a Resource Pack add-on that allows a UMC developer to use "water"-type hexes from previous iterations of Wesnoth in their work via the map editor, for whatever reason they might want to (not wanting their scenario to lag so much, aesthetics, etc.). I'm currently working on adding in the various animated waters from 1.12, and the non-animated water from before water was animated. I might even add even older versions to the pack in the future! ...if I can just get those first few to work.

I love the look of the older waters for nostalgic reasons, and I've dabbled in UMC before, but terrainWML has always been a problem for me. Nearly every time I try to make a custom terrain without piece for piece, file for file copying it from another UMC, it crashes the entire game without even displaying an error message when I open the map editor. I've tried to scrape together this handful of custom water terrains using snippets of WML from other UMC resources and mainline text, but the result is still the same unexplained crash.

Here's what I've gotten so far:
Old_Water_Resource_Pack.tar
if it looks like I don't know much about what I'm doing, that's an accurate observation!
(1.69 MiB) Downloaded 10 times
A big problem I think is I don't know the full "anatomy" of a custom terrain; I really don't know what I'm doing wrong, and I have no idea how to figure out what I've done wrong, either (not helped by the lack of error messages or the game crashing). I'd like to get all these little animations and transitions under control, but copying, pasting, and replacing variable names just isn't cutting it. I'd like to add in the old bridges and swamps too, but I can't reasonably consider those until I can make the waters function properly.

I am trying to make this work for the latest versions of Wesnoth, and am presently working with it in version 1.15.1. I know it's a development version, but the crashes have happened with other terrains I've tried to make in older (and more stable) versions, too.

Any help with explaining and fixing this would be very much appreciated.
Creator of Lonely Era.
Here's my art!
I'm also on Tumblr.

User avatar
beetlenaut
Developer
Posts: 2390
Joined: December 8th, 2007, 3:21 am
Location: Washington State
Contact:

Re: Attempting to Use Old Water Types for UMC; Trouble with TerrainWML

Post by beetlenaut » November 4th, 2019, 1:29 am

Terrain strings can only be four letters long, and you have some that are longer than that. Try shortening them and see if that works. You should also try adding your custom terrains one at a time, so if Wesnoth crashes, you know exactly which terrain is causing the problem.
Campaigns: Dead Water,
The Founding of Borstep,
Secrets of the Ancients,
and WML Guide

Post Reply