Westnoth 1.14.4 build failing on CentOS 7.5

Get help with compiling or installing the game, and discuss announcements of new official releases.

Moderators: Forum Moderators, Developers

Post Reply
slowaak_wesnoth
Posts: 2
Joined: August 19th, 2018, 7:52 pm

Westnoth 1.14.4 build failing on CentOS 7.5

Post by slowaak_wesnoth » August 20th, 2018, 11:46 am

I'm getting a variable access rights failure while compiling attack.o. I get the same error when using either cmake/make or scons. The logs here are from the scons build. Note it was partially built on a previous failed run so only the failed compile is shown in the log.

Code: Select all

$ uname -a
Linux localhost.localdomain 3.10.0-862.9.1.el7.x86_64 #1 SMP Mon Jul 16 16:29:36 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
$ cat /etc/centos-release
CentOS Linux release 7.5.1804 (Core)
The installed packages are
packages.txt
(117.65 KiB) Downloaded 47 times
scons log is
build.log
(7.68 KiB) Downloaded 72 times
scons config.log is
config.log
(39.62 KiB) Downloaded 57 times

Tad_Carlucci
Developer
Posts: 317
Joined: April 24th, 2016, 4:18 pm

Re: Westnoth 1.14.4 build failing on CentOS 7.5

Post by Tad_Carlucci » August 20th, 2018, 1:54 pm

Looks like Boost 1.53 is too old. Upgrading to something more recent should help.
I forked real life and now I'm getting merge conflicts.

User avatar
Pentarctagon
Forum Administrator
Posts: 3573
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: Westnoth 1.14.4 build failing on CentOS 7.5

Post by Pentarctagon » August 20th, 2018, 11:19 pm

Boost 1.50.0+ should be fine.
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code

slowaak_wesnoth
Posts: 2
Joined: August 19th, 2018, 7:52 pm

Re: Westnoth 1.14.4 build failing on CentOS 7.5

Post by slowaak_wesnoth » September 8th, 2018, 1:04 am

I guess Tad was correct. I replaced the Yum installed Boost 1.53 with Boost 1.68.0 and Wesnoth 1.14.4 built and installed just fine using scons. The dependencies should probably be updated to require newer Boost. I didn't try any other Boost than the latest stable so don't know which earlier versions will work also. Actually it could be there is an issue with the Yum package for Boost 1.53 since I also didn't build and install that and try to build Wesnoth.

Post Reply