Cutscenes refresh problem

Having trouble with the game? Report issues and get help here. Read this first!

Moderator: Forum Moderators

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
vghetto
Posts: 241
Joined: November 2nd, 2019, 5:12 pm

Cutscenes refresh problem

Post by vghetto »

Today, I updated wesnoth from version 1.14.5 to 1.14.9 on debian and I'm getting this weird cutscene refresh problem. The screen turns black before they talk, then as the units move or fake move certain hexes get updates.
These are screenshots from the opening scene of Delfadors Memoirs.
The opening scene of Bad Moon Rising had the same problem.

Ofcourse, I didn't have this issue before the update.
Screenshot from 2020-01-25 01-29-07.png
Screenshot from 2020-01-25 01-28-57.png
User avatar
Iris
Site Administrator
Posts: 6728
Joined: November 14th, 2006, 5:54 pm
Location: Chile
Contact:

Re: Cutscenes refresh problem

Post by Iris »

Looks like issue #4245, which will be fixed in 1.14.10.
Author of the unofficial UtBS sequels Invasion from the Unknown and After the Storm (now available for Wesnoth 1.14.x and 1.15.4+).
vghetto
Posts: 241
Joined: November 2nd, 2019, 5:12 pm

Re: Cutscenes refresh problem

Post by vghetto »

Thank you.
Till 1.14.10 comes out, export SDL_RENDER_BATCHING=0 does seem to resolve it.

Btw, I also had this #4196 problem as well while working on my mod VRA on version 1.14.5 but didn't think of reporting it because I thought it was my PC's problem.

It happened when I went through levels quickly using :n debug command, i.e. caused loading screen to appear in quick successions by going to the main level then to plain then :n back to main level then to plain ... and so on in rapid successions.

I'll see if I can reproduce it on 1.14.9
Post Reply