Wesnoth 1.9.9

Get help with compiling or installing the game, and discuss announcements of new official releases.

Moderators: Forum Moderators, Developers

User avatar
tekelili
Posts: 1038
Joined: August 19th, 2009, 9:28 pm

Re: Wesnoth 1.9.9

Post by tekelili »

I have discovered a bug, after own scenario of mine caused load a replay of it crash wesnoth, I wondered if was some kind of code in my cfg causing it.

I have now reproduced this bug with Caves of the Basilisk. Load a replay of that map cause Wesnoth 1.9.9 crash.

Should I report it so, or try first isolate code that cause this bug?
(that could be difficult for me...)

Edit:
-Bug also found in Fallen Star Lake, Sablestone Delta, Hamlets, The Freelands
-Bug no found in: Cysanum Battlefield, Sulla ruins, Silverhead Crossing, Elesenfar Courtyard, Arcanclave Citadel, HGB, Hexcake, Manzivian Traps, Volcano, Castle Hoping

I am not able to find problem in code, it could be even a terrain issue, but I have no clue :hmm:
Be aware English is not my first language and I could have explained bad myself using wrong or just invented words.
World Conquest II

User avatar
Rigor
Posts: 941
Joined: September 27th, 2007, 1:40 am

Re: Wesnoth 1.9.9

Post by Rigor »

just to remind you that 1.9.9 is far from stable (really): i was playing today for about 2h, and i crashed 5 times, my ally 2 times, and the 2 opponents also 2 times. we were pretty fast with remaking the game but still it was buggy.

in the last 1v1 i was playing the game crashed and couldnt be even restored with my replay-trick (the game just crashed during loading). here u have a screenshot. while my opponent was moving his units i clicked around and could "simulate" an attack of his adept versus his adept. thats when the game crashed.

Image

but the game also crashes a lot of times when the planning mode is enabled. the 1.9.9 tournament might need a patch before it starts or the community will avoid it when no solutions are found. not even being able to load the replay paves the way to frustration during a tournie.

AI
Developer
Posts: 2394
Joined: January 31st, 2008, 8:38 pm

Re: Wesnoth 1.9.9

Post by AI »

Quite a number of whiteboard bugs have been fixed since 1.9.9, though I haven't tested the stability lately myself. Were you intentionally using the whiteboard or did it just take over your interface?

User avatar
Rigor
Posts: 941
Joined: September 27th, 2007, 1:40 am

Re: Wesnoth 1.9.9

Post by Rigor »

i used it intentionally to reproduce the crash ive once had in a 2v2 (it worked, see above). the main reason why i reported the bug was exactly the reproducibility of it. and because i read this here, what made me :mrgreen: :
Anonymissimus wrote:my personal opinion is that 1.9 is actually more stable than 1.8 in some sense at least. The only disadvantage is that the number (and experience) of the players on the server is worse.
full quote found here: http://forums.wesnoth.org/viewtopic.php ... than%201.8

i dont think that its more stable, really, i dont :lol2:

Anonymissimus
Inactive Developer
Posts: 2460
Joined: August 15th, 2008, 8:46 pm
Location: Germany

Re: Wesnoth 1.9.9

Post by Anonymissimus »

Rigor wrote:
Anonymissimus wrote:my personal opinion is that 1.9 is actually more stable than 1.8 in some sense at least. The only disadvantage is that the number (and experience) of the players on the server is worse.
full quote found here: http://forums.wesnoth.org/viewtopic.php ... than%201.8

i dont think that its more stable, really, i dont :lol2:
Which is why I said "in some sense". The whiteboard is affected by this statement. And unfortunately, it's causing bugs even if it's disabled.
What is IMHO more stable and also more powerful is the lua and wml action engine; consider the multiplayer synchronization of side turn events for instance. That's not very noticable from a player point of view though. I also didn't play much normal multiplayer in 1.9 yet due to the lack of acceptable players and DSU so can't really comment on it (I only played my MP addon). ;)

If you can still reproduce this bug in the upcoming 1.9.10 then please report it, also taking care of AI's question. This testing what you do is exactly what's needed. A solution will be found.
projects (BfW 1.12):
A Simple Campaign: campaign draft for wml startersPlan Your Advancements: mp mod
The Earth's Gut: sp campaignSettlers of Wesnoth: mp scenarioWesnoth Lua Pack: lua tags and utils
updated to 1.8 and handed over: A Gryphon's Tale: sp campaign

User avatar
Rigor
Posts: 941
Joined: September 27th, 2007, 1:40 am

Re: Wesnoth 1.9.9

Post by Rigor »

i found the saves, they are attached.

first was freelands T9 then i played sullas T2 crashes, last one with whiteboard AND movement bug. i could recover the save from sullas but every time i tried to open freelands the game crashed.

bug was reproducible exactly as instructed above and in-game (sullas ruins replay).

i dont want to think about how many crashes the tournament will see XD
Attachments
2p_—_The_Freelands-Autospeichern9.gz
(31.98 KiB) Downloaded 217 times
crem.gz
(12.7 KiB) Downloaded 199 times
mp_bug_assertion_failed_bug_whiteboard_bug.gz
(9.6 KiB) Downloaded 202 times

User avatar
Pewskeepski
Posts: 353
Joined: November 17th, 2010, 6:24 pm
Location: The Dungeon

Re: Wesnoth 1.9.9

Post by Pewskeepski »

{TEAM_COLOR_OVERRIDE} Doesn't work. I checked it in Northern Rebirth and Tallin isn't purple anymore.

User avatar
Alarantalara
Art Contributor
Posts: 784
Joined: April 23rd, 2010, 8:17 pm
Location: Canada

Re: Wesnoth 1.9.9

Post by Alarantalara »

Pewskeepski wrote:{TEAM_COLOR_OVERRIDE} Doesn't work. I checked it in Northern Rebirth and Tallin isn't purple anymore.
Already fixed in trunk. See http://gna.org/bugs/?18817

The Black Sword
Posts: 373
Joined: October 13th, 2008, 4:35 pm

Re: Wesnoth 1.9.9

Post by The Black Sword »

Something I found from the WTT replays:
Interesting point I just found trying to watch the Mint vs Dauntless game;

Originally the replay crashed for me but I tried clicking the "show replay" box and then it worked. Perhaps check this on the other games that people can't watch, maybe this solves the issue.

It shows a message at the start of the game:
<Invalid WML found> [multiplayer] not supported at scenario toplevel.

But then continues fine. I'll post this on the 1.99 thread too.

Anonymissimus
Inactive Developer
Posts: 2460
Joined: August 15th, 2008, 8:46 pm
Location: Germany

Re: Wesnoth 1.9.9

Post by Anonymissimus »

The Black Sword wrote: It shows a message at the start of the game:
<Invalid WML found> [multiplayer] not supported at scenario toplevel.
Can you describe more under which circumstances this happened ?
This message is harmless btw.
projects (BfW 1.12):
A Simple Campaign: campaign draft for wml startersPlan Your Advancements: mp mod
The Earth's Gut: sp campaignSettlers of Wesnoth: mp scenarioWesnoth Lua Pack: lua tags and utils
updated to 1.8 and handed over: A Gryphon's Tale: sp campaign

The Black Sword
Posts: 373
Joined: October 13th, 2008, 4:35 pm

Re: Wesnoth 1.9.9

Post by The Black Sword »

I've been talking to csarmi about this and he created a thread for it so I thought I'd just link there.
http://forums.wesnoth.org/viewtopic.php?f=4&t=35375

It appears it was fullscreen mode that made the difference, not the "show replay" button.

I'm running 1.9.9 on Windows XP.

User avatar
tekelili
Posts: 1038
Joined: August 19th, 2009, 9:28 pm

Re: Wesnoth 1.9.9

Post by tekelili »

I have seen with a search that turn off stand animations have been discussed a lot. But I didnt find if someone has a solution to turn off them without turn off "flying animations". Can be them removed one by one handly if not general solution?

As feedback, I still remeber one of my thoughts few days after discover wesnoth (I swear is literal). I was amused how a free game could be so well done, and when I looked in detail idle animations, I thought: "This is really clever, that solves static of units without add noise to gameplay".
Be aware English is not my first language and I could have explained bad myself using wrong or just invented words.
World Conquest II

User avatar
HenryPlainview
Posts: 18
Joined: September 23rd, 2011, 9:57 pm

Re: Wesnoth 1.9.9

Post by HenryPlainview »

I'm running Vista, and why does the game grind to a crawl on campaigns with multiple AI enemies during their turns on 1.9.9? I know it's not a problem with my computer becuse 1.9.8 runs very smoothly. That's the only problem I've had with anything in the 1.9 branch (but I've only been playing mainline campaigns so *shrug*), but that was such a dealbreaker I had to downgrade to 1.9.8. I'd post this in the slow performance thread, but that seems to be more for fixes, and I don't need one because I already have a fix. It's too bad because I would like to have the few small changes in 1.9.9, but it's not that big a deal.

Post Reply