Bug for joining MP server without forum nick

Having trouble with the game? Report issues and get help here. Read this first!

Moderator: Forum Moderators

Forum rules
Before reporting issues in this section, you must read the following topic:
Jozrael
Posts: 1034
Joined: June 2nd, 2006, 1:39 pm
Location: NJ, USA.

Bug for joining MP server without forum nick

Post by Jozrael »

As far as I know, you're supposed to be able to create an MP account without a forum nick.

I just had my friend install wesnoth, and when he tried to play mp, it said 'even though your nick is registered on this server you cannot log on due to an error in the hashing algorithm

logging into your forum account on http:..may fix this problem'

I doubt he picked a nick already registered, so what does this mean?
User avatar
Turuk
Sithslayer
Posts: 5283
Joined: February 28th, 2007, 8:58 pm
Contact:

Re: Bug for joining MP server without forum nick

Post by Turuk »

Jozrael wrote:I doubt he picked a nick already registered, so what does this mean?
What nick did he pick? (Yes, I know it rhymes.)
Mainline Maintainer: AOI, DM, NR, TB and THoT.
UMC Maintainer: Forward They Cried, A Few Logs, A Few More Logs, Start of the War, and Battle Against Time
Jozrael
Posts: 1034
Joined: June 2nd, 2006, 1:39 pm
Location: NJ, USA.

Re: Bug for joining MP server without forum nick

Post by Jozrael »

Kane. Perhaps that was taken.

Some other things, though:

It keeps saying 'removing illegal command from player Kane42. current player is jozrael', when he's trying to recruit (on his turn).

Also, when he joined my game in the lobby (name private, but no password), he doubleclicked on it and he joined as an obs (the join option was greyed out), and when he rejoined, it joined regularly but did not give him the option to recruit.

Now granted this is a firsttime player and I'm not at his screen, so I'm just relaying what he's told me as best I could. sorry if he's doing things slightly oddly and I'm not mentioning them.

Ok, he also can't end his turn. It says removing illegal command, and on his screen its my turn, and on mine its his.
User avatar
Turuk
Sithslayer
Posts: 5283
Joined: February 28th, 2007, 8:58 pm
Contact:

Re: Bug for joining MP server without forum nick

Post by Turuk »

http://www.wesnoth.org/forum/memberlist ... e&u=101788

When in doubt, you can always just check the members list. As to the other problems, it sounds as if your computers do not like each other. Actually, I'll leave it to a developer or someone more knowledgeable to give you input on that.
Mainline Maintainer: AOI, DM, NR, TB and THoT.
UMC Maintainer: Forward They Cried, A Few Logs, A Few More Logs, Start of the War, and Battle Against Time
Jozrael
Posts: 1034
Joined: June 2nd, 2006, 1:39 pm
Location: NJ, USA.

Re: Bug for joining MP server without forum nick

Post by Jozrael »

We remade with him hosting, and there were no problems. Odd, that.
Soliton
Site Administrator
Posts: 1638
Joined: April 5th, 2005, 3:25 pm
Location: #wesnoth-mp

Re: Bug for joining MP server without forum nick

Post by Soliton »

Jozrael wrote:It keeps saying 'removing illegal command from player Kane42. current player is jozrael', when he's trying to recruit (on his turn).
The server disagreed with you there then. It thinks it was your turn not his. What kind of scenario did you play?
Jozrael wrote:Also, when he joined my game in the lobby (name private, but no password), he doubleclicked on it and he joined as an obs (the join option was greyed out), and when he rejoined, it joined regularly but did not give him the option to recruit.
The option to recruit when joining..? Do you perhaps mean choosing ones faction?

Note that per default games with unknown eras are not joinable. The era author has to explicitely set that you don't need an add-on for that era if that's the case.
Jozrael wrote:Ok, he also can't end his turn. It says removing illegal command, and on his screen its my turn, and on mine its his.
See above, the server must have gotten confused about whose turn it is somehow...
"If gameplay requires it, they can be made to live on Venus." -- scott
User avatar
Baufo
Inactive Developer
Posts: 1115
Joined: January 29th, 2006, 4:53 pm
Location: Vienna, Austria

Re: Bug for joining MP server without forum nick

Post by Baufo »

Jozrael wrote:'even though your nick is registered on this server you cannot log on due to an error in the hashing algorithm logging into your forum account on http:..may fix this problem'
Jozrael wrote:I doubt he picked a nick already registered, so what does this mean?
No it's not a bug. As you see you are simply trying to log in with a nick that is owned by somebody else.
I was working on the proof of one of my poems all the morning, and took out a comma. In the afternoon I put it back again. -- Oscar Wilde
Jozrael
Posts: 1034
Joined: June 2nd, 2006, 1:39 pm
Location: NJ, USA.

Re: Bug for joining MP server without forum nick

Post by Jozrael »

Aye, I thought he had made a different name (colt42, which I highly doubted had been taken). My bad on that one. We were playing default era everything, so it wasn't that that was making our games odd. I went over to his dorm and he was doing everything fine (though we didn't have any problems joining there).


Another interesting thing that's popping up: my wesnoth has randomly crashed during two of our MP games. No error message, just quits to desktop.

EDIT: Ok, when he is host, when I do the 'clear labels' command, it removes them (for me) but not for him, and issues a 'removing illegal command' thing. This happens on his turn.

EDIT2: I also can't place labels on his turn. I can do both of these just fine on my turn.

EDIT3: Moar bugs!

You can't type the character '<' first in the chat, or it causes odd bugs with overwriting sentences.

After leaving a game, I only see me and my opponent in the lobby, even thought there are about 8 people and I can talk with them.
Last edited by Jozrael on February 8th, 2009, 10:45 am, edited 1 time in total.
User avatar
Baufo
Inactive Developer
Posts: 1115
Joined: January 29th, 2006, 4:53 pm
Location: Vienna, Austria

Re: Bug for joining MP server without forum nick

Post by Baufo »

About the crash: could you maybe post the contents of your stderr.txt?
About the labels: sorry I couldn't reproduce this.
I was working on the proof of one of my poems all the morning, and took out a comma. In the afternoon I put it back again. -- Oscar Wilde
Jozrael
Posts: 1034
Joined: June 2nd, 2006, 1:39 pm
Location: NJ, USA.

Re: Bug for joining MP server without forum nick

Post by Jozrael »

Battle for Wesnoth v1.5.9
Started on Sun Feb 08 05:47:33 2009

Automatically found a possible data directory at C:/Program Files/Battle for Wesnoth 1.5.9

Data directory: C:/Program Files/Battle for Wesnoth 1.5.9
User configuration directory: C:/Documents and Settings/ROSELC/My Documents/My Games/Wesnoth1.5

Checking video mode: 1024x768x16...
setting mode to 1024x768x16
20090208 05:47:42 error config: Illegal character in map: (Gg^Vo) 'Gg^Vo'
20090208 05:47:42 error config: illegal map: Illegal character found in map. The scenario cannot be loaded.
20090208 05:48:07 error config: Illegal character in map: (Gg^Vo) 'Gg^Vo'
20090208 05:48:07 error config: illegal map: Illegal character found in map. The scenario cannot be loaded.


EDIT: Crap, this might not be for the previous crash. This might have been when i was demonstrating the what happened when I went to preferences > gamma and that always crashed. That was the most recent crash prior to posting this stderr. Sorry if I overwrote the old one. I'll try to remember to save it if it happens again.
Jozrael
Posts: 1034
Joined: June 2nd, 2006, 1:39 pm
Location: NJ, USA.

Re: Bug for joining MP server without forum nick

Post by Jozrael »

Update: I can label just fine now when I host normally. The problem lies in when you have to manually set a player in the lobby to a position.

Edit2: More chat glitches!

The * symbol also bugs as the first character: it makes the rest of the text giant. It is stackable (try doing 6 *'s first)

The # symbol makes ur text red.

If you type @ first, it makes ur text green.

Also, symbols stack. So u can do *****# to have giant, red text.

Tilda (~) is bold text.

` is tiny text.

| is another type of grey (the shifted version of \)

{ is slightly greyer than normal text (very hard to see).

} is black text.
User avatar
Baufo
Inactive Developer
Posts: 1115
Joined: January 29th, 2006, 4:53 pm
Location: Vienna, Austria

Re: Bug for joining MP server without forum nick

Post by Baufo »

Jozrael wrote:Update: I can label just fine now when I host normally. The problem lies in when you have to manually set a player in the lobby to a position.

Edit2: More chat glitches!

The * symbol also bugs as the first character: it makes the rest of the text giant. It is stackable (try doing 6 *'s first)

The # symbol makes ur text red.

If you type @ first, it makes ur text green.

Also, symbols stack. So u can do *****# to have giant, red text.

Tilda (~) is bold text.

` is tiny text.

| is another type of grey (the shifted version of \)

{ is slightly greyer than normal text (very hard to see).

} is black text.
These are features... :)
I was working on the proof of one of my poems all the morning, and took out a comma. In the afternoon I put it back again. -- Oscar Wilde
Jozrael
Posts: 1034
Joined: June 2nd, 2006, 1:39 pm
Location: NJ, USA.

Re: Bug for joining MP server without forum nick

Post by Jozrael »

I see. Nvm then ^^. I just never noticed them before.
User avatar
DEATH_is_undead
Posts: 960
Joined: March 4th, 2007, 3:00 pm
Location: Northern United States

Re: Bug for joining MP server without forum nick

Post by DEATH_is_undead »

Jozrael wrote:I see. Nvm then ^^. I just never noticed them before.
There new features. Though these work when naming a map or unit names as well. Though unit name can be made with <x,x,x>, x can equal anywhere from 1-255 I believe.
3P MP Scenario - Great Dwarves Escape
The best way to learn is to follow. In order to learn WML, you have to follow other's work, and check their codes.
User avatar
Turuk
Sithslayer
Posts: 5283
Joined: February 28th, 2007, 8:58 pm
Contact:

Re: Bug for joining MP server without forum nick

Post by Turuk »

Mainline Maintainer: AOI, DM, NR, TB and THoT.
UMC Maintainer: Forward They Cried, A Few Logs, A Few More Logs, Start of the War, and Battle Against Time
Post Reply