Add-ons not appearing

Having trouble with the game? Report issues and get help here. Read this first!

Moderator: Forum Moderators

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
westward_ho!
Posts: 2
Joined: May 19th, 2008, 9:26 pm

Add-ons not appearing

Post by westward_ho! »

First of all, this isn't an issue with an add-on itself--just installing them. If this should STILL be posted in that forum, feel free to move/lock/redirect.

I have downloaded a couple of add-ons through the game (not through the direct site http://wolff.to/campaigns/list.html?sort=downloads_down << here) and have not been able to play them. They appear in C:\Program Files\Wesnoth 1.4\userdata\data\campaigns but do not appear in the campaign list. A few websites said to make sure to "restart" Wesnoth after downloading each add-on, which I have done to no avail. I'm not sure what's going on here; I'm not a coder or developer but I do enjoy this game and would like to try a few of the user campaigns.

The add-on will download completely and install, and then the loading/install screen appears, and it always says that the add-on has been installed successfully, but again, does not appear in the campaign list.

Interestingly, the campaign (.cfg) files are identified as "Microsoft Office Outlook Configuration Files." I suspect that this is why they're not appearing but I'm not sure how to change that either. I tried the "Open With..." function, and selected wesnoth.exe, and a new "userdata" file was created in the folder, but the program did not automatically open, and STILL did not appear in the campaign list. An example:

In: C:\Program Files\Wesnoth 1.4\userdata\data\campaigns
Open "C:\Program Files\Wesnoth 1.4\userdata\data\campaigns\A_New_Land.cfg With: ("Select a program from a list") wesnoth.exe
Happened: "userdata" file created in C:\Program Files\Wesnoth 1.4\userdata\data\campaigns, campaign still not listed

I've reinstalled the program, which I downloaded from the sourceforge.net mirror. I have no trouble with package campaigns. The version (where can I find that? o_O) I believe is 1.4.2, which is available for download from the front page.

Running:
Windows XP Professional
Erm, not sure what else you need. About 2GB ram, on a laptop. McAfee antivirus, but the program has been showing no issues.

Thanks for the help in advance! :)
User avatar
Mist
Inactive Developer
Posts: 753
Joined: February 15th, 2007, 8:44 am
Location: Milton Keynes, UK

Re: Add-ons not appearing

Post by Mist »

It's simple and it keeps showing up like a bad penny.

Not all add-ons on the server are campaigns.
In fact most of them are content designed and playable only in Multiplayer Mode (anything with Era/Map Pack/Faction etc. in name/description)
So unless it says Campaign somewhere in the add-on description it'll be most likely not playable in Single Player mode and not visible on campaign list (makes sense doesn't it? ;) )

Yes we know the current system is confusing, and we do work towards making it more sane.

And a cookie to you for a good problem description, it keeps my faith in people alive in the flood of 'it doesn't work and I have xp' type of submisions :D Have fun playing the game, and check 'Scenario and Campaign development' forum for a list off add-ons that are actually a campaign.
Somewhere, between the sacred silence and sleep.
Disorder.
nataS
Posts: 166
Joined: January 28th, 2008, 3:21 pm

Re: Add-ons not appearing

Post by nataS »

List of campaigns is in my signature, all other content is for the multiplayer server.
User avatar
Iris
Site Administrator
Posts: 6745
Joined: November 14th, 2006, 5:54 pm
Location: Chile
Contact:

Re: Add-ons not appearing

Post by Iris »

BTW...
westward_ho! wrote:Interestingly, the campaign (.cfg) files are identified as "Microsoft Office Outlook Configuration Files." I suspect that this is why they're not appearing but I'm not sure how to change that either. I tried the "Open With..." function, and selected wesnoth.exe
CFG files are plain text files containing WML. You can open them with WordPad or other plain-text editors that support UNIX line endings with UTF-8 encoding.

For the "MS Office config file" identification, it means nothing to Wesnoth. It only affects Windows applications that try to use shell functions to open a file with its associated program (one of those apps would be Windows Explorer itself).

You can change file association if you want, but that is explained in Windows' Help instead.
Author of the unofficial UtBS sequels Invasion from the Unknown and After the Storm (now available for Wesnoth 1.14.x and 1.15.4+).
westward_ho!
Posts: 2
Joined: May 19th, 2008, 9:26 pm

Re: Add-ons not appearing

Post by westward_ho! »

Thanks very much for the replies, all, that makes perfect sense! I'm off to try that now, and I'll bookmark that list nataS, it's very useful. :)

Mist: I currently work as a mod on another game-based forum, and I know how frustrating "itz brokin fix pleeeze!!!!1" can be, so I wanted to make double sure I made the problem easy for you to diagnose and understand :)

Everyone's help is very much appreciated! Thanks again!
Post Reply