Wesnoth 1.3.1 not compatible with 1.3.1+svn?

Get help with compiling or installing the game, and discuss announcements of new official releases.

Moderator: Forum Moderators

Post Reply
viorc
Posts: 130
Joined: February 22nd, 2006, 3:03 am

Latest trunc branch cannot connect to 1.3.1 MP server

Post by viorc »

When I make a build from the latest SVN on branch trunc and I try to connect to the 1.3.1 multiplayer server, a message appears telling me I am running version 1.3.1+svn while the server only accept version 1.3.1
Is it normal to be denied to access 1.3.1 MP server with latest SVN (branch trunc) ?

As a comparison, when I compiled from latest SVN on branch 1.2, I could still connect to the MP server dedicated to 1.2.1 version.

Maybe I am mixing up everything :?
User avatar
ivanovic
Lord of Translations
Posts: 1147
Joined: September 28th, 2004, 10:10 pm
Location: Germany

Post by ivanovic »

The explaination is simple: The 1.2.x branch is compatible with each other version of 1.2.x. This means there are no balancing changes and such. Whereas in trunk there are balancing changes. These changes would result in OOS (OutOfSync) errors on the servers. That is why we tend to have an extra server for the stable version, for the latest development version and for trunk. ATM we have no active server for trunk yet, we have to set it up first.
Soliton
Site Administrator
Posts: 1638
Joined: April 5th, 2005, 3:25 pm
Location: #wesnoth-mp

Re: Latest trunc branch cannot connect to 1.3.1 MP server

Post by Soliton »

viorc wrote:When I make a build from the latest SVN on branch trunc and I try to connect to the 1.3.1 multiplayer server, a message appears telling me I am running version 1.3.1+svn while the server only accept version 1.3.1
Is it normal to be denied to access 1.3.1 MP server with latest SVN (branch trunc) ?

As a comparison, when I compiled from latest SVN on branch 1.2, I could still connect to the MP server dedicated to 1.2.1 version.

Maybe I am mixing up everything :?
If you're aware of the problems that may arise simply change the version string to 'test' and you can log on to any official server to test stuff.
"If gameplay requires it, they can be made to live on Venus." -- scott
viorc
Posts: 130
Joined: February 22nd, 2006, 3:03 am

Re: Latest trunc branch cannot connect to 1.3.1 MP server

Post by viorc »

Soliton wrote:If you're aware of the problems that may arise simply change the version string to 'test' and you can log on to any official server to test stuff.
How to do that, at runtime or compilation time ?
I see no place where to do it in the preference file nor parameter to set when I call the ./configure script.

About being aware of the problems, I am not positive on that. Can you tell me if there are at the moment balancing differences between latest svn in branch trunc and 1.3.1 ?
I understand from the answer from ivanovic that one can expect differences but he does not say that differences are already present.
User avatar
ivanovic
Lord of Translations
Posts: 1147
Joined: September 28th, 2004, 10:10 pm
Location: Germany

Post by ivanovic »

http://svn.gna.org/viewcvs/wesnoth/trun ... w=download
As you can see there are already two lines of balancing changes in. Keep in mind that this is just a snapshot of the cahngelog. Have a look at changelog.wensoth.org for the latest version.
You should *never* do such a change in code to modify your version to be different if you are not 100% aware what you are doing. You will get OOS errors otherwise and players might think that you are cheating (OOS errors are a sign for changed data like cheaters can use them). If you want to play on the server for the development version checkout "svn.gna.org/svn/wesnoth/tags/1.3.1" instead of "svn.gna.org/svn/wesnoth/trunk".
viorc
Posts: 130
Joined: February 22nd, 2006, 3:03 am

Post by viorc »

Thanks ivanovic for your very clear answer.
I indeed know how fast people will conclude to attempt of cheating when they see OOS during the game that is why I wanted to make things clear before doing anything.
From the changelog and viewcvs, I can see that these balancing changes were made at Revision 16105. So me using any prior revision ( I have revision 16102 ), it should be safe to try to connect to the 1.3.1 MP server.

PS: I have found the way to change the version string in the file ./configure.ac
Post Reply