The Legend Begins [SP Campaign for Wesnoth 1.10 and later]

Discussion and development of scenarios and campaigns for the game.

Moderators: Forum Moderators, Developers

Post Reply
User avatar
Lord-Knightmare
Forum Regular
Posts: 1180
Joined: May 24th, 2010, 5:26 pm
Location: Somewhere in the depths of Irdya, gathering my army to eventually destroy the known world.
Contact:

Re: The Legend Begins [SP Campaign for Wesnoth 1.10 and late

Post by Lord-Knightmare »

i guess i wasnt the only person thats stuck then i might as well stop this campaign cause i dont even have close to the amount in the list
It would have been wise to spent scenarios 5, 6 and 7 in leveling your units.

Anyways, I have rebalanced some scenarios in E2. Fixed stupid typos. And, a new map design for a few.
User avatar
marecki
Posts: 75
Joined: May 12th, 2010, 2:09 pm
Location: Poland

Re: The Legend Begins [SP Campaign for Wesnoth 1.10 and late

Post by marecki »

Armybone wrote:Hi, i have problem playing The Legend Begins... I download "War of Legends". Then, download "The Legend Begins"... When it loading it stop half way and got the error message said
"Error loading game configuration files: '[base_unit] recursion loop in [unit_type] Lava Giant->Lava Giant' (The game will now exit)"
Same for me. Is there a way to go around this, or is it impossible to play the campaign right now?
User avatar
Lord-Knightmare
Forum Regular
Posts: 1180
Joined: May 24th, 2010, 5:26 pm
Location: Somewhere in the depths of Irdya, gathering my army to eventually destroy the known world.
Contact:

Re: The Legend Begins [SP Campaign for Wesnoth 1.10 and late

Post by Lord-Knightmare »

Fixed issues about campaign not loading in new version which was uploaded 5 minutes ago...
HanFangAn
Posts: 2
Joined: June 16th, 2012, 3:56 pm

Re: The Legend Begins [SP Campaign for Wesnoth 1.10 and late

Post by HanFangAn »

Is the new version only for 1.10, i play fine before in 1.10 but i still get the lava giant bug in 1.11, is there a way to fix this?
User avatar
Lord-Knightmare
Forum Regular
Posts: 1180
Joined: May 24th, 2010, 5:26 pm
Location: Somewhere in the depths of Irdya, gathering my army to eventually destroy the known world.
Contact:

Re: The Legend Begins [SP Campaign for Wesnoth 1.10 and late

Post by Lord-Knightmare »

HanFangAn wrote:Is the new version only for 1.10, i play fine before in 1.10 but i still get the lava giant bug in 1.11, is there a way to fix this?
Due to my amazingly slow internet, I updated only the 1.10 version as most forum members say most of the players play 1.10... :(
Don't worry, I will update the 1.11 version once I have completed the final episode 3 (3 scenarios done out of a planned 30 - 10%)


By the way, I have an announcement to make. I have my IGCSE O LEVEL examinations beginning in about a month, so I will be on a "wesbreak" up till the 10th of June. Wish me luck. :)
102692597
Posts: 1
Joined: April 15th, 2013, 7:59 pm

Re: The Legend Begins [SP Campaign for Wesnoth 1.10 and late

Post by 102692597 »

Nice story, just played part 1 and its very creative, thanks for it.
User avatar
Lord-Knightmare
Forum Regular
Posts: 1180
Joined: May 24th, 2010, 5:26 pm
Location: Somewhere in the depths of Irdya, gathering my army to eventually destroy the known world.
Contact:

Re: The Legend Begins [SP Campaign for Wesnoth 1.10 and late

Post by Lord-Knightmare »

102692597 wrote:Nice story, just played part 1 and its very creative, thanks for it.
You're welcomed. :D
lu_zero
Posts: 196
Joined: April 16th, 2005, 10:25 am

Re: The Legend Begins [SP Campaign for Wesnoth 1.10 and late

Post by lu_zero »

Dead Caves is a *bit* slow since you literally get monster filling up the whole map...
User avatar
Lord-Knightmare
Forum Regular
Posts: 1180
Joined: May 24th, 2010, 5:26 pm
Location: Somewhere in the depths of Irdya, gathering my army to eventually destroy the known world.
Contact:

Re: The Legend Begins [SP Campaign for Wesnoth 1.10 and late

Post by Lord-Knightmare »

lu_zero wrote:Dead Caves is a *bit* slow since you literally get monster filling up the whole map...
Well, it's a lengthy scenario, inspired from The Pursuit from Northern Rebirth. Want me to make it harder? I can substitute regular Spectres for the Ethereal ones, if you are willing to lose a few veteran recalls....
lu_zero
Posts: 196
Joined: April 16th, 2005, 10:25 am

Re: The Legend Begins [SP Campaign for Wesnoth 1.10 and late

Post by lu_zero »

The main problem is that you do not see the end of it and we move from skirmish to siege, if you have enough stone golem or better you survive, otherwise you are already bound to lose veterans. (since you have already plenty of lv3 spectres chewing you)
arek72
Posts: 13
Joined: May 11th, 2010, 11:14 pm

Re: The Legend Begins [SP Campaign for Wesnoth 1.10 and late

Post by arek72 »

Hi, i´m on Episode 1. Great Campaign so far!!!
In the "Ralm of Fire" Scenario. When loading up i get the following Errow Message" unknown unit type: Bladesman".
Latest Version of TLB installed...
Any ideas?

Cheers
Arek
There is no spoon...

OS X 10.6.8
Wesnoth 1.10.5
User avatar
Lord-Knightmare
Forum Regular
Posts: 1180
Joined: May 24th, 2010, 5:26 pm
Location: Somewhere in the depths of Irdya, gathering my army to eventually destroy the known world.
Contact:

Re: The Legend Begins [SP Campaign for Wesnoth 1.10 and late

Post by Lord-Knightmare »

The main problem is that you do not see the end of it and we move from skirmish to siege, if you have enough stone golem or better you survive, otherwise you are already bound to lose veterans. (since you have already plenty of lv3 spectres chewing you)
So, you're suggesting a map re-design. Fair enough. I will see what can be done.
Hi, i´m on Episode 1. Great Campaign so far!!!
In the "Ralm of Fire" Scenario. When loading up i get the following Errow Message" unknown unit type: Bladesman".
Latest Version of TLB installed...
Any ideas?

Cheers
Arek
I see no error in the scenario file. Perhaps this is due to the ID change made to the Bladesman and Duke. Well, I had a file which worked as a work around, but I seem to have misplaced it. But, try making a file containing these lines:-

Code: Select all


[unit_type]
    id="Bladesman"
    [base_unit]
        unit="Infantryman"
    [/base_unit]
[/unit_type]

[unit_type]
    id="Duke"
    [base_unit]
        unit="Crusader"
    [/base_unit]
[/unit_type]
And then place the file in the campaign's units/humans/ folder. The campaign would work then.
arek72
Posts: 13
Joined: May 11th, 2010, 11:14 pm

Re: The Legend Begins [SP Campaign for Wesnoth 1.10 and late

Post by arek72 »

Thanks so far but...
How should i name this file? Name&suffix?
There is no spoon...

OS X 10.6.8
Wesnoth 1.10.5
User avatar
Lord-Knightmare
Forum Regular
Posts: 1180
Joined: May 24th, 2010, 5:26 pm
Location: Somewhere in the depths of Irdya, gathering my army to eventually destroy the known world.
Contact:

Re: The Legend Begins [SP Campaign for Wesnoth 1.10 and late

Post by Lord-Knightmare »

How should i name this file? Name&suffix?
Name it "obsolete-unit-ids.cfg". Since, the IDs that you require are no longer used.
arek72
Posts: 13
Joined: May 11th, 2010, 11:14 pm

Re: The Legend Begins [SP Campaign for Wesnoth 1.10 and late

Post by arek72 »

Unfortunetaly i get an other error after creating the file.
Please see attachment.
Attachments
The Battle for Wesnoth - 1.10.6.jpg
There is no spoon...

OS X 10.6.8
Wesnoth 1.10.5
Post Reply