After the Storm 0.9.17 [Wesnoth 1.12]

Discussion and development of scenarios and campaigns for the game.

Moderators: Forum Moderators, Developers

Post Reply
User avatar
Sadaharu
Posts: 136
Joined: December 13th, 2017, 11:39 pm

Re: After the Storm 0.9.17 [Wesnoth 1.12]

Post by Sadaharu » September 5th, 2018, 5:17 am

Oh!
Spoiler:
Edit:
Spoiler:

Konrad2
Forum Regular
Posts: 974
Joined: November 24th, 2010, 6:30 pm

Re: After the Storm 0.9.17 [Wesnoth 1.12]

Post by Konrad2 » September 5th, 2018, 3:42 pm

Sadaharu, if you don't mind playing AtS again, maybe download it from github for 1.14 and test it? Then I wouldn't be the only one doing it, maybe you discover bugs I overlooked. Or will overlook. I'm barely almost at Episode 2.
I am a Ghost: I drain the life energy from other people to survive and am hated/feared by regular people. Non-regular people don't like me either though.

User avatar
Sadaharu
Posts: 136
Joined: December 13th, 2017, 11:39 pm

Re: After the Storm 0.9.17 [Wesnoth 1.12]

Post by Sadaharu » September 8th, 2018, 1:34 am

Well… we could divide up the work.

On the one hand I'd love to contribute and all these years I've learned to like the game enough that I want to do a campaign/story of my own.
As a tester for other games and on other sites I have proven to be very thorough, to a point that unnerved some creators.
Which also means that I myself get burned out a bit when I playtest, rather than merely play, a mod/scenario/campaign.

So, just to prevent myself from losing what remains of/passes for (delete whichever is inappropriate) my sanity I could do an entire playtest of AtS Episode 3 and you finish with Ep. 2 if you have the time?

If shadowm wants me to test it… well, you might have to babysit me through the installation and so on. I've never installed any mods from anything other than the official click-and-wait in-game add-ons feature.

Konrad2
Forum Regular
Posts: 974
Joined: November 24th, 2010, 6:30 pm

Re: After the Storm 0.9.17 [Wesnoth 1.12]

Post by Konrad2 » September 8th, 2018, 7:14 am

I guess we could do that?
And it's more like watching out for things that are different in 1.14 compared to 1.12, instead of looking just for bugs (though some of them might be obvious as well).

Well, you go to here, click on 'Clone or Download', click 'Download ZIP', open it with whatever kind of program you use for that, click 'Extract to', look for 'Wesnoth 1.14' (which should be somewhere on your pc xD), 'data', 'addons', click on it and click okay.
Now you do the same thing with this one.

Also, open your addons folder and remove the '-master' from the AtS folder name, also copy the AtS Music folder from 1.12 to 1.14.
Download IftU from the Addon manager on 1.14.
Start playing. xD
I am a Ghost: I drain the life energy from other people to survive and am hated/feared by regular people. Non-regular people don't like me either though.

newfrenchy83
Posts: 42
Joined: October 6th, 2017, 12:57 pm

Re: After the Storm 0.9.17 [Wesnoth 1.12]

Post by newfrenchy83 » September 8th, 2018, 1:44 pm

fr.zip
(382.12 KiB) Downloaded 3 times
translate of ats 97% complwye. 83 chain remain to translate. And sorry for the late

white_haired_uncle
Posts: 35
Joined: August 26th, 2018, 11:46 pm

Re: After the Storm 0.9.17 [Wesnoth 1.12]

Post by white_haired_uncle » September 11th, 2018, 1:18 am

Konrad2 wrote:
September 8th, 2018, 7:14 am
I guess we could do that?
And it's more like watching out for things that are different in 1.14 compared to 1.12, instead of looking just for bugs (though some of them might be obvious as well).

Well, you go to here, click on 'Clone or Download', click 'Download ZIP', open it with whatever kind of program you use for that, click 'Extract to', look for 'Wesnoth 1.14' (which should be somewhere on your pc xD), 'data', 'addons', click on it and click okay.
Now you do the same thing with this one.

Also, open your addons folder and remove the '-master' from the AtS folder name, also copy the AtS Music folder from 1.12 to 1.14.
Download IftU from the Addon manager on 1.14.
Start playing. xD
Sweet! I come looking on the last of a 32 page thread and find exactly what I am hoping, but really not willing to search through 32 pages, for!

Tip for the Linux users, addons are in your home directory under ".local/share/wesnoth/1.14/data/add-ons". Or, if someone changed the defaults, start wesnoth from the command line and look for the "User data directory" and you'll find "add-ons" under that.

Just checked and you have to remove "-master" from "Naia-master" as well.

Unfortunately, the campaign still fails to load....

20180910 21:13:21 warning config: add-on 'After_the_Storm' has no _info.cfg; cannot read version info
Checking lua scripts... ok
20180910 21:13:26 error display: could not open image 'data/add-ons/AFriendshipTested/images/story/campaignicon.png'
20180910 21:13:45 error general: Failed to load the scenario

User avatar
Sadaharu
Posts: 136
Joined: December 13th, 2017, 11:39 pm

Re: After the Storm 0.9.17 [Wesnoth 1.12]

Post by Sadaharu » September 11th, 2018, 3:57 am

I've gotten as far as downloading IftU from the 1.14 addons manager. Tomorrow I'll have to do some hardware repairs.

white_haired_uncle
Posts: 35
Joined: August 26th, 2018, 11:46 pm

Re: After the Storm 0.9.17 [Wesnoth 1.12]

Post by white_haired_uncle » September 11th, 2018, 9:40 am

Sadaharu wrote:
September 8th, 2018, 1:34 am

On the one hand I'd love to contribute and all these years I've learned to like the game enough that I want to do a campaign/story of my own.
As a tester for other games and on other sites I have proven to be very thorough, to a point that unnerved some creators.
Which also means that I myself get burned out a bit when I playtest, rather than merely play, a mod/scenario/campaign.
As a semi-retired IT guy whose RNG is a real SOB, I think I actually enjoy bug hunting more than actual play.

Konrad2
Forum Regular
Posts: 974
Joined: November 24th, 2010, 6:30 pm

Re: After the Storm 0.9.17 [Wesnoth 1.12]

Post by Konrad2 » September 11th, 2018, 3:24 pm

white_haired_uncle wrote:
September 11th, 2018, 1:18 am

20180910 21:13:21 warning config: add-on 'After_the_Storm' has no _info.cfg; cannot read version info
Checking lua scripts... ok
20180910 21:13:26 error display: could not open image 'data/add-ons/AFriendshipTested/images/story/campaignicon.png'
20180910 21:13:45 error general: Failed to load the scenario
No idea why that happened. The info file is one that's automatically generated by wesnoth, so...no idea? Try restarting wesnoth I guess. And make sure that you have 'IftU', 'Naia' and 'AtS Music' in your addons folder, because those should be the dependencies for AtS.

Also, I recommend adding an empty base-maint.cfg file to the AtS folder, otherwise you will get a 'notice' everytime you load a savefile from AtS.

I do have to point out once more, the key to finding bugs is being able to spot differences in the behavior of events between 1.12 and 1.14.
I am a Ghost: I drain the life energy from other people to survive and am hated/feared by regular people. Non-regular people don't like me either though.

white_haired_uncle
Posts: 35
Joined: August 26th, 2018, 11:46 pm

Re: After the Storm 0.9.17 [Wesnoth 1.12]

Post by white_haired_uncle » September 11th, 2018, 7:25 pm

Still seeing the _info.cfg warning, but it doesn't seem to matter. I've tried a number of times, and the campaign will load on normal or hard, but not easy.

I'd never heard of wesnoth before 1.14, but that won't be an issue. Bugs are good at finding me.

white_haired_uncle
Posts: 35
Joined: August 26th, 2018, 11:46 pm

Re: After the Storm 0.9.17 [Wesnoth 1.12]

Post by white_haired_uncle » September 12th, 2018, 2:37 am

Well, I sort of figured it out. After a bit of hunting, I found the logs from working (normal/hard) and not (easy) diverge after a message about translations. After shooting a lot of trouble, I found that if I move one of the translation directories out of the way the problem is fixed. Doesn't matter which one. And once the problem goes away, it goes away for good even including reinstalling AtS. But there is ONE way to recreate it. If I restore my cache directory from last night's backup the issue comes back. All seems 100% repeatable.

So it looks like there was something odd in my cache and when I make any changes in the translation directory it gets corrected or replaced or whatever.

User avatar
Sadaharu
Posts: 136
Joined: December 13th, 2017, 11:39 pm

Re: After the Storm 0.9.17 [Wesnoth 1.12]

Post by Sadaharu » September 13th, 2018, 3:03 am

Sadaharu wrote:
September 11th, 2018, 3:57 am
I've gotten as far as downloading IftU from the 1.14 addons manager. Tomorrow I'll have to do some hardware repairs.
Which, I think, have worked?
white_haired_uncle wrote:
September 11th, 2018, 9:40 am
As a semi-retired IT guy whose RNG is a real SOB, I think I actually enjoy bug hunting more than actual play.
Yes and no… I've already done a lot of reporting and I don't mind helping out, but replaying the entire campaign again (all three -or five! episodes) just after finishing it is not the best course of action, I think.

white_haired_uncle
Posts: 35
Joined: August 26th, 2018, 11:46 pm

Re: After the Storm 0.9.17 [Wesnoth 1.12]

Post by white_haired_uncle » September 13th, 2018, 5:15 am

Running into what might be an issue. [I'll comment on the 5 minute difference between the log messages in a bit].

20180913 00:08:19 error audio: cannot open track 'harp.ogg'; disabled in this playlist.
20180913 00:13:12 error scripting/lua: lua/wml-tags.lua:281: Error: Attempted to access an invalid music track.

stack traceback:

Code: Select all

        [C]: in metamethod '__newindex'
        lua/wml-tags.lua:281: in function <lua/wml-tags.lua:275>
        (...tail calls...)
        ~add-ons/Naia/lua/common.lua:619: in field '?'
        ~add-ons/Naia/lua/patch.lua:220: in local 'cmd'
        lua/wml-utils.lua:145: in field 'handle_event_commands'
        lua/wml-flow.lua:6: in function <lua/wml-flow.lua:5>

Okay, let me start by admitting that I do NOT have the AtS music installed, even though a helpful poster pointed out that it should be just a few posts ago. I poked around trying to find it as part of my troubleshooting, but the closest thing I could find was a comment to copy the files from 1.12. I'm not sure what that means, maybe it's assuming that I once had 1.12 installed? I suppose I could install 1.12 and Ats music and then reinstall/restore 1.14, or fire up a VM, but maybe someone has a better idea?

Normally, I'd ignore this, but the game seems to be in a weird state, as shown by the attached snapshot.

I've also attached the last save file before the error occurs in case it has any value. You have to click through a lot of dialog to get to the next scenario where the error occurs.

I included the message about harp.ogg above because that's the usual message I see when I don't install music packs (I couldn't hear them anyway, since the game is running on a pc in a different room). I did manage to make that error go away by copying silence.ogg to harp.ogg, but I still end up with the wml-tags.lua error. I've never seen a lack of music cause an issue.

I'm also a little curious why it's complaining about music when I have all sounds, including music, disabled under preferences. I doubt this is a AtS issue, but I'm throwing it out there.
Attachments
Screenshot_2018-09-13_00-24-35.png
AtS-1-Quenoth Isle.gz
(11.46 KiB) Downloaded 3 times
Last edited by Pentarctagon on September 13th, 2018, 5:33 am, edited 1 time in total.
Reason: added [code] tags

Konrad2
Forum Regular
Posts: 974
Joined: November 24th, 2010, 6:30 pm

Re: After the Storm 0.9.17 [Wesnoth 1.12]

Post by Konrad2 » September 13th, 2018, 8:41 am

white_haired_uncle wrote:
September 13th, 2018, 5:15 am
Okay, let me start by admitting that I do NOT have the AtS music installed, even though a helpful poster pointed out that it should be just a few posts ago. I poked around trying to find it as part of my troubleshooting, but the closest thing I could find was a comment to copy the files from 1.12. I'm not sure what that means, maybe it's assuming that I once had 1.12 installed? I suppose I could install 1.12 and Ats music and then reinstall/restore 1.14, or fire up a VM, but maybe someone has a better idea?
You can download it here and then extract it to your 1.14 addons folder.
I am a Ghost: I drain the life energy from other people to survive and am hated/feared by regular people. Non-regular people don't like me either though.

white_haired_uncle
Posts: 35
Joined: August 26th, 2018, 11:46 pm

Re: After the Storm 0.9.17 [Wesnoth 1.12]

Post by white_haired_uncle » September 13th, 2018, 9:41 am

Konrad2 wrote:
September 13th, 2018, 8:41 am
white_haired_uncle wrote:
September 13th, 2018, 5:15 am
Okay, let me start by admitting that I do NOT have the AtS music installed, even though a helpful poster pointed out that it should be just a few posts ago. I poked around trying to find it as part of my troubleshooting, but the closest thing I could find was a comment to copy the files from 1.12. I'm not sure what that means, maybe it's assuming that I once had 1.12 installed? I suppose I could install 1.12 and Ats music and then reinstall/restore 1.14, or fire up a VM, but maybe someone has a better idea?
You can download it here and then extract it to your 1.14 addons folder.
Thanks. After installing and playing forward from the save, I got past where I formerly saw the error. It seemed like the game just sort of hung, but then I noticed that the button in the upper right corner of the screen had turned to "End Scenario", and I was able to move forward.

I'd like to see the scenario not get stuck due to lack of music (not all of us can hear after all), and some sort of dialog at the end of that scenario pronouncing the end, but at this point I'm able to continue on and I appreciate your help.

Post Reply