Campaign: Autumn Kingdoms - Prologue (Now v1.6.x Compatible)

Discussion and development of scenarios and campaigns for the game.

Moderators: Forum Moderators, Developers

User avatar
Matthi205
Posts: 75
Joined: March 7th, 2009, 8:32 pm
Location: Neptune

Re: Campaign: Autumn Kingdoms - Prologue (Now v1.6.x Compati

Post by Matthi205 » August 16th, 2012, 8:25 pm

I know that tar isn't an archive format . But it does what it should do: it packs the whole folder into a single file .
"And on his tomb,
an eptitaph:
'Always John,
now always off.'"

Dracostar_A
Posts: 15
Joined: July 2nd, 2011, 3:32 pm

Re: Campaign: Autumn Kingdoms - Prologue (Now v1.6.x Compati

Post by Dracostar_A » August 17th, 2012, 8:41 pm

While the first scenario was generally working, the units' images are failing to appear. I checked the files and though the unit images are present in the file, for me they do not seem to be working in the scenario. If it matters I am using the .tar link provided.

User avatar
Matthi205
Posts: 75
Joined: March 7th, 2009, 8:32 pm
Location: Neptune

Re: Campaign: Autumn Kingdoms - Prologue (Now v1.6.x Compati

Post by Matthi205 » August 18th, 2012, 8:17 pm

Dracostar_A wrote:While the first scenario was generally working, the units' images are failing to appear. I checked the files and though the unit images are present in the file, for me they do not seem to be working in the scenario. If it matters I am using the .tar link provided.
I've had that problem. It's generally caused by the paths in the unit files being wrong . If you are using 1.9 , you should probably change them appropriately. If it helps , I did the porting with 1.10.0 (you're using 1.10.3?) .It seems to work for other people though , so until I fix the bug you could probably download the old zip and only add the files I changed from the tar(Partisan Recruit,Lt.,Com.,Revolutionary unit files & images, scenarios 4&5&6).
"And on his tomb,
an eptitaph:
'Always John,
now always off.'"

User avatar
Celtic_Minstrel
Developer
Posts: 1486
Joined: August 3rd, 2012, 11:26 pm
Location: Canada
Contact:

Re: Campaign: Autumn Kingdoms - Prologue (Now v1.6.x Compati

Post by Celtic_Minstrel » August 19th, 2012, 4:36 am

Matthi205 wrote:I know that tar isn't an archive format . But it does what it should do: it packs the whole folder into a single file .
Which is the definition of an archive format. :P However it does this at the cost of increasing the total size, which is why you normally see it compressed (.tar.gz) instead. It was meant for encoding files onto non-random-access media (ie magnetic tapes), not for distributing packed files across the internet.
Author of The Black Cross of Aleron campaign and Default++ era.
Maintainer of Steelhive.

Groggy_Dice
Inactive Developer
Posts: 165
Joined: February 4th, 2011, 6:19 am
Contact:

Re: Campaign: Autumn Kingdoms - Prologue (Now v1.6.x Compati

Post by Groggy_Dice » August 20th, 2012, 9:08 am

Dracostar_A wrote:While the first scenario was generally working, the units' images are failing to appear. I checked the files and though the unit images are present in the file, for me they do not seem to be working in the scenario. If it matters I am using the .tar link provided.
This bedeviled me the first time I ported a campaign, too. You can't use "~" in the binary path. Replace:

Code: Select all

		path=~add-ons/Autumn_Kingdoms_Prologue/ 
with:

Code: Select all

		path=data/add-ons/Autumn_Kingdoms_Prologue/
Also, you need to get rid of every instance of "../userdata/". So, for instance in your textdomain path:

Code: Select all

	path="../userdata/data/add-ons/Autumn_Kingdoms_Prologue/translations"
	path="data/add-ons/Autumn_Kingdoms_Prologue/translations"
Ports:
Prudence (Josh Roby) | By the Sword (monochromatic) | The Eight of Cembulad (Lintana~ & WYRMY)
Resources:
UMC Timeline (Dec) | List of Unported UMC (Dec) | wmllint++ (Feb)

User avatar
Matthi205
Posts: 75
Joined: March 7th, 2009, 8:32 pm
Location: Neptune

Re: Campaign: Autumn Kingdoms - Prologue (Now v1.6.x Compati

Post by Matthi205 » August 20th, 2012, 7:01 pm

Groggy_Dice wrote:-snip-
Thanks for telling me where the problem was. I'm going to fix it when I get to my own PC (I'm on vacation now).

edit because I don't want to bump this thread: I probably won't be working on the campaign until I get the stupid graphical issue fixed (still having it, Server 2008R2 seems to have its drawbacks after all), so if anybody else wants to take over for the time being, they're welcome to do so (and if you've got a fix for The Purge, PM me). If anything is messed up badly, let me tell you that nearly all of my knowledge of WML comes from editing scenarios around v1.4.
"And on his tomb,
an eptitaph:
'Always John,
now always off.'"

Post Reply